get-ppd-file-for-statically-configured-ipp-shared-queues.patch 919 B

1234567891011121314151617181920212223242526272829303132
  1. Description: Applications could not get the PPD file for
  2. statically-configured IPP-shared print queues
  3. Author: Till Kamppeter <till.kamppeter@gmail.com>
  4. Bug-Upstream: http://cups.org/str.php?L4178
  5. Last-Updated: 2012-09-19
  6. --- a/cups/util.c
  7. +++ b/cups/util.c
  8. @@ -1731,6 +1731,22 @@
  9. return (1);
  10. }
  11. + else if (device_uri &&
  12. + (!strncmp(device_uri, "ipp:", 4) != NULL ||
  13. + !strncmp(device_uri, "ipps:", 5) != NULL))
  14. + {
  15. + /*
  16. + * Statically-configured IPP shared printer.
  17. + */
  18. +
  19. + httpSeparateURI(HTTP_URI_CODING_ALL,
  20. + device_uri,
  21. + scheme, sizeof(scheme), username, sizeof(username),
  22. + host, hostsize, port, resource, resourcesize);
  23. + ippDelete(response);
  24. +
  25. + return (1);
  26. + }
  27. else if ((attr = ippFindAttribute(response, "member-uris",
  28. IPP_TAG_URI)) != NULL)
  29. {