hexyl-0.15.0.ebuild 1.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990
  1. # Copyright 2017-2024 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. CRATES="
  5. aho-corasick@1.1.3
  6. anstream@0.6.17
  7. anstyle@1.0.9
  8. anstyle-parse@0.2.6
  9. anstyle-query@1.1.2
  10. anstyle-wincon@3.0.6
  11. anyhow@1.0.91
  12. assert_cmd@2.0.16
  13. autocfg@1.4.0
  14. bitflags@2.6.0
  15. bstr@1.10.0
  16. clap@4.5.20
  17. clap_builder@4.5.20
  18. clap_derive@4.5.18
  19. clap_lex@0.7.2
  20. colorchoice@1.0.3
  21. const_format@0.2.33
  22. const_format_proc_macros@0.2.33
  23. diff@0.1.13
  24. difflib@0.4.0
  25. doc-comment@0.3.3
  26. errno@0.3.9
  27. float-cmp@0.9.0
  28. heck@0.5.0
  29. is_ci@1.2.0
  30. is_terminal_polyfill@1.70.1
  31. libc@0.2.161
  32. linux-raw-sys@0.4.14
  33. memchr@2.7.4
  34. normalize-line-endings@0.3.0
  35. num-traits@0.2.19
  36. owo-colors@4.1.0
  37. predicates@3.1.2
  38. predicates-core@1.0.8
  39. predicates-tree@1.0.11
  40. pretty_assertions@1.4.1
  41. proc-macro2@1.0.89
  42. quote@1.0.37
  43. regex@1.11.1
  44. regex-automata@0.4.8
  45. regex-syntax@0.8.5
  46. rustix@0.38.38
  47. serde@1.0.214
  48. serde_derive@1.0.214
  49. strsim@0.11.1
  50. supports-color@3.0.1
  51. syn@2.0.85
  52. terminal_size@0.4.0
  53. termtree@0.4.1
  54. thiserror@1.0.65
  55. thiserror-impl@1.0.65
  56. unicode-ident@1.0.13
  57. unicode-xid@0.2.6
  58. utf8parse@0.2.2
  59. wait-timeout@0.2.0
  60. windows-sys@0.52.0
  61. windows-sys@0.59.0
  62. windows-targets@0.52.6
  63. windows_aarch64_gnullvm@0.52.6
  64. windows_aarch64_msvc@0.52.6
  65. windows_i686_gnu@0.52.6
  66. windows_i686_gnullvm@0.52.6
  67. windows_i686_msvc@0.52.6
  68. windows_x86_64_gnu@0.52.6
  69. windows_x86_64_gnullvm@0.52.6
  70. windows_x86_64_msvc@0.52.6
  71. yansi@1.0.1
  72. ${PN}@${PV}
  73. "
  74. inherit cargo
  75. DESCRIPTION="A command-line hex viewer"
  76. HOMEPAGE="https://github.com/sharkdp/hexyl"
  77. SRC_URI="${CARGO_CRATE_URIS}"
  78. LICENSE="|| ( Apache-2.0 MIT )"
  79. # Dependent crate licenses
  80. LICENSE+=" Apache-2.0 ISC MIT Unicode-DFS-2016 ZLIB"
  81. SLOT="0"
  82. KEYWORDS="amd64"
  83. RESTRICT="mirror"