herbe-1.0.0.ebuild 732 B

123456789101112131415161718192021222324252627282930313233343536373839
  1. # Copyright 2021-2023 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. inherit savedconfig
  5. DESCRIPTION="Daemon-less notifications without D-Bus"
  6. HOMEPAGE="https://github.com/dudik/herbe"
  7. SRC_URI="${HOMEPAGE}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
  8. LICENSE="MIT"
  9. SLOT="0"
  10. KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
  11. DEPEND="
  12. x11-libs/libX11
  13. x11-libs/libXft
  14. "
  15. RDEPEND="${DEPEND}"
  16. src_prepare() {
  17. default
  18. sed -i Makefile -e '/^CFLAGS/s/=/+&/' || die
  19. restore_config config.h
  20. }
  21. src_install() {
  22. local DOCS=( README.md )
  23. dobin "${PN}"
  24. save_config config.h
  25. einstalldocs
  26. }