hardware-configuration.nix 485 B

123456789101112131415
  1. { modulesPath, ... }:
  2. {
  3. imports = [ (modulesPath + "/profiles/qemu-guest.nix") ];
  4. boot.loader.grub = {
  5. efiSupport = true;
  6. efiInstallAsRemovable = true;
  7. device = "nodev";
  8. };
  9. fileSystems."/boot" = { device = "/dev/disk/by-uuid/4875-017B"; fsType = "vfat"; };
  10. boot.initrd.availableKernelModules = [ "ata_piix" "uhci_hcd" "xen_blkfront" ];
  11. boot.initrd.kernelModules = [ "nvme" ];
  12. fileSystems."/" = { device = "/dev/mapper/ocivolume-root"; fsType = "xfs"; };
  13. }