edrahil.nix 804 B

123456789101112131415161718192021222324252627282930
  1. { config, pkgs, ... }:
  2. {
  3. imports = [
  4. ./includes/linux-server.nix
  5. ./includes/irssi.nix
  6. ];
  7. # Let Home Manager install and manage itself.
  8. programs.home-manager.enable = true;
  9. # Home Manager needs a bit of information about you and the
  10. # paths it should manage.
  11. home.username = "djm";
  12. home.homeDirectory = "/home/djm";
  13. home.sessionVariables = {
  14. TMUX_AUTO_ATTACH = 1;
  15. };
  16. # This value determines the Home Manager release that your
  17. # configuration is compatible with. This helps avoid breakage
  18. # when a new Home Manager release introduces backwards
  19. # incompatible changes.
  20. #
  21. # You can update Home Manager without changing this value. See
  22. # the Home Manager release notes for a list of state version
  23. # changes in each release.
  24. home.stateVersion = "22.05";
  25. }