.guix.sh 926 B

1234567891011121314151617181920212223242526272829
  1. # Set XDG_DATA_DIRS to the default value before Guix appends to it
  2. #export XDG_DATA_DIRS="${XDG_DATA_DIRS:-/usr/local/share/:/usr/share/}"
  3. #export XDG_DATA_DIRS="$HOME/.guix-profile/share:/usr/local/share/:/usr/share/"
  4. # Arrange so that ~/.config/guix/current paths end up first in
  5. # the particular path list.
  6. for profile in "$HOME/.guix-profile" "$HOME/.config/guix/current"
  7. do
  8. if [ -f "$profile/etc/profile" ]
  9. then
  10. # Load the user profile's settings.
  11. GUIX_PROFILE="$profile" ; \
  12. . "$profile/etc/profile"
  13. else
  14. # At least define this one so that basic things just work
  15. # when the user installs their first package.
  16. export PATH="$profile/bin${PATH:+:$PATH}"
  17. export INFOPATH="$profile/share/info${INFOPATH:+:$INFOPATH}"
  18. fi
  19. done
  20. unset profile
  21. if [ -f "$HOME/.guix-profile/lib/locale" ]
  22. then
  23. export GUIX_LOCPATH=$HOME/.guix-profile/lib/locale
  24. fi