123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171 |
- # Edit this configuration file to define what should be installed on
- # your system. Help is available in the configuration.nix(5) man page, on
- # https://search.nixos.org/options and in the NixOS manual (`nixos-help`).
- { config, lib, pkgs, ... }:
- {
- imports =
- [ # Include the results of the hardware scan and a Lenovo Legion Y530 config from https://github.com/NixOS/nixos-hardware.git.
- <nixos-hardware/lenovo/legion/15ich>
- ./hardware-configuration.nix
- ];
- # Use the Grub2 EFI boot loader.
- boot.loader.grub.device = "nodev";
- boot.loader.grub.efiSupport = true;
- boot.loader.grub.useOSProber = true;
- # Wireless network (add network profile for user)
- networking.hostName = "loki"; # Define your hostname.
- networking.networkmanager.enable = true; # Easiest to use and most distros use this by default.
- # Set your time zone.
- time.timeZone = "Europe/Lisbon";
- # Configure network proxy if necessary
- # networking.proxy.default = "http://user:password@proxy:port/";
- # networking.proxy.noProxy = "127.0.0.1,localhost,internal.domain";
- # Select internationalisation properties.
- i18n.defaultLocale = "pt_PT.UTF-8";
- console = {
- # font = "Lat2-Terminus16";
- keyMap = "es";
- # useXkbConfig = true; # use xkb.options in tty.
- };
- # Enable the X11 windowing system.
- services.xserver.enable = true;
- services.xserver.displayManager.sddm.enable = true;
- services.xserver.desktopManager.plasma5.enable = true;
- # Steam
- programs.steam = {
- enable = true;
- remotePlay.openFirewall = true; # Open ports in the firewall for Steam Remote Play
- dedicatedServer.openFirewall = true; # Open ports in the firewall for Source Dedicated Server
- };
- # Configure keymap in X11
- services.xserver.xkb.layout = "es";
- services.xserver.xkb.options = "eurosign:e,caps:escape";
- # Enable CUPS to print documents.
- services.printing.enable = true;
- # Enable sound.
- sound.enable = true;
- hardware.pulseaudio.enable = true;
- # Enable touchpad support (enabled default in most desktopManager).
- services.xserver.libinput.enable = true;
- # Define a user account. Don't forget to set a password with ‘passwd’.
- users.users.dani77 = {
- isNormalUser = true;
- extraGroups = [ "wheel" "network" ];
- # packages = with pkgs; [ firefox
- # ];
- };
- # Allow unfree packages
- nixpkgs.config.allowUnfree = true;
- # List packages installed in system profile. To search, run:
- #$ nix search wget
- environment.systemPackages = with pkgs; [
- abiword
- bitwarden
- btop
- cmus
- curl
- ethtool
- feh
- firefox
- flashrom
- git
- github-desktop
- gnumeric
- htop
- hunspell
- hunspellDicts.pt_PT
- hw-probe
- inxi
- jstest-gtk
- lutris
- minigalaxy
- minitube
- mpv
- neofetch
- nextcloud-client
- onlykey
- protonup-ng
- protonup-qt
- protontricks
- ranger
- scribus
- smartmontools
- spotify
- steam
- surf
- thunderbird
- vifm
- vim
- wget
- winetricks
- wineWowPackages.stable
- xboxdrv
- youtube-tui
- youtube-dl
- yubioath-flutter
- zathura
- ];
- # Some programs need SUID wrappers, can be configured further or are
- # started in user sessions.
- programs.mtr.enable = true;
- programs.gnupg.agent = {
- enable = true;
- enableSSHSupport = true;
- };
- # List services that you want to enable:
- # Enable the OpenSSH daemon, flatpak and pcscd.
- services.openssh.enable = true;
- services.flatpak.enable = true;
- services.pcscd.enable = true;
- # Open ports in the firewall.
- # networking.firewall.allowedTCPPorts = [ ... ];
- # networking.firewall.allowedUDPPorts = [ ... ];
- # Or disable the firewall altogether.
- # networking.firewall.enable = false;
- # Copy the NixOS configuration file and link it from the resulting system
- # (/run/current-system/configuration.nix). This is useful in case you
- # accidentally delete configuration.nix.
- # system.copySystemConfiguration = true;
- # This option defines the first version of NixOS you have installed on this particular machine,
- # and is used to maintain compatibility with application data (e.g. databases) created on older NixOS versions.
- #
- # Most users should NEVER change this value after the initial install, for any reason,
- # even if you've upgraded your system to a new NixOS release.
- #
- # This value does NOT affect the Nixpkgs version your packages and OS are pulled from,
- # so changing it will NOT upgrade your system.
- #
- # This value being lower than the current NixOS release does NOT mean your system is
- # out of date, out of support, or vulnerable.
- #
- # Do NOT change this value unless you have manually inspected all the changes it would make to your configuration,
- # and migrated your data accordingly.
- #
- # For more information, see `man configuration.nix` or https://nixos.org/manual/nixos/stable/options#opt-system.stateVersion .
- system.stateVersion = "23.11"; # Did you read the comment?
- system.autoUpgrade.enable = true;
- }
|