rules 1.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263
  1. #! /usr/bin/make -f
  2. # debian/rules
  3. # Part of the ‘lojban-common’ package.
  4. #
  5. # Copyright © 2005–2013 Ben Finney <ben+debian@benfinney.id.au>
  6. # This is free software; you may copy, modify, and/or distribute this work
  7. # under the terms of the GNU General Public License, version 3 or later.
  8. # No warranty expressed or implied.
  9. # See the file ‘/usr/share/common-licenses/GPL-3’ for details.
  10. # Packaging variables
  11. PACKAGE_NAME = lojban-common
  12. SHA1SUMS_FILE = debian/upstream.sha1sums
  13. GET_ORIG_SOURCE = $(dir $_)get-orig-source
  14. .PHONY: build
  15. build: build-arch build-indep
  16. dh $@
  17. .PHONY: build-arch
  18. build-arch:
  19. dh $@
  20. .PHONY: build-indep
  21. build-indep:
  22. dh $@
  23. .PHONY: get-orig-source
  24. get-orig-source:
  25. $(GET_ORIG_SOURCE)
  26. .PHONY: clean
  27. clean:
  28. dh $@
  29. .PHONY: install
  30. install: build
  31. cut -d ' ' -f 3 ${SHA1SUMS_FILE} \
  32. | sed -e 's_$$_\tusr/share/lojban_' \
  33. > debian/${PACKAGE_NAME}.install
  34. dh $@
  35. .PHONY: binary-indep
  36. binary-indep: build install
  37. dh $@
  38. .PHONY: binary-arch
  39. binary-arch:
  40. dh $@
  41. .PHONY: binary
  42. binary: binary-indep binary-arch
  43. # Local variables:
  44. # mode: makefile
  45. # coding: utf-8
  46. # End:
  47. # vim: filetype=make fileencoding=utf-8 :