sml.scm 2.7 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2017 Andy Patterson <ajpatter@uwaterloo.ca>
  3. ;;;
  4. ;;; This file is part of GNU Guix.
  5. ;;;
  6. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  7. ;;; under the terms of the GNU General Public License as published by
  8. ;;; the Free Software Foundation; either version 3 of the License, or (at
  9. ;;; your option) any later version.
  10. ;;;
  11. ;;; GNU Guix is distributed in the hope that it will be useful, but
  12. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  13. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  14. ;;; GNU General Public License for more details.
  15. ;;;
  16. ;;; You should have received a copy of the GNU General Public License
  17. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  18. (define-module (gnu packages sml)
  19. #:use-module (gnu packages lesstif)
  20. #:use-module (gnu packages libffi)
  21. #:use-module (gnu packages multiprecision)
  22. #:use-module (gnu packages xorg)
  23. #:use-module (guix build-system gnu)
  24. #:use-module (guix download)
  25. #:use-module ((guix licenses) #:prefix license:)
  26. #:use-module (guix packages))
  27. (define-public polyml
  28. (package
  29. (name "polyml")
  30. (version "5.7")
  31. (source
  32. (origin
  33. (method url-fetch)
  34. (uri (string-append "https://github.com/polyml/polyml/archive/v"
  35. version ".tar.gz"))
  36. (sha256
  37. (base32 "0ycjl746h0m22w9nsdssjl47d56jih12gpkdg3yw65gakj70sd0r"))
  38. (file-name (string-append name "-" version ".tar.gz"))))
  39. (build-system gnu-build-system)
  40. (inputs
  41. `(("gmp" ,gmp)
  42. ("lesstif",lesstif)
  43. ("libffi" ,libffi)
  44. ("libx11" ,libx11)
  45. ("libxt" ,libxt)))
  46. (arguments
  47. '(#:configure-flags
  48. (list "--with-system-libffi=yes"
  49. "--with-x=yes"
  50. "--with-threads=yes"
  51. "--with-gmp=yes")
  52. #:phases
  53. (modify-phases %standard-phases
  54. (add-after 'build 'build-compiler
  55. (lambda* (#:key make-flags parallel-build? #:allow-other-keys)
  56. (define flags
  57. (if parallel-build?
  58. (cons (format #f "-j~d" (parallel-job-count))
  59. make-flags)
  60. make-flags))
  61. (apply system* "make" (append flags (list "compiler"))))))))
  62. (home-page "http://www.polyml.org/")
  63. (synopsis "Standard ML implementation")
  64. (description "Poly/ML is a Standard ML implementation. It is fully
  65. compatible with the ML97 standard. It includes a thread library, a foreign
  66. function interface, and a symbolic debugger.")
  67. ;; Some source files specify 'or any later version'; some don't
  68. (license
  69. (list license:lgpl2.1
  70. license:lgpl2.1+))))