onc-rpc.scm 3.7 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677787980818283848586878889909192939495969798
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2014, 2017 Ludovic Courtès <ludo@gnu.org>
  3. ;;; Copyright © 2016 John Darrington <jmd@gnu.org>
  4. ;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
  5. ;;;
  6. ;;; This file is part of GNU Guix.
  7. ;;;
  8. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  9. ;;; under the terms of the GNU General Public License as published by
  10. ;;; the Free Software Foundation; either version 3 of the License, or (at
  11. ;;; your option) any later version.
  12. ;;;
  13. ;;; GNU Guix is distributed in the hope that it will be useful, but
  14. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  15. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  16. ;;; GNU General Public License for more details.
  17. ;;;
  18. ;;; You should have received a copy of the GNU General Public License
  19. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  20. (define-module (gnu packages onc-rpc)
  21. #:use-module (guix licenses)
  22. #:use-module (guix packages)
  23. #:use-module (guix download)
  24. #:use-module (gnu packages)
  25. #:use-module (gnu packages kerberos)
  26. #:use-module (gnu packages pkg-config)
  27. #:use-module (guix build-system gnu))
  28. (define-public libtirpc
  29. (package
  30. (name "libtirpc")
  31. (version "1.0.1")
  32. (source (origin
  33. (method url-fetch)
  34. (uri (string-append "mirror://sourceforge/libtirpc/libtirpc/"
  35. version "/libtirpc-"
  36. version ".tar.bz2"))
  37. (patches (search-patches "libtirpc-CVE-2017-8779.patch"))
  38. (sha256
  39. (base32
  40. "17mqrdgsgp9m92pmq7bvr119svdg753prqqxmg4cnz5y657rfmji"))))
  41. (build-system gnu-build-system)
  42. (arguments
  43. `(#:phases
  44. (modify-phases %standard-phases
  45. (add-after 'unpack 'remote-dangling-symlink
  46. (lambda _
  47. (substitute* '("man/netconfig.5"
  48. "man/getnetconfig.3t"
  49. "man/getnetpath.3t"
  50. "man/rpc.3t"
  51. "src/getnetconfig.c"
  52. "tirpc/netconfig.h")
  53. (("/etc/netconfig") (string-append %output "/etc/netconfig")))
  54. ;; Remove the dangling symlinks since it breaks the
  55. ;; 'patch-source-shebangs' file tree traversal.
  56. (delete-file "INSTALL"))))))
  57. (inputs `(("mit-krb5" ,mit-krb5)))
  58. (home-page "https://sourceforge.net/projects/libtirpc/")
  59. (synopsis "Transport-independent Sun/ONC RPC implementation")
  60. (description
  61. "This package provides a library that implements the Sun/ONC RPC (remote
  62. procedure calls) protocol in a transport-independent manner. It supports both
  63. IPv4 and IPv6. ONC RPC is notably used by the network file system (NFS).")
  64. (license bsd-3)))
  65. (define-public rpcbind
  66. (package
  67. (name "rpcbind")
  68. (version "0.2.4")
  69. (source
  70. (origin
  71. (method url-fetch)
  72. (uri (string-append "mirror://sourceforge/" name "/" name "/"
  73. version "/"
  74. name "-" version ".tar.bz2"))
  75. (patches (search-patches "rpcbind-CVE-2017-8779.patch"))
  76. (sha256
  77. (base32
  78. "0rjc867mdacag4yqvs827wqhkh27135rp9asj06ixhf71m9rljh7"))))
  79. (build-system gnu-build-system)
  80. (arguments
  81. `(#:configure-flags
  82. `("--with-systemdsystemunitdir=no" "--enable-warmstarts")))
  83. (inputs
  84. `(("libtirpc" ,libtirpc)))
  85. (native-inputs
  86. `(("pkg-config" ,pkg-config)))
  87. (home-page "http://rpcbind.sourceforge.net/")
  88. (synopsis "Server to convert RPC program numbers into universal addresses")
  89. (description
  90. "@command{Rpcbind} is a server that converts RPC program numbers into
  91. universal addresses.")
  92. (license bsd-3)))