nano.scm 2.0 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
  3. ;;; Copyright © 2015, 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
  4. ;;; Copyright © 2016 Rene Saavedra <rennes@openmailbox.org>
  5. ;;;
  6. ;;; This file is part of GNU Guix.
  7. ;;;
  8. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  9. ;;; under the terms of the GNU General Public License as published by
  10. ;;; the Free Software Foundation; either version 3 of the License, or (at
  11. ;;; your option) any later version.
  12. ;;;
  13. ;;; GNU Guix is distributed in the hope that it will be useful, but
  14. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  15. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  16. ;;; GNU General Public License for more details.
  17. ;;;
  18. ;;; You should have received a copy of the GNU General Public License
  19. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  20. (define-module (gnu packages nano)
  21. #:use-module (guix licenses)
  22. #:use-module (gnu packages gettext)
  23. #:use-module (gnu packages ncurses)
  24. #:use-module (guix packages)
  25. #:use-module (guix download)
  26. #:use-module (guix build-system gnu))
  27. (define-public nano
  28. (package
  29. (name "nano")
  30. (version "2.8.7")
  31. (source
  32. (origin
  33. (method url-fetch)
  34. (uri (string-append "mirror://gnu/nano/nano-"
  35. version ".tar.xz"))
  36. (sha256
  37. (base32
  38. "0nhns59smd43mad2w6lnaxqnj4h6ifnlivi6cwydg646jm31gqzv"))))
  39. (build-system gnu-build-system)
  40. (inputs
  41. `(("gettext" ,gettext-minimal)
  42. ("ncurses" ,ncurses)))
  43. (home-page "https://www.nano-editor.org/")
  44. (synopsis "Small, user-friendly console text editor")
  45. (description
  46. "GNU nano is a small and simple text editor for use in a terminal. Besides
  47. basic editing, it supports: undo/redo, syntax highlighting, spell checking,
  48. justifying, auto-indentation, bracket matching, interactive search-and-replace
  49. (with regular expressions), and the editing of multiple files.")
  50. (license gpl3+))) ; some files are under GPLv2+