libupnp.scm 2.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2015 Federico Beffa <beffa@fbengineering.ch>
  3. ;;;
  4. ;;; This file is part of GNU Guix.
  5. ;;;
  6. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  7. ;;; under the terms of the GNU General Public License as published by
  8. ;;; the Free Software Foundation; either version 3 of the License, or (at
  9. ;;; your option) any later version.
  10. ;;;
  11. ;;; GNU Guix is distributed in the hope that it will be useful, but
  12. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  13. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  14. ;;; GNU General Public License for more details.
  15. ;;;
  16. ;;; You should have received a copy of the GNU General Public License
  17. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  18. (define-module (gnu packages libupnp)
  19. #:use-module (gnu packages)
  20. #:use-module (guix licenses)
  21. #:use-module (guix packages)
  22. #:use-module (guix download)
  23. #:use-module (guix build-system gnu))
  24. (define-public libupnp
  25. (package
  26. (name "libupnp")
  27. (version "1.6.21")
  28. (source
  29. (origin
  30. (method url-fetch)
  31. (uri (string-append "mirror://sourceforge/pupnp/pupnp/libUPnP%20"
  32. version "/" name "-" version ".tar.bz2"))
  33. (sha256
  34. (base32
  35. "16x3z6jg1krwyydmbd0z59z5c9x4pniaajmfmnp5pmx18q43qgxg"))))
  36. (build-system gnu-build-system)
  37. (arguments
  38. ;; The tests require a network device capable of multicasting which is
  39. ;; not available in the build environment. See
  40. ;; https://lists.gnu.org/archive/html/guix-devel/2015-01/msg00312.html.
  41. `(#:tests? #f
  42. #:configure-flags '("--enable-ipv6")))
  43. (home-page "http://pupnp.sourceforge.net")
  44. (synopsis "Portable SDK for UPnP Devices")
  45. (description
  46. "The portable SDK for UPnP Devices (libupnp) provides developers with an
  47. API and open source code for building control points, devices, and bridges
  48. that are compliant with Version 1.0 of the Universal Plug and Play Device
  49. Architecture Specification and support several operating systems like Linux,
  50. *BSD, Solaris and others.")
  51. (license bsd-3)))