libunistring.scm 2.6 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2012, 2013, 2014 Ludovic Courtès <ludo@gnu.org>
  3. ;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
  4. ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
  5. ;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
  6. ;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
  7. ;;;
  8. ;;; This file is part of GNU Guix.
  9. ;;;
  10. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  11. ;;; under the terms of the GNU General Public License as published by
  12. ;;; the Free Software Foundation; either version 3 of the License, or (at
  13. ;;; your option) any later version.
  14. ;;;
  15. ;;; GNU Guix is distributed in the hope that it will be useful, but
  16. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  17. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  18. ;;; GNU General Public License for more details.
  19. ;;;
  20. ;;; You should have received a copy of the GNU General Public License
  21. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  22. (define-module (gnu packages libunistring)
  23. #:use-module (guix licenses)
  24. #:use-module (guix packages)
  25. #:use-module (guix download)
  26. #:use-module (guix build-system gnu)
  27. #:use-module (gnu packages)
  28. #:use-module (gnu packages base))
  29. (define-public libunistring
  30. (package
  31. (name "libunistring")
  32. (version "0.9.7")
  33. (source (origin
  34. (method url-fetch)
  35. (uri (string-append
  36. "mirror://gnu/libunistring/libunistring-"
  37. version ".tar.xz"))
  38. (sha256
  39. (base32
  40. "15z76qrmrvkc3c6hfq2lzzqysgd21s682f2smycfab5g598n8drf"))
  41. ;; test-lock has performance issues on multi-core machines,
  42. ;; it hangs or takes a long time to complete.
  43. ;; This is a commit from gnulib to fix this issue.
  44. (patches (search-patches "libunistring-gnulib-multi-core.patch"))))
  45. (propagated-inputs (libiconv-if-needed))
  46. (build-system gnu-build-system)
  47. (arguments
  48. ;; Work around parallel build issue whereby C files may be compiled before
  49. ;; config.h is built: see <http://hydra.gnu.org/build/59381/nixlog/2/raw> and
  50. ;; <http://lists.openembedded.org/pipermail/openembedded-core/2012-April/059850.html>.
  51. '(#:parallel-build? #f))
  52. (synopsis "C library for manipulating Unicode strings")
  53. (description
  54. "GNU libunistring is a library providing functions to manipulate
  55. Unicode strings and for manipulating C strings according to the Unicode
  56. standard.")
  57. (home-page "https://www.gnu.org/software/libunistring/")
  58. (license (list lgpl3+ gpl2))))