inkscape.scm 3.0 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182838485
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2014 John Darrington <jmd@gnu.org>
  3. ;;; Copyright © 2014, 2016 Mark H Weaver <mhw@netris.org>
  4. ;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
  5. ;;;
  6. ;;; This file is part of GNU Guix.
  7. ;;;
  8. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  9. ;;; under the terms of the GNU General Public License as published by
  10. ;;; the Free Software Foundation; either version 3 of the License, or (at
  11. ;;; your option) any later version.
  12. ;;;
  13. ;;; GNU Guix is distributed in the hope that it will be useful, but
  14. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  15. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  16. ;;; GNU General Public License for more details.
  17. ;;;
  18. ;;; You should have received a copy of the GNU General Public License
  19. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  20. (define-module (gnu packages inkscape)
  21. #:use-module ((guix licenses) #:prefix license:)
  22. #:use-module (guix packages)
  23. #:use-module (guix download)
  24. #:use-module (guix utils)
  25. #:use-module (guix build-system cmake)
  26. #:use-module (gnu packages)
  27. #:use-module (gnu packages aspell)
  28. #:use-module (gnu packages bdw-gc)
  29. #:use-module (gnu packages boost)
  30. #:use-module (gnu packages glib)
  31. #:use-module (gnu packages gtk)
  32. #:use-module (gnu packages maths)
  33. #:use-module (gnu packages perl)
  34. #:use-module (gnu packages pdf)
  35. #:use-module (gnu packages popt)
  36. #:use-module (gnu packages python)
  37. #:use-module (gnu packages xml)
  38. #:use-module (gnu packages ghostscript)
  39. #:use-module (gnu packages fontutils)
  40. #:use-module (gnu packages image)
  41. #:use-module (gnu packages pkg-config))
  42. (define-public inkscape
  43. (package
  44. (name "inkscape")
  45. (version "0.92.1")
  46. (source (origin
  47. (method url-fetch)
  48. (uri (string-append "https://media.inkscape.org/dl/"
  49. "resources/file/"
  50. "inkscape-" version ".tar.bz2"))
  51. (sha256
  52. (base32
  53. "01chr3vh728dkg7l7lilwgmh5nrp784khdhjgpqjbq9dh2zhax15"))))
  54. (build-system cmake-build-system)
  55. (inputs
  56. `(("aspell" ,aspell)
  57. ("gtkmm" ,gtkmm-2)
  58. ("gtk" ,gtk+-2)
  59. ("gsl" ,gsl)
  60. ("poppler" ,poppler)
  61. ("libpng" ,libpng)
  62. ("libxml2" ,libxml2)
  63. ("libxslt" ,libxslt)
  64. ("libgc" ,libgc)
  65. ("freetype" ,freetype)
  66. ("popt" ,popt)
  67. ("python" ,python-2)
  68. ("lcms" ,lcms)
  69. ("boost" ,boost)))
  70. (native-inputs
  71. `(("intltool" ,intltool)
  72. ("glib" ,glib "bin")
  73. ("perl" ,perl)
  74. ("pkg-config" ,pkg-config)))
  75. ;; FIXME: tests require gmock
  76. (arguments `(#:tests? #f))
  77. (home-page "http://inkscape.org/")
  78. (synopsis "Vector graphics editor")
  79. (description "Inkscape is a vector graphics editor. What sets Inkscape
  80. apart is its use of Scalable Vector Graphics (SVG), an XML-based W3C standard,
  81. as the native format.")
  82. (license license:gpl2+)))