123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472 |
- ;;; GNU Guix --- Functional package management for GNU
- ;;; Copyright © 2013, 2015 Andreas Enge <andreas@enge.fr>
- ;;; Copyright © 2014 John Darrington <jmd@gnu.org>
- ;;; Copyright © 2015, 2016 Sou Bunnbu <iyzsong@gmail.com>
- ;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
- ;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
- ;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
- ;;;
- ;;; This file is part of GNU Guix.
- ;;;
- ;;; GNU Guix is free software; you can redistribute it and/or modify it
- ;;; under the terms of the GNU General Public License as published by
- ;;; the Free Software Foundation; either version 3 of the License, or (at
- ;;; your option) any later version.
- ;;;
- ;;; GNU Guix is distributed in the hope that it will be useful, but
- ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
- ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- ;;; GNU General Public License for more details.
- ;;;
- ;;; You should have received a copy of the GNU General Public License
- ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
- (define-module (gnu packages gstreamer)
- #:use-module ((guix licenses) #:prefix license:)
- #:use-module (guix packages)
- #:use-module (guix download)
- #:use-module (guix build-system gnu)
- #:use-module (guix utils)
- #:use-module (gnu packages)
- #:use-module (gnu packages audio)
- #:use-module (gnu packages bison)
- #:use-module (gnu packages cdrom)
- #:use-module (gnu packages curl)
- #:use-module (gnu packages compression)
- #:use-module (gnu packages flex)
- #:use-module (gnu packages freedesktop)
- #:use-module (gnu packages gl)
- #:use-module (gnu packages glib)
- #:use-module (gnu packages gnome)
- #:use-module (gnu packages gnupg)
- #:use-module (gnu packages graphics)
- #:use-module (gnu packages gtk)
- #:use-module (gnu packages image)
- #:use-module (gnu packages libusb)
- #:use-module (gnu packages linux)
- #:use-module (gnu packages mp3)
- #:use-module (gnu packages perl)
- #:use-module (gnu packages pulseaudio)
- #:use-module (gnu packages qt)
- #:use-module (gnu packages rdf)
- #:use-module (gnu packages video)
- #:use-module (gnu packages xorg)
- #:use-module (gnu packages xiph)
- #:use-module (gnu packages pkg-config)
- #:use-module (gnu packages python)
- #:use-module (gnu packages ssh)
- #:use-module (gnu packages telephony)
- #:use-module (gnu packages tls)
- #:use-module (gnu packages version-control)
- #:use-module (gnu packages assembly)
- #:use-module (gnu packages xml))
- (define-public orc
- (package
- (name "orc")
- (version "0.4.27")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://gstreamer.freedesktop.org/data/src/"
- "orc/orc-" version ".tar.xz"))
- (sha256
- (base32
- "14vbwdydwarcvswzf744jdjb3ibhv6k4j6hzdacfan41zic3xrai"))))
- (build-system gnu-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'check 'disable-faulty-test
- (lambda _
- ;; XXX Disable the 'test-limits' and 'exec_opcodes_sys'
- ;; tests, which fail on some machines. See:
- ;; https://bugzilla.gnome.org/show_bug.cgi?id=735273
- (substitute* '("testsuite/test-limits.c"
- "testsuite/exec_opcodes_sys.c")
- (("if \\(error\\) return 1;")
- "if (error) return 77;")))))))
- (home-page "http://gstreamer.freedesktop.org/modules/orc.html")
- (synopsis "Oil runtime compiler")
- (description
- "Orc is a just-in-time compiler implemented as a library and set of
- associated tools for compiling and executing simple programs that operate on
- arrays of data.")
- ;; The source code implementing the Marsenne Twister algorithm is licensed
- ;; under the 3-clause BSD license, the rest is under 2-clause BSD license.
- (license (list license:bsd-2 license:bsd-3))))
- (define-public gstreamer
- (package
- (name "gstreamer")
- (version "1.12.3")
- (source
- (origin
- (method url-fetch)
- (uri (string-append
- "https://gstreamer.freedesktop.org/src/gstreamer/gstreamer-"
- version ".tar.xz"))
- (sha256
- (base32
- "0vi1g8rmmsnd630ds3jwv2iph46ll8y07fzf04mz15q88j9g926k"))))
- (build-system gnu-build-system)
- (outputs '("out" "doc"))
- (arguments
- `(#:configure-flags
- (list (string-append "--with-html-dir="
- (assoc-ref %outputs "doc")
- "/share/gtk-doc/html"))))
- (propagated-inputs `(("glib" ,glib))) ; required by gstreamer-1.0.pc.
- (native-inputs
- `(("bison" ,bison)
- ("flex" ,flex)
- ("glib" ,glib "bin")
- ("gobject-introspection" ,gobject-introspection)
- ("perl" ,perl)
- ("pkg-config" ,pkg-config)
- ("python-wrapper" ,python-wrapper)))
- (native-search-paths
- (list (search-path-specification
- (variable "GST_PLUGIN_SYSTEM_PATH")
- (files '("lib/gstreamer-1.0")))))
- (home-page "https://gstreamer.freedesktop.org/")
- (synopsis "Multimedia library")
- (description
- "GStreamer is a library for constructing graphs of media-handling
- components. The applications it supports range from simple Ogg/Vorbis
- playback, audio/video streaming to complex audio mixing and video
- non-linear editing.
- Applications can take advantage of advances in codec and filter technology
- transparently. Developers can add new codecs and filters by writing a
- simple plugin with a clean, generic interface.
- This package provides the core library and elements.")
- (license license:lgpl2.0+)))
- (define-public gst-plugins-base
- (package
- (name "gst-plugins-base")
- (version "1.12.3")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "https://gstreamer.freedesktop.org/src/" name "/"
- name "-" version ".tar.xz"))
- (sha256
- (base32
- "19ffwdch7m777ragmwpy6prqmfb742ym1n3ki40s0zyki627plyk"))))
- (build-system gnu-build-system)
- (outputs '("out" "doc"))
- (propagated-inputs
- `(("gstreamer" ,gstreamer))) ; required by gstreamer-plugins-base-1.0.pc
- (inputs
- `(("cdparanoia" ,cdparanoia)
- ("opus" ,opus)
- ("orc" ,orc)
- ("pango" ,pango)
- ("libogg" ,libogg)
- ("libtheora" ,libtheora)
- ("libvorbis" ,libvorbis)
- ("libx11" ,libx11)
- ("zlib" ,zlib)
- ("libXext" ,libxext)
- ("libxv" ,libxv)
- ("alsa-lib" ,alsa-lib)))
- (native-inputs
- `(("pkg-config" ,pkg-config)
- ("glib" ,glib "bin")
- ("gobject-introspection" ,gobject-introspection)
- ("python-wrapper" ,python-wrapper)))
- (arguments
- `(#:parallel-tests? #f ; 'pipelines/tcp' fails in parallel
- #:configure-flags
- (list (string-append "--with-html-dir="
- (assoc-ref %outputs "doc")
- "/share/gtk-doc/html"))
- #:phases
- (modify-phases %standard-phases
- (add-before 'configure 'patch
- (lambda _
- (substitute* "tests/check/libs/pbutils.c"
- (("/bin/sh") (which "sh")))
- #t)))))
- (home-page "https://gstreamer.freedesktop.org/")
- (synopsis
- "Plugins for the GStreamer multimedia library")
- (description "This package provides an essential exemplary set of plug-ins
- for the GStreamer multimedia library.")
- (license license:lgpl2.0+)))
- (define-public gst-plugins-good
- (package
- (name "gst-plugins-good")
- (version "1.12.3")
- (source
- (origin
- (method url-fetch)
- (uri (string-append
- "https://gstreamer.freedesktop.org/src/" name "/"
- name "-" version ".tar.xz"))
- (sha256
- (base32
- "00sznj1sl97fqpn6j8ngps04clvxp8h8yhw6lvszx4b855wz9rqk"))))
- (build-system gnu-build-system)
- (inputs
- `(("aalib" ,aalib)
- ("cairo" ,cairo)
- ("flac" ,flac)
- ("gdk-pixbuf" ,gdk-pixbuf)
- ("gst-plugins-base" ,gst-plugins-base)
- ("jack" ,jack-1)
- ("libavc1394" ,libavc1394)
- ("libcaca" ,libcaca)
- ("libdv" ,libdv)
- ("libiec61883" ,libiec61883)
- ("libjpeg" ,libjpeg)
- ("libpng" ,libpng)
- ("libshout" ,libshout)
- ("libsoup" ,libsoup)
- ("libvpx" ,libvpx)
- ("orc" ,orc)
- ("pulseaudio" ,pulseaudio)
- ("speex" ,speex)
- ("taglib" ,taglib)
- ("wavpack" ,wavpack)))
- (native-inputs
- `(("glib:bin" ,glib "bin")
- ("pkg-config" ,pkg-config)
- ("python-wrapper" ,python-wrapper)))
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after
- 'unpack 'disable-failing-tests
- (lambda _
- ;; Disable tests that fail non-deterministically.
- ;; This test fails on aarch64 on 1.12.x.
- (substitute* "tests/check/elements/alpha.c"
- (("tcase_add_test \\(tc_chain, test_chromakeying\\);" all)
- (string-append "/* " all " */")))
- #t)))))
- (home-page "https://gstreamer.freedesktop.org/")
- (synopsis
- "Plugins for the GStreamer multimedia library")
- (description "GStreamer Good Plug-ins is a set of plug-ins for the
- GStreamer multimedia library. This set contains those plug-ins which the
- developers consider to have good quality code and correct functionality.")
- (license license:lgpl2.0+)))
- (define-public gst-plugins-bad
- (package
- (name "gst-plugins-bad")
- (version "1.12.3")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://gstreamer.freedesktop.org/src/"
- name "/" name "-" version ".tar.xz"))
- (sha256
- (base32
- "1v5z3i5ha20gmbb3r9dwsaaspv5fm1jfzlzwlzqx1gjj31v5kl1n"))))
- (outputs '("out" "doc"))
- (build-system gnu-build-system)
- (arguments
- '(#:tests? #f ; XXX: 18 of 65 tests fail
- #:configure-flags
- (list (string-append "--with-html-dir="
- (assoc-ref %outputs "doc")
- "/share/gtk-doc/html"))
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-openjpeg-reference
- (lambda _
- ;; Remove hard-coded openjpeg-2.2 path. 2.3 is API- and
- ;; ABI-compatible.
- (substitute* "ext/openjpeg/gstopenjpeg.h"
- (("<openjpeg-2\\.2/") "<openjpeg-2.3/"))
- #t)))))
- (propagated-inputs
- `(("gst-plugins-base" ,gst-plugins-base)))
- (native-inputs
- `(("glib:bin" ,glib "bin") ; for glib-mkenums, etc.
- ("gobject-introspection" ,gobject-introspection)
- ("pkg-config" ,pkg-config)
- ("python" ,python)))
- (inputs
- ;; XXX: The following dependencies are missing:
- ;; vo-amrwbenc, vo-aacenc, bs2b, chromaprint, directfb, daala, libdts,
- ;; faac, flite, libgsm, libde265, libmms, libmimic, mjpegtools,
- ;; mpeg2enc, libofa, opencv, openh264, openni2, libtimemmgr, wildmidi,
- ;; openspc, gme, sbc, schroedinger, zbar, librtmp, spandsp
- `(("bluez" ,bluez)
- ("curl" ,curl)
- ("faad2" ,faad2)
- ("fluidsynth" ,fluidsynth)
- ("gtk+" ,gtk+)
- ("ladspa" ,ladspa)
- ("libass" ,libass)
- ("libdvdnav" ,libdvdnav)
- ("libdvdread" ,libdvdread)
- ("libgcrypt" ,libgcrypt)
- ("libgudev" ,libgudev)
- ("libkate" ,libkate)
- ("libmodplug" ,libmodplug)
- ("librsvg" ,librsvg)
- ("libsndfile" ,libsndfile)
- ("libsrtp" ,libsrtp)
- ("libssh2" ,libssh2)
- ("libusb" ,libusb)
- ("libvdpau" ,libvdpau)
- ("libwebp" ,libwebp)
- ("libxml2" ,libxml2)
- ("lrdf" ,lrdf)
- ("mesa" ,mesa)
- ("mpg123" ,mpg123)
- ("neon" ,neon)
- ("openal" ,openal)
- ("openexr" ,openexr)
- ("openjpeg" ,openjpeg)
- ("openssl" ,openssl)
- ("opus" ,opus)
- ("orc" ,orc)
- ;("qtbase" ,qtbase)
- ;("qtdeclarative" ,qtdeclarative)
- ;("qtx11extras" ,qtx11extras)
- ("soundtouch" ,soundtouch)
- ("x265" ,x265)
- ("wayland" ,wayland)))
- (home-page "https://gstreamer.freedesktop.org/")
- (synopsis "Plugins for the GStreamer multimedia library")
- (description
- "GStreamer Bad Plug-ins is a set of plug-ins whose quality aren't up to
- par compared to the rest.")
- (license license:lgpl2.0+)))
- (define-public gst-plugins-ugly
- (package
- (name "gst-plugins-ugly")
- (version "1.12.3")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "https://gstreamer.freedesktop.org/src/"
- name "/" name "-" version ".tar.xz"))
- (sha256
- (base32
- "0lh00rg26iy5lr5al23lxsyncjqkgzph1bzkrgp8x9sfr62ab378"))))
- (build-system gnu-build-system)
- (inputs
- `(("gst-plugins-base" ,gst-plugins-base)
- ("liba52" ,liba52)
- ("libmad" ,libmad)
- ("lame" ,lame)
- ("libcdio" ,libcdio)
- ("twolame" ,twolame)
- ("libmpeg2" ,libmpeg2)
- ("libdvdread" ,libdvdread)
- ("libx264" ,libx264)
- ("mpg123" ,mpg123)
- ;; TODO:
- ;; * opencore-amr (for the AMR-NB decoder and encoder and the
- ;; AMR-WB decoder) <http://sourceforge.net/projects/opencore-amr/>
- ("orc" ,orc)))
- (native-inputs
- `(("glib:bin" ,glib "bin")
- ("pkg-config" ,pkg-config)
- ("python-wrapper" ,python-wrapper)))
- (home-page "https://gstreamer.freedesktop.org/")
- (synopsis "GStreamer plugins from the \"ugly\" set")
- (description "GStreamer Ugly Plug-ins. This set contains those plug-ins
- which the developers consider to have good quality code but that might pose
- distribution problems in some jurisdictions, e.g. due to patent threats.")
- (license license:lgpl2.0+)))
- (define-public gst-libav
- (package
- (name "gst-libav")
- (version "1.12.3")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "https://gstreamer.freedesktop.org/src/" name "/"
- name "-" version ".tar.xz"))
- (sha256
- (base32
- "0l4nc6ikdx49l7bdrk3bd9p3pzry8a328r22zg48gyzpnv5ghph1"))))
- (build-system gnu-build-system)
- (arguments
- '(#:configure-flags '("--with-system-libav")
- #:phases
- (modify-phases %standard-phases
- (add-before 'configure 'patch-/bin/sh
- (lambda _
- (substitute* "gst-libs/ext/libav/configure"
- (("#! /bin/sh")
- (string-append "#! "(which "sh"))))
- #t)))))
- (native-inputs
- `(("pkg-config" ,pkg-config)
- ("python" ,python)))
- (inputs
- `(("gst-plugins-base" ,gst-plugins-base)
- ("ffmpeg" ,ffmpeg)
- ("orc" ,orc)
- ("zlib" ,zlib)))
- (home-page "http://gstreamer.freedesktop.org/")
- (synopsis "Plugins for the GStreamer multimedia library")
- (description
- "This GStreamer plugin supports a large number of audio and video
- compression formats through the use of the libav library.")
- (license license:gpl2+)))
- (define-public python-gst
- (package
- (name "python-gst")
- (version "1.12.3")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "https://gstreamer.freedesktop.org/src/gst-python/"
- "gst-python-" version ".tar.xz"))
- (sha256
- (base32
- "19rb06x2m7103zwfm0plxx95gb8bp01ng04h4q9k6ii9q7g2kxf3"))))
- (build-system gnu-build-system)
- (arguments
- ;; XXX: Factorize python-sitedir with python-build-system.
- `(#:imported-modules (,@%gnu-build-system-modules
- (guix build python-build-system))
- #:configure-flags
- (let* ((python (assoc-ref %build-inputs "python"))
- (python-version ((@@ (guix build python-build-system)
- get-python-version)
- python))
- (python-sitedir (string-append
- "lib/python" python-version "/site-packages")))
- (list (string-append
- "--with-pygi-overrides-dir=" %output "/" python-sitedir
- "/gi/overrides")))))
- (native-inputs
- `(("pkg-config" ,pkg-config)
- ("python" ,python)))
- (propagated-inputs
- `(("gst-plugins-base" ,gst-plugins-base)
- ("python-pygobject" ,python-pygobject)))
- (home-page "https://gstreamer.freedesktop.org/")
- (synopsis "GStreamer GObject Introspection overrides for Python")
- (description
- "This package contains GObject Introspection overrides for Python that can
- be used by Python applications using GStreamer.")
- (license license:lgpl2.1+)
- (properties `((python2-variant . ,(delay python2-gst))))))
- (define-public python2-gst
- (package (inherit python-gst)
- (name "python2-gst")
- (native-inputs
- `(("pkg-config" ,pkg-config)
- ("python" ,python-2)))
- (propagated-inputs
- `(("gst-plugins-base" ,gst-plugins-base)
- ("python-pygobject" ,python2-pygobject)))))
|