gnuzilla.scm 34 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2013, 2015 Andreas Enge <andreas@enge.fr>
  3. ;;; Copyright © 2013, 2014, 2015, 2016, 2017 Ludovic Courtès <ludo@gnu.org>
  4. ;;; Copyright © 2014, 2015, 2016, 2017 Mark H Weaver <mhw@netris.org>
  5. ;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
  6. ;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
  7. ;;; Copyright © 2016 Alex Griffin <a@ajgrf.com>
  8. ;;; Copyright © 2017 Clément Lassieur <clement@lassieur.org>
  9. ;;; Copyright © 2017 ng0 <ng0@no-reply.pragmatique.xyz>
  10. ;;;
  11. ;;; This file is part of GNU Guix.
  12. ;;;
  13. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  14. ;;; under the terms of the GNU General Public License as published by
  15. ;;; the Free Software Foundation; either version 3 of the License, or (at
  16. ;;; your option) any later version.
  17. ;;;
  18. ;;; GNU Guix is distributed in the hope that it will be useful, but
  19. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  20. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  21. ;;; GNU General Public License for more details.
  22. ;;;
  23. ;;; You should have received a copy of the GNU General Public License
  24. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  25. (define-module (gnu packages gnuzilla)
  26. #:use-module ((srfi srfi-1) #:hide (zip))
  27. #:use-module (ice-9 match)
  28. #:use-module (gnu packages)
  29. #:use-module ((guix licenses) #:prefix license:)
  30. #:use-module (guix packages)
  31. #:use-module (guix download)
  32. #:use-module (guix utils)
  33. #:use-module (guix build-system gnu)
  34. #:use-module (gnu packages autotools)
  35. #:use-module (gnu packages base)
  36. #:use-module (gnu packages databases)
  37. #:use-module (gnu packages glib)
  38. #:use-module (gnu packages gtk)
  39. #:use-module (gnu packages gnome)
  40. #:use-module (gnu packages libcanberra)
  41. #:use-module (gnu packages cups)
  42. #:use-module (gnu packages kerberos)
  43. #:use-module (gnu packages linux)
  44. #:use-module (gnu packages perl)
  45. #:use-module (gnu packages pkg-config)
  46. #:use-module (gnu packages compression)
  47. #:use-module (gnu packages fontutils)
  48. #:use-module (gnu packages libevent)
  49. #:use-module (gnu packages libreoffice) ;for hunspell
  50. #:use-module (gnu packages image)
  51. #:use-module (gnu packages libffi)
  52. #:use-module (gnu packages pulseaudio)
  53. #:use-module (gnu packages python)
  54. #:use-module (gnu packages xorg)
  55. #:use-module (gnu packages gl)
  56. #:use-module (gnu packages assembly)
  57. #:use-module (gnu packages icu4c)
  58. #:use-module (gnu packages video)
  59. #:use-module (gnu packages xdisorg)
  60. #:use-module (gnu packages readline))
  61. (define-public mozjs
  62. (package
  63. (name "mozjs")
  64. (version "17.0.0")
  65. (source (origin
  66. (method url-fetch)
  67. (uri (string-append
  68. "https://ftp.mozilla.org/pub/mozilla.org/js/"
  69. name version ".tar.gz"))
  70. (sha256
  71. (base32
  72. "1fig2wf4f10v43mqx67y68z6h77sy900d1w0pz9qarrqx57rc7ij"))
  73. (patches (search-patches "mozjs17-aarch64-support.patch"))
  74. (modules '((guix build utils)))
  75. (snippet
  76. ;; Fix incompatibility with Perl 5.22+.
  77. '(substitute* '("js/src/config/milestone.pl")
  78. (("defined\\(@TEMPLATE_FILE)") "@TEMPLATE_FILE")))))
  79. (build-system gnu-build-system)
  80. (native-inputs
  81. `(("perl" ,perl)
  82. ("pkg-config" ,pkg-config)
  83. ("python" ,python-2)))
  84. (propagated-inputs
  85. `(("nspr" ,nspr))) ; in the Requires.private field of mozjs-17.0.pc
  86. (inputs
  87. `(("zlib" ,zlib)))
  88. (arguments
  89. `(;; XXX: parallel build fails, lacking:
  90. ;; mkdir -p "system_wrapper_js/"
  91. #:parallel-build? #f
  92. #:phases
  93. (modify-phases %standard-phases
  94. (add-after 'unpack 'delete-timedout-test
  95. ;; This test times out on slower hardware.
  96. (lambda _ (delete-file "js/src/jit-test/tests/basic/bug698584.js")))
  97. (add-before 'configure 'chdir
  98. (lambda _
  99. (chdir "js/src")
  100. #t))
  101. (replace 'configure
  102. ;; configure fails if it is followed by SHELL and CONFIG_SHELL
  103. (lambda* (#:key outputs #:allow-other-keys)
  104. (let ((out (assoc-ref outputs "out")))
  105. (setenv "SHELL" (which "sh"))
  106. (setenv "CONFIG_SHELL" (which "sh"))
  107. (zero? (system*
  108. "./configure" (string-append "--prefix=" out)
  109. ,@(if (string=? "aarch64-linux"
  110. (%current-system))
  111. '("--host=aarch64-unknown-linux-gnu")
  112. '())))))))))
  113. (home-page
  114. "https://developer.mozilla.org/en-US/docs/Mozilla/Projects/SpiderMonkey")
  115. (synopsis "Mozilla javascript engine")
  116. (description "SpiderMonkey is Mozilla's JavaScript engine written
  117. in C/C++.")
  118. (license license:mpl2.0))) ; and others for some files
  119. (define-public mozjs-24
  120. (package (inherit mozjs)
  121. (name "mozjs")
  122. (version "24.2.0")
  123. (source (origin
  124. (method url-fetch)
  125. (uri (string-append
  126. "https://ftp.mozilla.org/pub/mozilla.org/js/"
  127. name "-" version ".tar.bz2"))
  128. (sha256
  129. (base32
  130. "1n1phk8r3l8icqrrap4czplnylawa0ddc2cc4cgdz46x3lrkybz6"))
  131. (modules '((guix build utils)))
  132. (patches (search-patches "mozjs24-aarch64-support.patch"))
  133. (snippet
  134. ;; Fix incompatibility with Perl 5.22+.
  135. '(substitute* '("js/src/config/milestone.pl")
  136. (("defined\\(@TEMPLATE_FILE)") "@TEMPLATE_FILE")))))
  137. (arguments
  138. (substitute-keyword-arguments (package-arguments mozjs)
  139. ((#:phases phases)
  140. `(modify-phases ,phases
  141. (replace 'configure
  142. (lambda* (#:key outputs #:allow-other-keys)
  143. (let ((out (assoc-ref outputs "out")))
  144. ;; configure fails if it is followed by SHELL and CONFIG_SHELL
  145. (setenv "SHELL" (which "sh"))
  146. (setenv "CONFIG_SHELL" (which "sh"))
  147. (zero? (system* "./configure"
  148. (string-append "--prefix=" out)
  149. "--with-system-nspr"
  150. "--enable-system-ffi"
  151. "--enable-threadsafe"
  152. ,@(if (string=? "aarch64-linux"
  153. (%current-system))
  154. '("--host=aarch64-unknown-linux-gnu")
  155. '()))))))))))
  156. (inputs
  157. `(("libffi" ,libffi)
  158. ("zlib" ,zlib)))))
  159. (define-public mozjs-38
  160. (package
  161. (inherit mozjs)
  162. (name "mozjs")
  163. (version "38.2.1.rc0")
  164. (source (origin
  165. (method url-fetch)
  166. (uri (string-append
  167. "https://people.mozilla.org/~sstangl/"
  168. name "-" version ".tar.bz2"))
  169. (sha256
  170. (base32
  171. "0p4bmbpgkfsj54xschcny0a118jdrdgg0q29rwxigg3lh5slr681"))
  172. (patches
  173. (search-patches
  174. ;; See https://bugzilla.mozilla.org/show_bug.cgi?id=1269317 for
  175. ;; GCC 6 compatibility.
  176. "mozjs38-version-detection.patch" ; for 0ad
  177. "mozjs38-tracelogger.patch"
  178. ;; See https://bugzilla.mozilla.org/show_bug.cgi?id=1339931.
  179. "mozjs38-pkg-config-version.patch"
  180. "mozjs38-shell-version.patch"))
  181. (modules '((guix build utils)))
  182. (snippet
  183. '(begin
  184. ;; Fix incompatibility with sed 4.4.
  185. (substitute* "js/src/configure"
  186. (("\\^\\[:space:\\]") "^[[:space:]]"))
  187. ;; The headers are symlinks to files that are in /tmp, so they
  188. ;; end up broken. Copy them instead.
  189. (substitute*
  190. "python/mozbuild/mozbuild/backend/recursivemake.py"
  191. (("\\['dist_include'\\].add_symlink")
  192. "['dist_include'].add_copy"))
  193. ;; Remove bundled libraries.
  194. (for-each delete-file-recursively
  195. '("intl"
  196. "js/src/ctypes/libffi"
  197. "js/src/ctypes/libffi-patches"
  198. "modules/zlib"))
  199. #t))))
  200. (arguments
  201. `(;; XXX: parallel build fails, lacking:
  202. ;; mkdir -p "system_wrapper_js/"
  203. #:parallel-build? #f
  204. ;; See https://bugzilla.mozilla.org/show_bug.cgi?id=1008470.
  205. #:tests? #f
  206. #:phases
  207. (modify-phases %standard-phases
  208. (replace 'configure
  209. (lambda* (#:key outputs #:allow-other-keys)
  210. (let ((out (assoc-ref outputs "out")))
  211. (chdir "js/src")
  212. (setenv "SHELL" (which "sh"))
  213. (setenv "CONFIG_SHELL" (which "sh"))
  214. (zero? (system* "./configure"
  215. (string-append "--prefix=" out)
  216. "--enable-ctypes"
  217. "--enable-gcgenerational"
  218. "--enable-optimize"
  219. "--enable-pie"
  220. "--enable-readline"
  221. "--enable-shared-js"
  222. "--enable-system-ffi"
  223. "--enable-threadsafe"
  224. "--enable-xterm-updates"
  225. "--with-system-icu"
  226. "--with-system-nspr"
  227. "--with-system-zlib"
  228. ;; Intl API requires bundled ICU.
  229. "--without-intl-api"))))))))
  230. (native-inputs
  231. `(("perl" ,perl)
  232. ("pkg-config" ,pkg-config)
  233. ("python-2" ,python-2)))
  234. (inputs
  235. `(("libffi" ,libffi)
  236. ("readline" ,readline)
  237. ("icu4c" ,icu4c)
  238. ("zlib" ,zlib)))))
  239. (define-public nspr
  240. (package
  241. (name "nspr")
  242. (version "4.17")
  243. (source (origin
  244. (method url-fetch)
  245. (uri (string-append
  246. "https://ftp.mozilla.org/pub/mozilla.org/nspr/releases/v"
  247. version "/src/nspr-" version ".tar.gz"))
  248. (sha256
  249. (base32
  250. "158hdn285dsb5rys8wl1wi32dd1axwhqq0r8fwny4aj157m0l2jr"))))
  251. (build-system gnu-build-system)
  252. (native-inputs
  253. `(("perl" ,perl)))
  254. (arguments
  255. `(#:tests? #f ; no check target
  256. #:configure-flags (list "--enable-64bit"
  257. (string-append "LDFLAGS=-Wl,-rpath="
  258. (assoc-ref %outputs "out")
  259. "/lib"))
  260. #:phases (modify-phases %standard-phases
  261. (add-before 'configure 'chdir
  262. (lambda _ (chdir "nspr") #t)))))
  263. (home-page
  264. "https://developer.mozilla.org/en-US/docs/Mozilla/Projects/NSPR")
  265. (synopsis "Netscape API for system level and libc-like functions")
  266. (description "Netscape Portable Runtime (NSPR) provides a
  267. platform-neutral API for system level and libc-like functions. It is used
  268. in the Mozilla clients.")
  269. (license license:mpl2.0)))
  270. (define-public nss
  271. (package
  272. (name "nss")
  273. (version "3.33")
  274. (source (origin
  275. (method url-fetch)
  276. (uri (let ((version-with-underscores
  277. (string-join (string-split version #\.) "_")))
  278. (string-append
  279. "https://ftp.mozilla.org/pub/mozilla.org/security/nss/"
  280. "releases/NSS_" version-with-underscores "_RTM/src/"
  281. "nss-" version ".tar.gz")))
  282. (sha256
  283. (base32
  284. "1r44qa4j7sri50mxxbnrpm6fxprwrhv76whi7bfq73j06syxmw4q"))
  285. ;; Create nss.pc and nss-config.
  286. (patches (search-patches "nss-pkgconfig.patch"
  287. "nss-increase-test-timeout.patch"))))
  288. (build-system gnu-build-system)
  289. (outputs '("out" "bin"))
  290. (arguments
  291. `(#:parallel-build? #f ; not supported
  292. #:make-flags
  293. (let* ((out (assoc-ref %outputs "out"))
  294. (nspr (string-append (assoc-ref %build-inputs "nspr")))
  295. (rpath (string-append "-Wl,-rpath=" out "/lib/nss")))
  296. (list "-C" "nss" (string-append "PREFIX=" out)
  297. "NSDISTMODE=copy"
  298. "NSS_USE_SYSTEM_SQLITE=1"
  299. (string-append "NSPR_INCLUDE_DIR=" nspr "/include/nspr")
  300. ;; Add $out/lib/nss to RPATH.
  301. (string-append "RPATH=" rpath)
  302. (string-append "LDFLAGS=" rpath)))
  303. #:modules ((guix build gnu-build-system)
  304. (guix build utils)
  305. (ice-9 ftw)
  306. (ice-9 match)
  307. (srfi srfi-26))
  308. #:phases
  309. (modify-phases %standard-phases
  310. (replace 'configure
  311. (lambda _
  312. (setenv "CC" "gcc")
  313. ;; Tells NSS to build for the 64-bit ABI if we are 64-bit system.
  314. ,@(match (%current-system)
  315. ((or "x86_64-linux" "aarch64-linux")
  316. `((setenv "USE_64" "1")))
  317. (_
  318. '()))
  319. #t))
  320. (replace 'check
  321. (lambda _
  322. ;; Use 127.0.0.1 instead of $HOST.$DOMSUF as HOSTADDR for testing.
  323. ;; The later requires a working DNS or /etc/hosts.
  324. (setenv "DOMSUF" "(none)")
  325. (setenv "USE_IP" "TRUE")
  326. (setenv "IP_ADDRESS" "127.0.0.1")
  327. (zero? (system* "./nss/tests/all.sh"))))
  328. (replace 'install
  329. (lambda* (#:key outputs #:allow-other-keys)
  330. (let* ((out (assoc-ref outputs "out"))
  331. (bin (string-append (assoc-ref outputs "bin") "/bin"))
  332. (inc (string-append out "/include/nss"))
  333. (lib (string-append out "/lib/nss"))
  334. (obj (match (scandir "dist" (cut string-suffix? "OBJ" <>))
  335. ((obj) (string-append "dist/" obj)))))
  336. ;; Install nss-config to $out/bin.
  337. (install-file (string-append obj "/bin/nss-config")
  338. (string-append out "/bin"))
  339. (delete-file (string-append obj "/bin/nss-config"))
  340. ;; Install nss.pc to $out/lib/pkgconfig.
  341. (install-file (string-append obj "/lib/pkgconfig/nss.pc")
  342. (string-append out "/lib/pkgconfig"))
  343. (delete-file (string-append obj "/lib/pkgconfig/nss.pc"))
  344. (rmdir (string-append obj "/lib/pkgconfig"))
  345. ;; Install other files.
  346. (copy-recursively "dist/public/nss" inc)
  347. (copy-recursively (string-append obj "/bin") bin)
  348. (copy-recursively (string-append obj "/lib") lib)
  349. ;; FIXME: libgtest1.so is installed in the above step, and it's
  350. ;; (unnecessarily) linked with several NSS libraries, but
  351. ;; without the needed rpaths, causing the 'validate-runpath'
  352. ;; phase to fail. Here we simply delete libgtest1.so, since it
  353. ;; seems to be used only during the tests.
  354. (delete-file (string-append lib "/libgtest1.so"))
  355. (delete-file (string-append lib "/libgtestutil.so"))
  356. #t))))))
  357. (inputs
  358. `(("sqlite" ,sqlite)
  359. ("zlib" ,zlib)))
  360. (propagated-inputs `(("nspr" ,nspr))) ; required by nss.pc.
  361. (native-inputs `(("perl" ,perl)))
  362. ;; The NSS test suite takes around 48 hours on Loongson 3A (MIPS) when
  363. ;; another build is happening concurrently on the same machine.
  364. (properties '((timeout . 216000))) ; 60 hours
  365. (home-page
  366. "https://developer.mozilla.org/en-US/docs/Mozilla/Projects/NSS")
  367. (synopsis "Network Security Services")
  368. (description
  369. "Network Security Services (NSS) is a set of libraries designed to support
  370. cross-platform development of security-enabled client and server applications.
  371. Applications built with NSS can support SSL v2 and v3, TLS, PKCS #5, PKCS #7,
  372. PKCS #11, PKCS #12, S/MIME, X.509 v3 certificates, and other security
  373. standards.")
  374. (license license:mpl2.0)))
  375. (define (mozilla-patch file-name changeset hash)
  376. "Return an origin for CHANGESET from the mozilla-esr52 repository."
  377. (origin
  378. (method url-fetch)
  379. (uri (string-append "https://hg.mozilla.org/releases/mozilla-esr52/raw-rev/"
  380. changeset))
  381. (sha256 (base32 hash))
  382. (file-name file-name)))
  383. (define-public icecat
  384. (package
  385. (name "icecat")
  386. (version "52.3.0-gnu1")
  387. (source
  388. (origin
  389. (method url-fetch)
  390. (uri (string-append "mirror://gnu/gnuzilla/"
  391. (first (string-split version #\-))
  392. "/" name "-" version ".tar.bz2"))
  393. (sha256
  394. (base32
  395. "00jki754d6310fxj1b7dbhqj69y5igck6gqg6rgfya243nsb56k9"))
  396. (patches
  397. (list
  398. (search-patch "icecat-avoid-bundled-libraries.patch")
  399. (mozilla-patch "icecat-bug-546387.patch" "d13e3fefb76e" "1b760r0bg2ydbl585wlmajljh1nlisrwxvjws5b28a3sgjy01i6k")
  400. (mozilla-patch "icecat-bug-1350152.patch" "f822bda79c28" "1wf56169ca874shr6r7qx40s17h2gwj7ngmpyylrpmd1c6hipvsj")
  401. (mozilla-patch "icecat-bug-1388166.patch" "fbb0bdb191d5" "1y8wpj38vw1dd6f375s9i0mrk9bd8z8gz5g70p4qynfllpkn072d")
  402. (mozilla-patch "icecat-CVE-2017-7810-pt1.patch" "fbddb5cdd3c7" "0k5nyl2z1y2rx9fwqyfj64678yv6v3pnmshgk552pbzqmaf8i1hq")
  403. (mozilla-patch "icecat-CVE-2017-7810-pt2.patch" "76c25987a275" "095b9vwsiza9ikbnnppfcld16h75x5bxjfxc73913y04n0i42ifh")
  404. (mozilla-patch "icecat-CVE-2017-7810-pt3.patch" "32eec29a85a5" "057simakqg56jvas1wkskg5kszn96m74nca26x08d5w7rzmbv1q2")
  405. (mozilla-patch "icecat-bug-1373222.patch" "ecef71fa933f" "0vsymgy5j702lamvh2riahni7rdj9ba3bd6i4a2m22d638rwp1i2")
  406. (mozilla-patch "icecat-CVE-2017-7814.patch" "68a444daf85b" "1faaadaajidzb9i00710zxdyv370hlrdg1l5rw2ymfmzbjj4jqyd")
  407. (mozilla-patch "icecat-bug-1376825.patch" "eeeec9cafc4e" "188qf6zi9kyxb33330yia6wmrd5mdyqn5hr1cl38zy7m3akv8srh")
  408. (mozilla-patch "icecat-bug-1385272.patch" "d68fa12fbffc" "13gh97vz9n2b7303jcvr1072iy8bghy9chvbmxzvw82prvkscavw")
  409. (mozilla-patch "icecat-bug-1390002.patch" "c24e6fc9f689" "0aswhy5fz2f6wzd5j5gg3nqvz707ip344089h2z2chcp146vxmf4")
  410. (mozilla-patch "icecat-CVE-2017-7810-pt4.patch" "ae110cf77596" "0gdrkfq9wy9cfcdgbj14ci86xgh2prkbz69pfy97r9igd8059syw")
  411. (mozilla-patch "icecat-CVE-2017-7810-pt5.patch" "b8417112486d" "1hya6lccz7vm51v4f6ww072794cwzmfn9xhxmvrnqbiyspxx5fz4")
  412. (mozilla-patch "icecat-bug-1386905.patch" "badbf4308211" "0fj1pyjqfdsbrlfykwmkzav2nvdj1f4grwq3cal9f7ay6wjnfs9b")
  413. (mozilla-patch "icecat-CVE-2017-7810-pt6.patch" "d78675515c78" "03w5hqy40xkckbaf5bm9kdbdqvp9ffvpk9mlrc9lja6b7qa4pjhg")
  414. (mozilla-patch "icecat-bug-1382303.patch" "f01155fe4d54" "0hnz1kvmvspg6453kydsklbvrjgzn8x3djvrym3f2xl2yinaf90d")
  415. (mozilla-patch "icecat-bug-1393467.patch" "4eec2a60622c" "1h006mwcsagq7mz7haymwgr7fn4zj14n5lxbjcmhdqrxdvma2hjj")
  416. (mozilla-patch "icecat-bug-1384801.patch" "9556e792f905" "0i74r807189s8i78483caiifw68cn7fs543i4cys6k3gn12dhhjy")
  417. (mozilla-patch "icecat-CVE-2017-7823.patch" "bd284765b5bc" "1c4hss87kc4qwx30magbqczm9h7zmwirjfc8zimqbrnwv9bbsfh3")
  418. (mozilla-patch "icecat-CVE-2017-7805.patch" "113da8d46aa4" "1vy0lw659mwixmb57mgybga152rdwqd5zj1g7nfw1zgp15pfwr75")
  419. (mozilla-patch "icecat-bug-1376399.patch" "58a574502ca9" "1zmg91pg0s5nwngc32a4fywidvxyaayvx1h052fsv0i4cfm16l9v")
  420. (mozilla-patch "icecat-bug-1396570.patch" "24db61862c54" "0af1jjfma042xvn0xhgims1yvb2b51nhn4m0pcfwg3fn0llmka03")
  421. (mozilla-patch "icecat-CVE-2017-7819.patch" "1a02f11c6efe" "18a9qvdvrqw34qw3lljg6gkn358jl23lyimhmbc964023rhs36sz")
  422. (mozilla-patch "icecat-CVE-2017-7810-pt7.patch" "002686d9536f" "065g0d759wfiaj69b1sqg7l08p2knc0q9m9hvkgwwsf0r78xcbjj")
  423. (mozilla-patch "icecat-CVE-2017-7810-pt8.patch" "eaadb31758d8" "0b3k3la6ykac5mbp9gyqqgjbmj19vx9sl1b0wp387qar0p12nyaz")
  424. (mozilla-patch "icecat-bug-1368269.patch" "0cff5e66e0f4" "0jb0wqi7c0ih4441s1908j6gv18v4inh7k2w47h3c9nhz4rgyrw7")
  425. (mozilla-patch "icecat-CVE-2017-7793.patch" "6ff3c82962f0" "0bw82034kdmrpznigbavzzsiybzrw8giyf8v0z2cxf6mwl72bf9k")
  426. (mozilla-patch "icecat-bug-1400399.patch" "d6f78b1349b7" "0i3gwr2al3xl65yfa3nimvy8dp0jzpx21f6bjw18xwn7zkkh9j54")
  427. (mozilla-patch "icecat-bug-1400721.patch" "285cde398833" "0a1i32zl30wfyw7zkqj595s94n6wdlg5c495m0910pd05pjg3qam")))
  428. (modules '((guix build utils)))
  429. (snippet
  430. '(begin
  431. (use-modules (ice-9 ftw))
  432. ;; Remove bundled libraries that we don't use, since they may
  433. ;; contain unpatched security flaws, they waste disk space and
  434. ;; network bandwidth, and may cause confusion.
  435. (for-each delete-file-recursively
  436. '(;; FIXME: Removing the bundled icu breaks configure.
  437. ;; * The bundled icu headers are used in some places.
  438. ;; * The version number is taken from the bundled copy.
  439. ;;"intl/icu"
  440. ;;
  441. ;; FIXME: A script from the bundled nspr is used.
  442. ;;"nsprpub"
  443. ;;
  444. ;; TODO: Use system media libraries. Waiting for:
  445. ;; <https://bugzilla.mozilla.org/show_bug.cgi?id=517422>
  446. ;; * libogg
  447. ;; * libtheora
  448. ;; * libvorbis
  449. ;; * libtremor (not yet in guix)
  450. ;; * libopus
  451. ;; * speex
  452. ;; * soundtouch (not yet in guix)
  453. ;;
  454. ;; TODO: Use system harfbuzz. Waiting for:
  455. ;; <https://bugzilla.mozilla.org/show_bug.cgi?id=847568>
  456. ;;
  457. ;; TODO: Use system graphite2.
  458. ;;
  459. "modules/freetype2"
  460. "modules/zlib"
  461. "modules/libbz2"
  462. "ipc/chromium/src/third_party/libevent"
  463. "media/libjpeg"
  464. "media/libvpx"
  465. "security/nss"
  466. "gfx/cairo"
  467. "js/src/ctypes/libffi"
  468. "db/sqlite3"))
  469. ;; Delete .pyc files, typically present in icecat source tarballs
  470. (for-each delete-file (find-files "." "\\.pyc$"))
  471. ;; Delete obj-* directories, sometimes present in icecat tarballs
  472. (for-each delete-file-recursively
  473. (scandir "." (lambda (name)
  474. (string-prefix? "obj-" name))))
  475. #t))))
  476. (build-system gnu-build-system)
  477. (inputs
  478. `(("alsa-lib" ,alsa-lib)
  479. ("bzip2" ,bzip2)
  480. ("cairo" ,cairo)
  481. ("cups" ,cups)
  482. ("dbus-glib" ,dbus-glib)
  483. ("gdk-pixbuf" ,gdk-pixbuf)
  484. ("glib" ,glib)
  485. ("gtk+" ,gtk+)
  486. ("gtk+-2" ,gtk+-2)
  487. ("pango" ,pango)
  488. ("freetype" ,freetype)
  489. ("hunspell" ,hunspell)
  490. ("libcanberra" ,libcanberra)
  491. ("libgnome" ,libgnome)
  492. ("libjpeg-turbo" ,libjpeg-turbo)
  493. ("libxft" ,libxft)
  494. ("libevent" ,libevent-2.0)
  495. ("libxinerama" ,libxinerama)
  496. ("libxscrnsaver" ,libxscrnsaver)
  497. ("libxcomposite" ,libxcomposite)
  498. ("libxt" ,libxt)
  499. ("libffi" ,libffi)
  500. ("ffmpeg" ,ffmpeg)
  501. ("libvpx" ,libvpx)
  502. ("icu4c" ,icu4c)
  503. ("pixman" ,pixman)
  504. ("pulseaudio" ,pulseaudio)
  505. ("mesa" ,mesa)
  506. ("mit-krb5" ,mit-krb5)
  507. ("nspr" ,nspr)
  508. ("nss" ,nss)
  509. ("sqlite" ,sqlite)
  510. ("startup-notification" ,startup-notification)
  511. ("unzip" ,unzip)
  512. ("zip" ,zip)
  513. ("zlib" ,zlib)))
  514. (native-inputs
  515. `(("perl" ,perl)
  516. ("python" ,python-2) ; Python 3 not supported
  517. ("python2-pysqlite" ,python2-pysqlite)
  518. ("yasm" ,yasm)
  519. ("pkg-config" ,pkg-config)
  520. ("autoconf" ,autoconf-2.13)
  521. ("which" ,which)))
  522. (arguments
  523. `(#:tests? #f ; no check target
  524. #:out-of-source? #t ; must be built outside of the source directory
  525. ;; XXX: There are RUNPATH issues such as
  526. ;; $prefix/lib/icecat-31.6.0/plugin-container NEEDing libmozalloc.so,
  527. ;; which is not in its RUNPATH, but they appear to be harmless in
  528. ;; practice somehow. See <http://hydra.gnu.org/build/378133>.
  529. #:validate-runpath? #f
  530. #:configure-flags '("--enable-default-toolkit=cairo-gtk3"
  531. "--enable-gio"
  532. "--enable-startup-notification"
  533. "--enable-pulseaudio"
  534. "--disable-gconf"
  535. "--disable-gnomeui"
  536. ;; Building with debugging symbols takes ~5GiB, so
  537. ;; disable it.
  538. "--disable-debug"
  539. "--disable-debug-symbols"
  540. ;; Hack to work around missing
  541. ;; "unofficial" branding in icecat.
  542. "--enable-official-branding"
  543. ;; Avoid bundled libraries.
  544. "--with-system-zlib"
  545. "--with-system-bz2"
  546. "--with-system-jpeg" ; must be libjpeg-turbo
  547. "--with-system-libevent"
  548. "--with-system-libvpx"
  549. "--with-system-icu"
  550. "--with-system-nspr"
  551. "--with-system-nss"
  552. "--enable-system-pixman"
  553. "--enable-system-cairo"
  554. "--enable-system-ffi"
  555. "--enable-system-hunspell"
  556. "--enable-system-sqlite"
  557. ;; Fails with "--with-system-png won't work because
  558. ;; the system's libpng doesn't have APNG support".
  559. ;; According to
  560. ;; http://sourceforge.net/projects/libpng-apng/ ,
  561. ;; "the Animated Portable Network Graphics (APNG)
  562. ;; is an unofficial extension of the Portable
  563. ;; Network Graphics (PNG) format";
  564. ;; we probably do not wish to support it.
  565. ;; "--with-system-png"
  566. )
  567. #:modules ((ice-9 ftw)
  568. (ice-9 rdelim)
  569. (ice-9 match)
  570. ,@%gnu-build-system-modules)
  571. #:phases
  572. (modify-phases %standard-phases
  573. (add-after
  574. 'unpack 'ensure-no-mtimes-pre-1980
  575. (lambda _
  576. ;; Without this, the 'source/test/addons/packed.xpi' and
  577. ;; 'source/test/addons/simple-prefs.xpi' targets fail while trying
  578. ;; to create zip archives.
  579. (let ((early-1980 315619200)) ; 1980-01-02 UTC
  580. (ftw "." (lambda (file stat flag)
  581. (unless (<= early-1980 (stat:mtime stat))
  582. (utime file early-1980 early-1980))
  583. #t))
  584. #t)))
  585. (add-after
  586. 'unpack 'use-skia-by-default
  587. (lambda _
  588. ;; Use the bundled Skia library by default, since IceCat appears
  589. ;; to be far more stable when using it than when using our system
  590. ;; Cairo.
  591. (let ((out (open "browser/app/profile/icecat.js"
  592. (logior O_WRONLY O_APPEND))))
  593. (format out "~%// Use Skia by default~%")
  594. (format out "pref(~s, ~s);~%" "gfx.canvas.azure.backends" "skia")
  595. (format out "pref(~s, ~s);~%" "gfx.content.azure.backends" "skia")
  596. (close-port out))
  597. #t))
  598. (add-after
  599. 'unpack 'arrange-to-link-libxul-with-libraries-it-might-dlopen
  600. (lambda _
  601. ;; libxul.so dynamically opens libraries, so here we explicitly
  602. ;; link them into libxul.so instead.
  603. ;;
  604. ;; TODO: It might be preferable to patch in absolute file names in
  605. ;; calls to dlopen or PR_LoadLibrary, but that didn't seem to
  606. ;; work. More investigation is needed.
  607. (substitute* "toolkit/library/moz.build"
  608. (("^# This library needs to be last" all)
  609. (string-append "OS_LIBS += [
  610. 'GL', 'gnome-2', 'canberra', 'Xss', 'cups', 'gssapi_krb5',
  611. 'avcodec', 'avutil', 'pulse' ]\n\n"
  612. all)))
  613. #t))
  614. (replace
  615. 'configure
  616. ;; configure does not work followed by both "SHELL=..." and
  617. ;; "CONFIG_SHELL=..."; set environment variables instead
  618. (lambda* (#:key outputs configure-flags #:allow-other-keys)
  619. (let* ((out (assoc-ref outputs "out"))
  620. (bash (which "bash"))
  621. (abs-srcdir (getcwd))
  622. (srcdir (string-append "../" (basename abs-srcdir)))
  623. (flags `(,(string-append "--prefix=" out)
  624. ,(string-append "--with-l10n-base="
  625. abs-srcdir "/l10n")
  626. ,@configure-flags)))
  627. (setenv "SHELL" bash)
  628. (setenv "CONFIG_SHELL" bash)
  629. (setenv "AUTOCONF" (which "autoconf")) ; must be autoconf-2.13
  630. (mkdir "../build")
  631. (chdir "../build")
  632. (format #t "build directory: ~s~%" (getcwd))
  633. (format #t "configure flags: ~s~%" flags)
  634. (zero? (apply system* bash
  635. (string-append srcdir "/configure")
  636. flags)))))
  637. (add-before 'configure 'install-desktop-entry
  638. (lambda* (#:key outputs #:allow-other-keys)
  639. ;; Install the '.desktop' file.
  640. (define (swallow-%%-directives input output)
  641. ;; Interpret '%%ifdef' directives found in the '.desktop' file.
  642. (let loop ((state 'top))
  643. (match (read-line input 'concat)
  644. ((? eof-object?)
  645. #t)
  646. ((? string? line)
  647. (cond ((string-prefix? "%%ifdef" line)
  648. (loop 'ifdef))
  649. ((string-prefix? "%%else" line)
  650. (loop 'else))
  651. ((string-prefix? "%%endif" line)
  652. (loop 'top))
  653. (else
  654. (case state
  655. ((top else)
  656. (display line output)
  657. (loop state))
  658. (else
  659. (loop state)))))))))
  660. (let* ((out (assoc-ref outputs "out"))
  661. (applications (string-append out "/share/applications")))
  662. (call-with-input-file "debian/icecat.desktop.in"
  663. (lambda (input)
  664. (call-with-output-file "debian/icecat.desktop"
  665. (lambda (output)
  666. (swallow-%%-directives input output)))))
  667. (substitute* "debian/icecat.desktop"
  668. (("@MOZ_DISPLAY_NAME@")
  669. "GNU IceCat")
  670. (("^Exec=@MOZ_APP_NAME@")
  671. (string-append "Exec=" out "/bin/icecat"))
  672. (("@MOZ_APP_NAME@")
  673. "icecat"))
  674. (install-file "debian/icecat.desktop" applications)
  675. #t)))
  676. (add-after 'install-desktop-entry 'install-icons
  677. (lambda* (#:key outputs #:allow-other-keys)
  678. (let ((out (assoc-ref outputs "out")))
  679. (with-directory-excursion "browser/branding/official"
  680. (for-each
  681. (lambda (file)
  682. (let* ((size (string-filter char-numeric? file))
  683. (icons (string-append out "/share/icons/hicolor/"
  684. size "x" size "/apps")))
  685. (mkdir-p icons)
  686. (copy-file file (string-append icons "/icecat.png"))))
  687. '("default16.png" "default22.png" "default24.png"
  688. "default32.png" "default48.png" "content/icon64.png"
  689. "mozicon128.png" "default256.png"))))))
  690. ;; This fixes the file chooser crash that happens with GTK 3.
  691. (add-after 'install 'wrap-program
  692. (lambda* (#:key inputs outputs #:allow-other-keys)
  693. (let* ((out (assoc-ref outputs "out"))
  694. (lib (string-append out "/lib"))
  695. (gtk (assoc-ref inputs "gtk+"))
  696. (gtk-share (string-append gtk "/share")))
  697. (wrap-program (car (find-files lib "^icecat$"))
  698. `("XDG_DATA_DIRS" ":" prefix (,gtk-share)))))))))
  699. (home-page "https://www.gnu.org/software/gnuzilla/")
  700. (synopsis "Entirely free browser derived from Mozilla Firefox")
  701. (description
  702. "IceCat is the GNU version of the Firefox browser. It is entirely free
  703. software, which does not recommend non-free plugins and addons. It also
  704. features built-in privacy-protecting features.")
  705. (license license:mpl2.0) ;and others, see toolkit/content/license.html
  706. (properties
  707. `((ftp-directory . "/gnu/gnuzilla")
  708. (cpe-name . "firefox_esr")
  709. (cpe-version . ,(first (string-split version #\-)))))))