fribidi.scm 1.7 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2014 Marek Benc <merkur32@gmail.com>
  3. ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
  4. ;;;
  5. ;;; This file is part of GNU Guix.
  6. ;;;
  7. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  8. ;;; under the terms of the GNU General Public License as published by
  9. ;;; the Free Software Foundation; either version 3 of the License, or (at
  10. ;;; your option) any later version.
  11. ;;;
  12. ;;; GNU Guix is distributed in the hope that it will be useful, but
  13. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  14. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  15. ;;; GNU General Public License for more details.
  16. ;;;
  17. ;;; You should have received a copy of the GNU General Public License
  18. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  19. (define-module (gnu packages fribidi)
  20. #:use-module (guix packages)
  21. #:use-module (guix download)
  22. #:use-module (guix build-system gnu)
  23. #:use-module (guix licenses))
  24. (define-public fribidi
  25. (package
  26. (name "fribidi")
  27. (version "0.19.7")
  28. (source
  29. (origin
  30. (method url-fetch)
  31. (uri
  32. (string-append "http://fribidi.org/download/" name "-" version
  33. ".tar.bz2"))
  34. (sha256
  35. (base32 "13jsb5qadlhsaxkbrb49nqslmbh904vvzhsm5mm2ghmv29i2l8h8"))))
  36. (build-system gnu-build-system)
  37. (synopsis "Implementation of the Unicode bidirectional algorithm")
  38. (description
  39. "GNU FriBidi is an implementation of the Unicode Bidirectional
  40. Algorithm. This algorithm is used to properly display text in left-to-right
  41. or right-to-left ordering as necessary.")
  42. (home-page "http://fribidi.org/")
  43. (license lgpl2.1+)))