docker.scm 3.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2016 David Thompson <davet@gnu.org>
  3. ;;;
  4. ;;; This file is part of GNU Guix.
  5. ;;;
  6. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  7. ;;; under the terms of the GNU General Public License as published by
  8. ;;; the Free Software Foundation; either version 3 of the License, or (at
  9. ;;; your option) any later version.
  10. ;;;
  11. ;;; GNU Guix is distributed in the hope that it will be useful, but
  12. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  13. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  14. ;;; GNU General Public License for more details.
  15. ;;;
  16. ;;; You should have received a copy of the GNU General Public License
  17. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  18. (define-module (gnu packages docker)
  19. #:use-module ((guix licenses) #:prefix license:)
  20. #:use-module (gnu packages)
  21. #:use-module (guix packages)
  22. #:use-module (guix download)
  23. #:use-module (guix git-download)
  24. #:use-module (guix build-system python)
  25. #:use-module (guix utils)
  26. #:use-module (gnu packages python))
  27. (define-public python-docker-py
  28. (package
  29. (name "python-docker-py")
  30. (version "1.6.0")
  31. (source
  32. (origin
  33. (method url-fetch)
  34. (uri (pypi-uri "docker-py" version))
  35. (sha256
  36. (base32
  37. "16ba4xyd46hkj9nkfpz15r8kskl7ljx1afjzchyrhdsrklvzgzim"))))
  38. (build-system python-build-system)
  39. ;; TODO: Tests require a running Docker daemon.
  40. (arguments '(#:tests? #f))
  41. (inputs
  42. `(("python-requests" ,python-requests)
  43. ("python-six" ,python-six)
  44. ("python-websocket-client" ,python-websocket-client)))
  45. (home-page "https://github.com/docker/docker-py/")
  46. (synopsis "Python client for Docker")
  47. (description "Docker-Py is a Python client for the Docker container
  48. management tool.")
  49. (license license:asl2.0)))
  50. (define-public python-dockerpty
  51. (package
  52. (name "python-dockerpty")
  53. (version "0.3.4")
  54. (source
  55. (origin
  56. (method url-fetch)
  57. (uri (pypi-uri "dockerpty" version))
  58. (sha256
  59. (base32
  60. "0za6rr349641wv76ww9l3zcic2xyxrirlxpnzl4296h897648455"))))
  61. (build-system python-build-system)
  62. (native-inputs
  63. `(("python-six" ,python-six)))
  64. (home-page "https://github.com/d11wtq/dockerpty")
  65. (synopsis "Python library to use the pseudo-TTY of a Docker container")
  66. (description "Docker PTY provides the functionality needed to operate the
  67. pseudo-terminal (PTY) allocated to a Docker container using the Python
  68. client.")
  69. (license license:asl2.0)))
  70. (define-public docker-compose
  71. (package
  72. (name "docker-compose")
  73. (version "1.5.2")
  74. (source
  75. (origin
  76. (method url-fetch)
  77. (uri (pypi-uri "docker-compose" version))
  78. (sha256
  79. (base32
  80. "0ksg7hm2yvc977968dixxisrhcmvskzpcx3pz0v1kazrdqp7xakr"))))
  81. (build-system python-build-system)
  82. ;; TODO: Tests require running Docker daemon.
  83. (arguments '(#:tests? #f))
  84. (inputs
  85. `(("python-docker-py" ,python-docker-py)
  86. ("python-dockerpty" ,python-dockerpty)
  87. ("python-docopt" ,python-docopt)
  88. ("python-jsonschema" ,python-jsonschema)
  89. ("python-pyyaml" ,python-pyyaml)
  90. ("python-requests" ,python-requests-2.7)
  91. ("python-six" ,python-six)
  92. ("python-texttable" ,python-texttable)
  93. ("python-websocket-client" ,python-websocket-client)))
  94. (home-page "https://www.docker.com/")
  95. (synopsis "Multi-container orchestration for Docker")
  96. (description "Docker Compose is a tool for defining and running
  97. multi-container Docker applications. A Compose file is used to configure an
  98. application’s services. Then, using a single command, the containers are
  99. created and all the services are started as specified in the configuration.")
  100. (license license:asl2.0)))