djvu.scm 2.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2015 Paul van der Walt <paul@denknerd.org>
  3. ;;;
  4. ;;; This file is part of GNU Guix.
  5. ;;;
  6. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  7. ;;; under the terms of the GNU General Public License as published by
  8. ;;; the Free Software Foundation; either version 3 of the License, or (at
  9. ;;; your option) any later version.
  10. ;;;
  11. ;;; GNU Guix is distributed in the hope that it will be useful, but
  12. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  13. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  14. ;;; GNU General Public License for more details.
  15. ;;;
  16. ;;; You should have received a copy of the GNU General Public License
  17. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  18. (define-module (gnu packages djvu)
  19. #:use-module ((guix licenses) #:prefix license:)
  20. #:use-module (guix packages)
  21. #:use-module (guix download)
  22. #:use-module (guix build-system gnu))
  23. (define-public djvulibre
  24. (package
  25. (name "djvulibre")
  26. (version "3.5.27")
  27. (source (origin
  28. (method url-fetch)
  29. (uri (string-append "mirror://sourceforge/djvu/DjVuLibre/"
  30. version "/djvulibre-" version ".tar.gz"))
  31. (sha256
  32. (base32
  33. "0psh3zl9dj4n4r3lx25390nx34xz0bg0ql48zdskhq354ljni5p6"))))
  34. (build-system gnu-build-system)
  35. (arguments
  36. `(#:phases (modify-phases %standard-phases
  37. (add-after 'unpack 'reproducible
  38. (lambda _
  39. ;; Ensure there are no timestamps in .svgz files.
  40. (substitute* "desktopfiles/Makefile.in"
  41. (("gzip") "gzip -n"))
  42. #t)))))
  43. (home-page "http://djvu.sourceforge.net/")
  44. (synopsis "Implementation of DjVu, the document format")
  45. (description "DjVuLibre is an implementation of DjVu,
  46. including viewers, browser plugins, decoders, simple encoders, and
  47. utilities.")
  48. (license license:gpl2+)))