cpp.scm 2.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2017 Ethan R. Jones <doubleplusgood23@gmail.com>
  3. ;;;
  4. ;;; This file is part of GNU Guix.
  5. ;;;
  6. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  7. ;;; under the terms of the GNU General Public License as published by
  8. ;;; the Free Software Foundation; either version 3 of the License, or (at
  9. ;;; your option) any later version.
  10. ;;;
  11. ;;; GNU Guix is distributed in the hope that it will be useful, but
  12. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  13. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  14. ;;; GNU General Public License for more details.
  15. ;;;
  16. ;;; You should have received a copy of the GNU General Public License
  17. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  18. (define-module (gnu packages cpp)
  19. #:use-module ((guix licenses) #:prefix license:)
  20. #:use-module (guix packages)
  21. #:use-module (guix download)
  22. #:use-module (guix build-system gnu)
  23. #:use-module (gnu packages)
  24. #:use-module (gnu packages autotools))
  25. (define-public libzen
  26. (package
  27. (name "libzen")
  28. (version "0.4.35")
  29. (source (origin
  30. (method url-fetch)
  31. (uri (string-append "https://mediaarea.net/download/source/"
  32. name "/" version "/"
  33. name "_" version ".tar.bz2"))
  34. (sha256
  35. (base32
  36. "12a1icgcffgv503ii2k1453kxg5hfly09mf4zjcc80aq8a6rf8by"))))
  37. (native-inputs
  38. `(("autoconf" ,autoconf)
  39. ("automake" ,automake)
  40. ("libtool" ,libtool)))
  41. (build-system gnu-build-system)
  42. (arguments
  43. '(#:phases
  44. ;; build scripts not in root of archive
  45. (modify-phases %standard-phases
  46. (add-after 'unpack 'pre-configure
  47. (lambda _
  48. (chdir "Project/GNU/Library")))
  49. (add-after 'pre-configure 'autogen
  50. (lambda _
  51. (zero? (system* "sh" "autogen.sh")))))))
  52. (home-page "https://github.com/MediaArea/ZenLib")
  53. (synopsis "C++ utility library")
  54. (description "ZenLib is a C++ utility library. It includes classes for handling
  55. strings, configuration, bit streams, threading, translation, and cross-platform
  56. operating system functions.")
  57. (license license:zlib)))