123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960 |
- ;;; GNU Guix --- Functional package management for GNU
- ;;; Copyright © 2017 Ethan R. Jones <doubleplusgood23@gmail.com>
- ;;;
- ;;; This file is part of GNU Guix.
- ;;;
- ;;; GNU Guix is free software; you can redistribute it and/or modify it
- ;;; under the terms of the GNU General Public License as published by
- ;;; the Free Software Foundation; either version 3 of the License, or (at
- ;;; your option) any later version.
- ;;;
- ;;; GNU Guix is distributed in the hope that it will be useful, but
- ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
- ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- ;;; GNU General Public License for more details.
- ;;;
- ;;; You should have received a copy of the GNU General Public License
- ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
- (define-module (gnu packages cpp)
- #:use-module ((guix licenses) #:prefix license:)
- #:use-module (guix packages)
- #:use-module (guix download)
- #:use-module (guix build-system gnu)
- #:use-module (gnu packages)
- #:use-module (gnu packages autotools))
- (define-public libzen
- (package
- (name "libzen")
- (version "0.4.35")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://mediaarea.net/download/source/"
- name "/" version "/"
- name "_" version ".tar.bz2"))
- (sha256
- (base32
- "12a1icgcffgv503ii2k1453kxg5hfly09mf4zjcc80aq8a6rf8by"))))
- (native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("libtool" ,libtool)))
- (build-system gnu-build-system)
- (arguments
- '(#:phases
- ;; build scripts not in root of archive
- (modify-phases %standard-phases
- (add-after 'unpack 'pre-configure
- (lambda _
- (chdir "Project/GNU/Library")))
- (add-after 'pre-configure 'autogen
- (lambda _
- (zero? (system* "sh" "autogen.sh")))))))
- (home-page "https://github.com/MediaArea/ZenLib")
- (synopsis "C++ utility library")
- (description "ZenLib is a C++ utility library. It includes classes for handling
- strings, configuration, bit streams, threading, translation, and cross-platform
- operating system functions.")
- (license license:zlib)))
|