cpio.scm 2.0 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
  3. ;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
  4. ;;;
  5. ;;; This file is part of GNU Guix.
  6. ;;;
  7. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  8. ;;; under the terms of the GNU General Public License as published by
  9. ;;; the Free Software Foundation; either version 3 of the License, or (at
  10. ;;; your option) any later version.
  11. ;;;
  12. ;;; GNU Guix is distributed in the hope that it will be useful, but
  13. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  14. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  15. ;;; GNU General Public License for more details.
  16. ;;;
  17. ;;; You should have received a copy of the GNU General Public License
  18. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  19. (define-module (gnu packages cpio)
  20. #:use-module (guix licenses)
  21. #:use-module (gnu packages)
  22. #:use-module (gnu packages autotools)
  23. #:use-module (guix packages)
  24. #:use-module (guix download)
  25. #:use-module (guix build-system gnu))
  26. (define-public cpio
  27. (package
  28. (name "cpio")
  29. (version "2.12")
  30. (source (origin
  31. (method url-fetch)
  32. (uri (string-append "mirror://gnu/cpio/cpio-"
  33. version ".tar.bz2"))
  34. (sha256
  35. (base32
  36. "0vi9q475h1rki53100zml75vxsykzyhrn70hidy41s5c2rc8r6bh"))
  37. (patches (search-patches "cpio-CVE-2016-2037.patch"))))
  38. (build-system gnu-build-system)
  39. (home-page "https://www.gnu.org/software/cpio/")
  40. (synopsis "Manage cpio and tar file archives")
  41. (description
  42. "GNU cpio copies files into or out of cpio or tar archives. Indeed,
  43. many formats are supported, including legacy formats. The format is
  44. determined automatically by the program and is handled appropriately.
  45. Furthermore, the location of the archive is not important. It can be another
  46. file on the drive, a tape, or data on a pipe.")
  47. (license gpl3+)))