cook.scm 3.4 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2014 John Darrington <jmd@gnu.org>
  3. ;;;
  4. ;;; This file is part of GNU Guix.
  5. ;;;
  6. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  7. ;;; under the terms of the GNU General Public License as published by
  8. ;;; the Free Software Foundation; either version 3 of the License, or (at
  9. ;;; your option) any later version.
  10. ;;;
  11. ;;; GNU Guix is distributed in the hope that it will be useful, but
  12. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  13. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  14. ;;; GNU General Public License for more details.
  15. ;;;
  16. ;;; You should have received a copy of the GNU General Public License
  17. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  18. (define-module (gnu packages cook)
  19. #:use-module (guix packages)
  20. #:use-module (guix licenses)
  21. #:use-module (guix download)
  22. #:use-module (gnu packages ed)
  23. #:use-module (gnu packages bison)
  24. #:use-module (gnu packages groff)
  25. #:use-module (gnu packages compression)
  26. #:use-module (guix build-system gnu))
  27. (define-public cook
  28. (package
  29. (name "cook")
  30. (version "2.34")
  31. (source
  32. (origin
  33. (method url-fetch)
  34. (uri "http://fossies.org/linux/misc/old/cook-2.34.tar.gz")
  35. (sha256
  36. (base32
  37. "104saqnqql1l7zr2pm3f718fdky3ds8j07c6xvwrs1rfkhrw58yw"))))
  38. (build-system gnu-build-system)
  39. (arguments
  40. `(#:parallel-build? #f ; There are some nasty racy rules in the Makefile.
  41. #:phases
  42. (alist-cons-before
  43. 'configure 'pre-conf
  44. (lambda _
  45. (substitute* (append '("common/env.c")
  46. (find-files "test" "\\.sh"))
  47. (("/bin/sh") (which "sh")))
  48. ;; Guix's binutils (because it wants bit-reproducable builds) is
  49. ;; is configured with the --enable-deterministic-archives flag.
  50. ;; This means the timestamp of files appended to an ar archive
  51. ;; are automatically and silently mutated to 00:00 1 Jan 1970
  52. ;; which plays havoc with this test, for which correct timestamps
  53. ;; are very important. Adding the U flag undoes the effect of
  54. ;; --enable-deterministic-archives and allows this test to work
  55. ;; again.
  56. (substitute* "test/00/t0077a.sh"
  57. (("ar qc") "ar qcU"))
  58. (setenv "SH" (which "sh")))
  59. %standard-phases)))
  60. (native-inputs `(("bison" ,bison)
  61. ;; For building the documentation:
  62. ("groff" ,groff)
  63. ;; For the tests:
  64. ("sharutils" ,sharutils)
  65. ;; One test wants rsh. However there is no rsh server
  66. ;; running in the build environment and so far as I'm
  67. ;; aware, it cannot be started without root.
  68. ;; This test is therefore just skipped.
  69. ;; ("inetutils" ,inetutils)
  70. ("ed" ,ed)))
  71. (home-page "http://miller.emu.id.au/pmiller/software/cook")
  72. (synopsis "Tool for constructing files")
  73. (description "Cook is a tool for constructing files. It is given a set of
  74. files to create, and recipes of how to create them. In any non-trivial program
  75. there will be prerequisites to performing the actions necessary to creating
  76. any file, such as include files. Cook provides a mechanism to define these.")
  77. (license gpl3+)))