cobol.scm 2.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
  3. ;;;
  4. ;;; This file is part of GNU Guix.
  5. ;;;
  6. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  7. ;;; under the terms of the GNU General Public License as published by
  8. ;;; the Free Software Foundation; either version 3 of the License, or (at
  9. ;;; your option) any later version.
  10. ;;;
  11. ;;; GNU Guix is distributed in the hope that it will be useful, but
  12. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  13. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  14. ;;; GNU General Public License for more details.
  15. ;;;
  16. ;;; You should have received a copy of the GNU General Public License
  17. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  18. (define-module (gnu packages cobol)
  19. #:use-module (gnu packages)
  20. #:use-module (guix build-system gnu)
  21. #:use-module (guix licenses)
  22. #:use-module (guix packages)
  23. #:use-module (guix download)
  24. #:use-module (gnu packages databases)
  25. #:use-module (gnu packages multiprecision)
  26. #:use-module (gnu packages ncurses))
  27. (define-public gnucobol
  28. (package
  29. (name "gnucobol")
  30. (version "2.2")
  31. (source
  32. (origin
  33. (method url-fetch)
  34. (uri (string-append
  35. "mirror://gnu/gnucobol/gnucobol-"
  36. version ".tar.xz"))
  37. (sha256
  38. (base32
  39. "1814s1n95xax2dz938cf4fkcp0q94nkj1gjbdblbzpk9q92zq66w"))))
  40. (arguments
  41. '(#:configure-flags (list (string-append "LDFLAGS=-Wl,-rpath="
  42. (assoc-ref %outputs "out")
  43. "/lib"))))
  44. (inputs
  45. `(("bdb" ,bdb)
  46. ("gmp" ,gmp)
  47. ("ncurses" ,ncurses)))
  48. (build-system gnu-build-system)
  49. (home-page "https://savannah.gnu.org/projects/gnucobol/")
  50. (synopsis "A modern COBOL compiler")
  51. (description "GnuCOBOL is a free, modern COBOL compiler. GnuCOBOL
  52. implements a substantial part of the COBOL 85, COBOL 2002 and COBOL 2014
  53. standards and X/Open COBOL, as well as many extensions included in other
  54. COBOL compilers (IBM COBOL, MicroFocus COBOL, ACUCOBOL-GT and others).
  55. GnuCOBOL translates COBOL into C and compiles the translated code using
  56. a native C compiler.")
  57. (license gpl3+)))