augeas.scm 2.5 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2016, 2017 Ricardo Wurmus <rekado@elephly.net>
  3. ;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
  4. ;;;
  5. ;;; This file is part of GNU Guix.
  6. ;;;
  7. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  8. ;;; under the terms of the GNU General Public License as published by
  9. ;;; the Free Software Foundation; either version 3 of the License, or (at
  10. ;;; your option) any later version.
  11. ;;;
  12. ;;; GNU Guix is distributed in the hope that it will be useful, but
  13. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  14. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  15. ;;; GNU General Public License for more details.
  16. ;;;
  17. ;;; You should have received a copy of the GNU General Public License
  18. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  19. (define-module (gnu packages augeas)
  20. #:use-module ((guix licenses) #:prefix license:)
  21. #:use-module (guix packages)
  22. #:use-module (guix download)
  23. #:use-module (guix utils)
  24. #:use-module (guix build-system gnu)
  25. #:use-module (gnu packages)
  26. #:use-module (gnu packages readline)
  27. #:use-module (gnu packages pkg-config)
  28. #:use-module (gnu packages xml))
  29. (define-public augeas
  30. (package
  31. (name "augeas")
  32. (version "1.8.1")
  33. (source (origin
  34. (method url-fetch)
  35. (uri (string-append "http://download.augeas.net/augeas-"
  36. version ".tar.gz"))
  37. (sha256
  38. (base32
  39. "1yf93fqwav1zsl8dpyfkf0g11w05mmfckqy6qsjy5zkklnspbkv5"))))
  40. (build-system gnu-build-system)
  41. ;; Marked as "required" in augeas.pc
  42. (propagated-inputs
  43. `(("libxml2" ,libxml2)))
  44. (inputs
  45. `(("readline" ,readline)))
  46. (native-inputs
  47. `(("pkg-config" ,pkg-config)))
  48. (home-page "http://augeas.net/")
  49. (synopsis "Edit configuration files programmatically")
  50. (description
  51. "Augeas is a library and command line tool for programmatically editing
  52. configuration files in a controlled manner. Augeas exposes a tree of all
  53. configuration settings and a simple local API for manipulating the tree.
  54. Augeas then modifies underlying configuration files according to the changes
  55. that have been made to the tree; it does as little modeling of configurations
  56. as possible, and focuses exclusivley on transforming the tree-oriented syntax
  57. of its public API to the myriad syntaxes of individual configuration files.")
  58. (license license:lgpl2.1+)))