accessibility.scm 4.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2017 ng0 <ng0@no-reply.pragmatique.xyz>
  3. ;;; Copyright © 2017 Stefan Reichör <stefan@xsteve.at>
  4. ;;;
  5. ;;; This file is part of GNU Guix.
  6. ;;;
  7. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  8. ;;; under the terms of the GNU General Public License as published by
  9. ;;; the Free Software Foundation; either version 3 of the License, or (at
  10. ;;; your option) any later version.
  11. ;;;
  12. ;;; GNU Guix is distributed in the hope that it will be useful, but
  13. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  14. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  15. ;;; GNU General Public License for more details.
  16. ;;;
  17. ;;; You should have received a copy of the GNU General Public License
  18. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  19. (define-module (gnu packages accessibility)
  20. #:use-module ((guix licenses) #:prefix license:)
  21. #:use-module (guix packages)
  22. #:use-module (guix download)
  23. #:use-module (guix git-download)
  24. #:use-module (guix build-system gnu)
  25. #:use-module (guix build-system glib-or-gtk)
  26. #:use-module (gnu packages)
  27. #:use-module (gnu packages xml)
  28. #:use-module (gnu packages gnome)
  29. #:use-module (gnu packages gstreamer)
  30. #:use-module (gnu packages gtk)
  31. #:use-module (gnu packages xorg)
  32. #:use-module (gnu packages gettext)
  33. #:use-module (gnu packages glib)
  34. #:use-module (gnu packages pkg-config)
  35. #:use-module (gnu packages libusb))
  36. (define-public florence
  37. (package
  38. (name "florence")
  39. (version "0.6.3")
  40. (source
  41. (origin
  42. (method url-fetch)
  43. (uri (string-append "mirror://sourceforge/florence/florence/" version
  44. "/" name "-" version ".tar.bz2"))
  45. (sha256
  46. (base32
  47. "07h9qm22krlwayhzvc391lr23vicw81s48g7rirvx1fj0zyr4aa2"))))
  48. (build-system glib-or-gtk-build-system)
  49. (arguments
  50. `(#:configure-flags (list "--with-xtst"
  51. "--without-docs"
  52. "--with-notification")))
  53. (inputs
  54. `(("libxml2" ,libxml2)
  55. ("libglade" ,libglade)
  56. ("librsvg" ,librsvg)
  57. ("gstreamer" ,gstreamer)
  58. ("cairo" ,cairo)
  59. ("gtk+" ,gtk+)
  60. ("libxtst" ,libxtst)
  61. ("libxcomposite" ,libxcomposite)
  62. ("libnotify" ,libnotify)))
  63. (native-inputs
  64. `(("gettext-minimal" ,gettext-minimal)
  65. ("intltool" ,intltool)
  66. ("pkg-config" ,pkg-config)))
  67. (home-page "http://florence.sourceforge.net/")
  68. (synopsis "Extensible, scalable virtual keyboard for X11")
  69. (description
  70. "Florence is an extensible scalable virtual keyboard for X11.
  71. It is useful for people who can't use a real hardware keyboard (for
  72. example for people with disabilities), but you must be able to use
  73. a pointing device (as a mouse, a trackball, a touchscreen or opengazer).
  74. Florence stays out of your way when you don't need it: it appears on the
  75. screen only when you need it. A timer-based auto-click input method is
  76. available to help to click.")
  77. ;; The documentation is under FDL1.2, but we do not install the
  78. ;; documentation.
  79. (license license:gpl2+)))
  80. (define-public footswitch
  81. (let ((commit "7cb0a9333a150c27c7e4746ee827765d244e567a"))
  82. (package
  83. (name "footswitch")
  84. (version (git-version "0.1" "1" commit))
  85. (source (origin
  86. (method git-fetch)
  87. (uri (git-reference
  88. (url "https://github.com/rgerganov/footswitch")
  89. (commit commit)))
  90. (file-name (git-file-name name version))
  91. (sha256
  92. (base32 "0mg1vr4a9vls5y435w7wdnr1vb5059gy60lvrdfjgzhd2wwf47iw"))))
  93. (build-system gnu-build-system)
  94. (native-inputs
  95. `(("pkg-config" ,pkg-config)))
  96. (inputs
  97. `(("hidapi" ,hidapi)))
  98. (arguments
  99. `(#:tests? #f ; no tests
  100. #:make-flags (list "CC=gcc")
  101. #:phases (modify-phases %standard-phases
  102. (delete 'configure)
  103. ;; Install target in the Makefile does not work for Guix
  104. (replace 'install
  105. (lambda* (#:key outputs #:allow-other-keys)
  106. (let ((bin (string-append (assoc-ref outputs "out")
  107. "/bin")))
  108. (mkdir-p bin)
  109. (install-file "footswitch" bin)
  110. #t))))))
  111. (home-page "https://github.com/rgerganov/footswitch")
  112. (synopsis "Command line utility for PCsensor foot switch")
  113. (description
  114. "Command line utility for programming foot switches sold by PCsensor.
  115. It works for both single pedal devices and three pedal devices. All supported
  116. devices have vendorId:productId = 0c45:7403 or 0c45:7404.")
  117. (license license:expat))))