task-management.scm 2.3 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2015 Tomáš Čech <sleep_walker@suse.cz>
  3. ;;;
  4. ;;; This file is part of GNU Guix.
  5. ;;;
  6. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  7. ;;; under the terms of the GNU General Public License as published by
  8. ;;; the Free Software Foundation; either version 3 of the License, or (at
  9. ;;; your option) any later version.
  10. ;;;
  11. ;;; GNU Guix is distributed in the hope that it will be useful, but
  12. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  13. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  14. ;;; GNU General Public License for more details.
  15. ;;;
  16. ;;; You should have received a copy of the GNU General Public License
  17. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  18. (define-module (gnu packages task-management)
  19. #:use-module ((guix licenses) #:prefix license:)
  20. #:use-module (guix packages)
  21. #:use-module (gnu packages linux)
  22. #:use-module (gnu packages lua)
  23. #:use-module (gnu packages tls)
  24. #:use-module (guix download)
  25. #:use-module (guix build-system cmake))
  26. (define-public taskwarrior
  27. (package
  28. (name "taskwarrior")
  29. (version "2.5.1")
  30. (source
  31. (origin
  32. (method url-fetch)
  33. (uri (string-append
  34. "http://taskwarrior.org/download/task-" version ".tar.gz"))
  35. (sha256 (base32
  36. "059a9yc58wcicc6xxsjh1ph7k2yrag0spsahp1wqmsq6h7jwwyyq"))))
  37. (build-system cmake-build-system)
  38. (inputs
  39. `(("gnutls" ,gnutls)
  40. ("lua" ,lua)
  41. ("util-linux" ,util-linux)))
  42. (arguments
  43. `(#:tests? #f ; No tests implemented.
  44. #:phases
  45. (modify-phases %standard-phases
  46. (add-before
  47. 'patch-source-shebangs 'remove-broken-symlinks
  48. (lambda _
  49. ;; These files are broken symlinks - delete them.
  50. (delete-file "src/cal")
  51. (delete-file "src/calendar")
  52. (delete-file "src/tw"))))))
  53. (home-page "http://taskwarrior.org")
  54. (synopsis "Command line task manager")
  55. (description
  56. "Taskwarrior is a command-line task manager following the Getting Things
  57. Done time management method. It supports network synchronization, filtering
  58. and querying data, exposing task data in multiple formats to other tools.")
  59. (license license:expat)))