pth.scm 2.3 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2012, 2015 Ludovic Courtès <ludo@gnu.org>
  3. ;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
  4. ;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
  5. ;;;
  6. ;;; This file is part of GNU Guix.
  7. ;;;
  8. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  9. ;;; under the terms of the GNU General Public License as published by
  10. ;;; the Free Software Foundation; either version 3 of the License, or (at
  11. ;;; your option) any later version.
  12. ;;;
  13. ;;; GNU Guix is distributed in the hope that it will be useful, but
  14. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  15. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  16. ;;; GNU General Public License for more details.
  17. ;;;
  18. ;;; You should have received a copy of the GNU General Public License
  19. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  20. (define-module (gnu packages pth)
  21. #:use-module (guix licenses)
  22. #:use-module (guix packages)
  23. #:use-module (guix download)
  24. #:use-module (guix build-system gnu))
  25. (define-public pth
  26. (package
  27. (name "pth")
  28. (version "2.0.7")
  29. (source
  30. (origin
  31. (method url-fetch)
  32. (uri (string-append "mirror://gnu/pth/pth-" version
  33. ".tar.gz"))
  34. (sha256
  35. (base32
  36. "0ckjqw5kz5m30srqi87idj7xhpw6bpki43mj07bazjm2qmh3cdbj"))))
  37. (build-system gnu-build-system)
  38. (arguments
  39. `(#:parallel-build? #f
  40. #:configure-flags (list
  41. ,@(if (string=? "aarch64-linux"
  42. (%current-system))
  43. '("--host=aarch64-unknown-linux-gnu")
  44. '()))))
  45. (home-page "https://www.gnu.org/software/pth/")
  46. (synopsis "Portable thread library")
  47. (description
  48. "GNU Pth is a portable library providing non-preemptive, priority-based
  49. scheduling for multiple execution threads. Each thread has its own
  50. program-counter, run-time stack, signal mask and errno variable. Threads are
  51. scheduled in a cooperative way, rather than in the standard preemptive way,
  52. such that they are managed according to priority and events. However, Pth
  53. also features emulation of POSIX.1c threads (\"pthreads\") for backwards
  54. compatibility.")
  55. (license lgpl2.1+)))