photo.scm 21 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2014, 2015, 2017 Ludovic Courtès <ludo@gnu.org>
  3. ;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
  4. ;;; Copyright © 2015, 2017 Andreas Enge <andreas@enge.fr>
  5. ;;; Copyright © 2016, 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
  6. ;;; Copyright © 2017 Roel Janssen <roel@gnu.org>
  7. ;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
  8. ;;; Copyright © 2018 Leo Famulari <leo@famulari.name>
  9. ;;;
  10. ;;; This file is part of GNU Guix.
  11. ;;;
  12. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  13. ;;; under the terms of the GNU General Public License as published by
  14. ;;; the Free Software Foundation; either version 3 of the License, or (at
  15. ;;; your option) any later version.
  16. ;;;
  17. ;;; GNU Guix is distributed in the hope that it will be useful, but
  18. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  19. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  20. ;;; GNU General Public License for more details.
  21. ;;;
  22. ;;; You should have received a copy of the GNU General Public License
  23. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  24. (define-module (gnu packages photo)
  25. #:use-module (guix build-system cmake)
  26. #:use-module (guix build-system gnu)
  27. #:use-module (guix build-system perl)
  28. #:use-module (guix download)
  29. #:use-module ((guix licenses) #:prefix license:)
  30. #:use-module (guix packages)
  31. #:use-module (guix utils)
  32. #:use-module (gnu packages)
  33. #:use-module (gnu packages algebra)
  34. #:use-module (gnu packages autotools)
  35. #:use-module (gnu packages base)
  36. #:use-module (gnu packages boost)
  37. #:use-module (gnu packages compression)
  38. #:use-module (gnu packages curl)
  39. #:use-module (gnu packages gettext)
  40. #:use-module (gnu packages ghostscript)
  41. #:use-module (gnu packages gl)
  42. #:use-module (gnu packages gnome)
  43. #:use-module (gnu packages glib)
  44. #:use-module (gnu packages graphics)
  45. #:use-module (gnu packages gtk)
  46. #:use-module (gnu packages image)
  47. #:use-module (gnu packages imagemagick)
  48. #:use-module (gnu packages libcanberra)
  49. #:use-module (gnu packages libusb)
  50. #:use-module (gnu packages llvm)
  51. #:use-module (gnu packages man)
  52. #:use-module (gnu packages maths)
  53. #:use-module (gnu packages perl)
  54. #:use-module (gnu packages pkg-config)
  55. #:use-module (gnu packages popt)
  56. #:use-module (gnu packages python)
  57. #:use-module (gnu packages python-xyz)
  58. #:use-module (gnu packages readline)
  59. #:use-module (gnu packages sqlite)
  60. #:use-module (gnu packages tex)
  61. #:use-module (gnu packages web)
  62. #:use-module (gnu packages wxwidgets)
  63. #:use-module (gnu packages xfig)
  64. #:use-module (gnu packages xorg)
  65. #:use-module (gnu packages xml)
  66. #:use-module ((srfi srfi-1) #:hide (zip))
  67. #:use-module (srfi srfi-26))
  68. (define-public libraw
  69. (package
  70. (name "libraw")
  71. (version "0.19.2")
  72. (source (origin
  73. (method url-fetch)
  74. (uri (string-append "https://www.libraw.org/data/LibRaw-"
  75. version ".tar.gz"))
  76. (sha256
  77. (base32
  78. "0i4nhjm5556xgn966x0i503ygk2wafq6z83kg0lisacjjab4f3a0"))))
  79. (build-system gnu-build-system)
  80. (native-inputs
  81. `(("pkg-config" ,pkg-config)))
  82. (inputs
  83. `(("libjpeg" ,libjpeg))) ;for lossy DNGs and old Kodak cameras
  84. (propagated-inputs
  85. `(("lcms" ,lcms))) ;for color profiles
  86. (home-page "https://www.libraw.org")
  87. (synopsis "Raw image decoder")
  88. (description
  89. "LibRaw is a library for reading RAW files obtained from digital photo
  90. cameras (CRW/CR2, NEF, RAF, DNG, and others).")
  91. ;; LibRaw is distributed under both LGPL2.1 and CDDL 1.0. From the README:
  92. ;; "You may use one of these licensing modes and switch between them. If
  93. ;; you modify LibRaw source and made your changes public, you should accept
  94. ;; both two licensing modes for your changes/additions."
  95. (license (list license:lgpl2.1 license:cddl1.0))))
  96. (define-public libraw-0.18
  97. (package (inherit libraw)
  98. (name "libraw")
  99. (version "0.18.12")
  100. (source (origin
  101. (method url-fetch)
  102. (uri (string-append "https://www.libraw.org/data/LibRaw-"
  103. version ".tar.gz"))
  104. (sha256
  105. (base32
  106. "1m2khr2cij8z6lawgbmdksjn14fpnjsy8ad4qahnpqapm1slsxap"))))))
  107. (define-public libexif
  108. (package
  109. (name "libexif")
  110. (version "0.6.21")
  111. (source (origin
  112. (method url-fetch)
  113. (uri (string-append "mirror://sourceforge/libexif/libexif/"
  114. version "/libexif-" version ".tar.bz2"))
  115. (patches (search-patches "libexif-CVE-2016-6328.patch"
  116. "libexif-CVE-2017-7544.patch"))
  117. (sha256
  118. (base32
  119. "06nlsibr3ylfwp28w8f5466l6drgrnydgxrm4jmxzrmk5svaxk8n"))))
  120. (build-system gnu-build-system)
  121. (home-page "https://libexif.github.io/")
  122. (synopsis "Read and manipulate EXIF data in digital photographs")
  123. (description
  124. "The libexif C library allows applications to read, edit, and save EXIF
  125. data as produced by digital cameras.")
  126. (license license:lgpl2.1+)))
  127. (define-public libgphoto2
  128. (package
  129. (name "libgphoto2")
  130. (version "2.5.22")
  131. (source (origin
  132. (method url-fetch)
  133. (uri (string-append "mirror://sourceforge/gphoto/libgphoto/"
  134. version "/libgphoto2-" version ".tar.bz2"))
  135. (sha256
  136. (base32
  137. "0n6f6nagys775ib483nka1sbclhkm1dz3n5z3lgaz1m9m5x35mqm"))))
  138. (build-system gnu-build-system)
  139. (native-inputs `(("pkg-config" ,pkg-config)))
  140. (inputs
  141. `(("libjpeg-turbo" ,libjpeg-turbo)
  142. ("libltdl" ,libltdl)
  143. ("libusb" ,libusb)
  144. ("libxml2" ,libxml2)))
  145. (propagated-inputs
  146. `(;; The .pc refers to libexif.
  147. ("libexif" ,libexif)))
  148. (home-page "http://www.gphoto.org/proj/libgphoto2/")
  149. (synopsis "Accessing digital cameras")
  150. (description
  151. "This is the library backend for gphoto2. It contains the code for PTP,
  152. MTP, and other vendor specific protocols for controlling and transferring data
  153. from digital cameras.")
  154. ;; 'COPYING' says LGPLv2.1+, but in practices files are under LGPLv2+.
  155. (license license:lgpl2.1+)))
  156. (define-public gphoto2
  157. (package
  158. (name "gphoto2")
  159. (version "2.5.17")
  160. (source (origin
  161. (method url-fetch)
  162. (uri (string-append "mirror://sourceforge/gphoto/gphoto/" version
  163. "/gphoto2-" version ".tar.bz2"))
  164. (sha256
  165. (base32
  166. "0kslwclyyzvnxjw3gdzhlagj7l5f8lba833ipr9s0s0c4hwi0mxa"))))
  167. (build-system gnu-build-system)
  168. (native-inputs
  169. `(("pkg-config" ,pkg-config)))
  170. (inputs
  171. `(("readline" ,readline)
  172. ("libjpeg-turbo" ,libjpeg-turbo)
  173. ("popt" ,popt)
  174. ("libexif" ,libexif)
  175. ("libgphoto2" ,libgphoto2)))
  176. (arguments
  177. '(#:phases
  178. (modify-phases %standard-phases
  179. (add-before 'check 'pre-check
  180. (lambda* (#:key inputs #:allow-other-keys)
  181. (substitute* (find-files "tests/data" "\\.param$")
  182. (("/usr/bin/env")
  183. (which "env")))
  184. #t)))
  185. ;; FIXME: There is 1 test failure, most likely related to the build
  186. ;; environment.
  187. #:tests? #f))
  188. (home-page "http://www.gphoto.org/")
  189. (synopsis "Command-line tools to access digital cameras")
  190. (description
  191. "Gphoto2 is a set of command line utilities for manipulating a large
  192. number of different digital cameras. Through libgphoto2, it supports PTP,
  193. MTP, and much more.")
  194. ;; Files are typically under LGPLv2+, but 'COPYING' says GPLv2+.
  195. (license license:gpl2+)))
  196. (define-public perl-image-exiftool
  197. (package
  198. (name "perl-image-exiftool")
  199. (version "11.11")
  200. (source (origin
  201. (method url-fetch)
  202. (uri (string-append
  203. "mirror://cpan/authors/id/E/EX/EXIFTOOL/Image-ExifTool-"
  204. version ".tar.gz"))
  205. (sha256
  206. (base32
  207. "1szg1k82nz88pp5n7lg71ja7q3hh5i5f9bcbb7m482dwrmsywkp6"))))
  208. (build-system perl-build-system)
  209. (arguments
  210. '(#:phases
  211. (modify-phases %standard-phases
  212. (add-after 'install 'post-install
  213. (lambda* (#:key outputs #:allow-other-keys)
  214. ;; Make sure the 'exiftool' commands finds the library.
  215. ;; XXX: Shouldn't it be handled by PERL-BUILD-SYSTEM?
  216. (let* ((out (assoc-ref outputs "out"))
  217. (pm (find-files out "^ExifTool\\.pm$"))
  218. (lib (dirname (dirname (car pm)))))
  219. (wrap-program (string-append out "/bin/exiftool")
  220. `("PERL5LIB" prefix (,lib)))
  221. #t))))))
  222. (home-page "https://metacpan.org/release/Image-ExifTool")
  223. (synopsis "Program and Perl library to manipulate EXIF and other metadata")
  224. (description "This package provides the @code{exiftool} command and the
  225. @code{Image::ExifTool} Perl library to manipulate EXIF tags of digital images
  226. and a wide variety of other metadata.")
  227. (license license:perl-license)))
  228. (define-public libpano13
  229. (package
  230. (name "libpano13")
  231. (version "2.9.19")
  232. (source (origin
  233. (method url-fetch)
  234. (uri (string-append "mirror://sourceforge/panotools/libpano13/"
  235. "libpano13-" version "/"
  236. "libpano13-" version ".tar.gz"))
  237. (sha256
  238. (base32
  239. "1a4m3plmfcrrplqs9zfzhc5apibn10m5sajpizm1sd3q74w5fwq3"))))
  240. (build-system cmake-build-system)
  241. (inputs
  242. `(("libjpeg" ,libjpeg)
  243. ("libpng" ,libpng)
  244. ("libtiff" ,libtiff)
  245. ("zlib" ,zlib)))
  246. (home-page "http://panotools.sourceforge.net/")
  247. (synopsis "Library for panoramic images")
  248. (description
  249. "The libpano13 package contains the backend library written by the
  250. Panorama Tools project for building panoramic images from a set of
  251. overlapping images, as well as some command line tools.")
  252. (license license:gpl2+)))
  253. (define-public enblend-enfuse
  254. (package
  255. (name "enblend-enfuse")
  256. (version "4.2")
  257. (source (origin
  258. (method url-fetch)
  259. (uri (string-append "mirror://sourceforge/enblend/"
  260. name "/"
  261. name "-" (version-major+minor version) "/"
  262. name "-" version ".tar.gz"))
  263. (sha256
  264. (base32
  265. "0j5x011ilalb47ssah50ag0a4phgh1b0wdgxdbbp1gcyjcjf60w7"))))
  266. (build-system gnu-build-system)
  267. (native-inputs
  268. `(("pkg-config" ,pkg-config)
  269. ("perl" ,perl)
  270. ("perl-timedate" ,perl-timedate)
  271. ;; for building the documentation
  272. ("gnuplot" ,gnuplot)
  273. ("help2man" ,help2man)
  274. ("imagemagick" ,imagemagick)
  275. ("libxml2" ,libxml2)
  276. ("texlive-minimal" ,texlive-tiny)
  277. ("tidy" ,tidy)
  278. ("transfig" ,transfig)))
  279. (inputs
  280. `(("boost" ,boost)
  281. ("gsl" ,gsl)
  282. ("lcms" ,lcms)
  283. ("libjpeg" ,libjpeg)
  284. ("libpng" ,libpng)
  285. ("libtiff" ,libtiff)
  286. ("openexr" ,openexr)
  287. ("vigra" ,vigra)
  288. ("zlib" ,zlib)))
  289. (arguments
  290. `(#:configure-flags `("--enable-openmp")))
  291. (home-page "http://enblend.sourceforge.net/")
  292. (synopsis "Tools for combining and blending images")
  293. (description
  294. "Enblend blends away the seams in a panoramic image mosaic using a
  295. multi-resolution spline. Enfuse merges different exposures of the same
  296. scene to produce an image that looks much like a tone-mapped image.")
  297. (license license:gpl2+)))
  298. (define-public lensfun
  299. (package
  300. (name "lensfun")
  301. (version "0.3.2")
  302. (source (origin
  303. (method url-fetch)
  304. (uri (string-append
  305. "mirror://sourceforge/lensfun/"
  306. version "/lensfun-" version ".tar.gz"))
  307. (sha256
  308. (base32
  309. "0cfk8jjhs9nbfjfdy98plrj9ayi59aph0nx6ppslgjhlcvacm2xf"))))
  310. (build-system cmake-build-system)
  311. (arguments
  312. `(,@(if (any (cute string-prefix? <> (or (%current-system)
  313. (%current-target-system)))
  314. '("x86_64" "i686"))
  315. ;; SSE and SSE2 are supported only on Intel processors.
  316. '()
  317. '(#:configure-flags '("-DBUILD_FOR_SSE=OFF" "-DBUILD_FOR_SSE2=OFF")))
  318. #:tests? #f)) ; There are no tests to run.
  319. (native-inputs
  320. `(("pkg-config" ,pkg-config)))
  321. (inputs
  322. `(("glib" ,glib)))
  323. (home-page "https://sourceforge.net/projects/lensfun/")
  324. (synopsis "Library to correct optical lens defects with a lens database")
  325. (description "Digital photographs are not ideal. Of course, the better is
  326. your camera, the better the results will be, but in any case if you look
  327. carefully at shots taken even by the most expensive cameras equipped with the
  328. most expensive lenses you will see various artifacts. It is very hard to make
  329. ideal cameras, because there are a lot of factors that affect the final image
  330. quality, and at some point camera and lens designers have to trade one factor
  331. for another to achieve the optimal image quality, within the given design
  332. restrictions and budget. But we all want ideal shots, don't we? So that's
  333. what's Lensfun is all about: rectifying the defects introduced by your
  334. photographic equipment.")
  335. ;; The libraries are licensed under the LGPL3, the programs are
  336. ;; licensed GPL3, and the database is license CC-BY-SA 3.0. See the
  337. ;; README.md file for this clarification.
  338. (license (list license:lgpl3 license:gpl3 license:cc-by-sa3.0))))
  339. (define-public darktable
  340. (package
  341. (name "darktable")
  342. (version "2.6.0")
  343. (source (origin
  344. (method url-fetch)
  345. (uri (string-append
  346. "https://github.com/darktable-org/darktable/releases/"
  347. "download/release-"
  348. version "/darktable-" version ".tar.xz"))
  349. (sha256
  350. (base32
  351. "0y04cx0a0rwdclmn16f5y0z2vnm7yxly291gzjgdhcn59a77sga8"))))
  352. (build-system cmake-build-system)
  353. (arguments
  354. `(#:tests? #f ; There are no tests.
  355. #:configure-flags '("-DBINARY_PACKAGE_BUILD=On")
  356. #:make-flags
  357. (list
  358. (string-append "CPATH=" (assoc-ref %build-inputs "ilmbase")
  359. "/include/OpenEXR:" (or (getenv "CPATH") "")))
  360. #:phases
  361. (modify-phases %standard-phases
  362. (add-before 'configure 'set-ldflags
  363. (lambda* (#:key outputs #:allow-other-keys)
  364. (setenv "LDFLAGS"
  365. (string-append
  366. "-Wl,-rpath="
  367. (assoc-ref outputs "out") "/lib/darktable"))
  368. #t)))))
  369. (native-inputs
  370. `(("llvm" ,llvm-3.9.1)
  371. ("clang" ,clang-3.9.1)))
  372. (inputs
  373. `(("libxslt" ,libxslt)
  374. ("libxml2" ,libxml2)
  375. ("pugixml" ,pugixml)
  376. ("gtk+" ,gtk+)
  377. ("sqlite" ,sqlite)
  378. ("libjpeg" ,libjpeg)
  379. ("libpng" ,libpng)
  380. ("cairo" ,cairo)
  381. ("lcms" ,lcms)
  382. ("exiv2" ,exiv2)
  383. ("libtiff" ,libtiff)
  384. ("curl" ,curl)
  385. ("libgphoto2" ,libgphoto2)
  386. ("dbus-glib" ,dbus-glib)
  387. ("openexr" ,openexr)
  388. ("ilmbase" ,ilmbase)
  389. ("libsoup" ,libsoup)
  390. ("python-jsonschema" ,python-jsonschema)
  391. ("intltool" ,intltool)
  392. ("perl" ,perl)
  393. ("pkg-config" ,pkg-config)
  394. ("libwebp" ,libwebp)
  395. ("lensfun" ,lensfun)
  396. ("librsvg" ,librsvg)
  397. ("json-glib" ,json-glib)
  398. ("freeimage" ,freeimage)))
  399. (home-page "https://www.darktable.org")
  400. (synopsis "Virtual lighttable and darkroom for photographers")
  401. (description "Darktable is a photography workflow application and RAW
  402. developer. It manages your digital negatives in a database, lets you view
  403. them through a zoomable lighttable and enables you to develop raw images
  404. and enhance them.")
  405. ;; see src/is_supported_platform.h for supported platforms
  406. (supported-systems '("i686-linux" "x86_64-linux" "aarch64-linux"))
  407. (license license:gpl3+)))
  408. (define-public hugin
  409. (package
  410. (name "hugin")
  411. (version "2018.0.0")
  412. (source (origin
  413. (method url-fetch)
  414. (uri (string-append "mirror://sourceforge/hugin/hugin/hugin-"
  415. (version-major+minor version)
  416. "/hugin-" version ".tar.bz2"))
  417. (sha256
  418. (base32
  419. "1jv5wpqbq49fhbl5g521g1qxhdm1rm7acxd18fr3n3n5d830vbyk"))))
  420. (build-system cmake-build-system)
  421. (native-inputs
  422. `(("gettext" ,gnu-gettext)
  423. ("pkg-config" ,pkg-config)))
  424. (inputs
  425. `(("boost" ,boost)
  426. ("enblend-enfuse" ,enblend-enfuse)
  427. ("exiv2" ,exiv2)
  428. ("fftw" ,fftw)
  429. ("flann" ,flann)
  430. ("freeglut" ,freeglut)
  431. ("glew" ,glew)
  432. ("lcms" ,lcms)
  433. ("libjpeg" ,libjpeg)
  434. ("libpano13" ,libpano13)
  435. ("libpng" ,libpng)
  436. ("libtiff" ,libtiff)
  437. ("libxi" ,libxi)
  438. ("libxmu" ,libxmu)
  439. ("mesa" ,mesa)
  440. ("openexr" ,openexr)
  441. ("sqlite" ,sqlite)
  442. ("vigra" ,vigra)
  443. ("wxwidgets" ,wxwidgets)
  444. ("zlib" ,zlib)))
  445. (arguments
  446. `(#:tests? #f ; no check target
  447. #:configure-flags
  448. (list
  449. ;; The header files of ilmbase (propagated by openexr) are not found
  450. ;; when included by the header files of openexr, and an explicit
  451. ;; flag needs to be set.
  452. (string-append "-DCMAKE_CXX_FLAGS=-I"
  453. (assoc-ref %build-inputs "ilmbase")
  454. "/include/OpenEXR")
  455. ;; Disable installation of the Python scripting interface.
  456. ;; It would require the additional inputs python and swig.
  457. ;; Installation would need to be tweaked, as it tries to install
  458. ;; into the python directory.
  459. "-DBUILD_HSI=OFF")
  460. #:phases
  461. (modify-phases %standard-phases
  462. (add-before 'configure 'substitute
  463. (lambda _
  464. (substitute* "src/hugin1/base_wx/StitchingExecutor.cpp"
  465. (("wxT\\(\"enblend\"\\)")
  466. (string-append "wxT(\"" (which "enblend") "\")"))
  467. (("wxT\\(\"enfuse\"\\)")
  468. (string-append "wxT(\"" (which "enfuse") "\")")))
  469. #t)))))
  470. (home-page "http://hugin.sourceforge.net/")
  471. (synopsis "Panorama photo stitcher")
  472. (description
  473. "Hugin is an easy to use panoramic imaging toolchain with a graphical
  474. user interface. It can be used to assemble a mosaic of photographs into
  475. a complete panorama and stitch any series of overlapping pictures.")
  476. (license license:gpl2+)))
  477. (define-public rawtherapee
  478. (package
  479. (name "rawtherapee")
  480. (version "5.5")
  481. (source (origin
  482. (method url-fetch)
  483. (uri (string-append "http://rawtherapee.com/shared/source/"
  484. "rawtherapee-" version ".tar.xz"))
  485. (sha256
  486. (base32
  487. "1w28a2rnxnw8hs7s8x8zkccgi5z5y653602jg7g86lfx6zxwjsf1"))))
  488. (build-system cmake-build-system)
  489. (arguments
  490. '(#:tests? #f ; no test suite
  491. #:build-type "release"
  492. #:configure-flags
  493. (list (string-append "-DLENSFUNDBDIR="
  494. (assoc-ref %build-inputs "lensfun")
  495. "/share/lensfun")
  496. ; Don't optimize the build for the host machine. See the file
  497. ; 'ProcessorTargets.cmake' in the source distribution for more
  498. ; information.
  499. "-DPROC_TARGET_NUMBER=1"
  500. ; These flags are recommended by upstream for distributed packages.
  501. ; See the file 'RELEASE_NOTES.txt' in the source distribution.
  502. "-O3"
  503. "-DCACHE_NAME_SUFFIX=\"\"")))
  504. (native-inputs
  505. `(("pkg-config" ,pkg-config)))
  506. (inputs
  507. `(("expat" ,expat)
  508. ("fftw" ,fftwf)
  509. ("glib" ,glib)
  510. ("glibmm" ,glibmm)
  511. ("gtk+" ,gtk+)
  512. ("gtkmm" ,gtkmm)
  513. ("lcms" ,lcms)
  514. ("lensfun" ,lensfun)
  515. ("libcanberra" ,libcanberra)
  516. ("libiptcdata" ,libiptcdata)
  517. ("libjpeg" ,libjpeg)
  518. ("libpng" ,libpng)
  519. ("libsigc++" ,libsigc++)
  520. ("libtiff" ,libtiff)
  521. ("zlib" ,zlib)))
  522. (home-page "http://rawtherapee.com")
  523. (synopsis "Raw image developing and processing")
  524. (description "RawTherapee is a raw image processing suite. It comprises a
  525. subset of image editing operations specifically aimed at non-destructive raw
  526. photo post-production and is primarily focused on improving a photographer's
  527. workflow by facilitating the handling of large numbers of images. Most raw
  528. formats are supported, including Pentax Pixel Shift, Canon Dual-Pixel, and those
  529. from Foveon and X-Trans sensors.")
  530. (license license:gpl3+)))