lolcode.scm 2.3 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2016 Nils Gillmann <ng0@n0.is>
  3. ;;;
  4. ;;; This file is part of GNU Guix.
  5. ;;;
  6. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  7. ;;; under the terms of the GNU General Public License as published by
  8. ;;; the Free Software Foundation; either version 3 of the License, or (at
  9. ;;; your option) any later version.
  10. ;;;
  11. ;;; GNU Guix is distributed in the hope that it will be useful, but
  12. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  13. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  14. ;;; GNU General Public License for more details.
  15. ;;;
  16. ;;; You should have received a copy of the GNU General Public License
  17. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  18. (define-module (gnu packages lolcode)
  19. #:use-module (gnu packages)
  20. #:use-module (gnu packages python)
  21. #:use-module (gnu packages readline)
  22. #:use-module (guix build-system cmake)
  23. #:use-module (guix download)
  24. #:use-module ((guix licenses) #:prefix license:)
  25. #:use-module (guix packages))
  26. (define-public lci
  27. (package
  28. (name "lci")
  29. (version "0.11.2")
  30. (source (origin
  31. (method url-fetch)
  32. (uri (string-append "https://github.com/justinmeza/lci/archive/v"
  33. version ".tar.gz"))
  34. (sha256
  35. (base32
  36. "1li7ikcrs7wqah7gqkirg0k61n6pm12w7pydin966x1sdn9na46b"))
  37. (file-name (string-append name "-" version ".tar.gz"))))
  38. (build-system cmake-build-system)
  39. (inputs
  40. `(("readline" ,readline)))
  41. (native-inputs
  42. `(("python-2" ,python-2))) ; for the tests
  43. (synopsis "LOLCODE interpreter written in C")
  44. (description
  45. "@code{lci} is a LOLCODE interpreter written in C and is designed to be
  46. correct, portable, fast, and precisely documented.
  47. @enumerate
  48. @item correct: Every effort has been made to test lci's conformance to the
  49. LOLCODE language specification. Unit tests come packaged with the lci source code.
  50. @item portable: lci follows the widely ported ANSI C specification allowing it
  51. to compile on a broad range of systems.
  52. @item fast: Much effort has gone into producing simple and efficient code
  53. whenever possible to the extent that the above points are not compromized.
  54. @end enumerate")
  55. (home-page "http://lolcode.org/")
  56. (license license:gpl3+)))