libdaemon.scm 2.8 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2013, 2014 Ludovic Courtès <ludo@gnu.org>
  3. ;;;
  4. ;;; This file is part of GNU Guix.
  5. ;;;
  6. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  7. ;;; under the terms of the GNU General Public License as published by
  8. ;;; the Free Software Foundation; either version 3 of the License, or (at
  9. ;;; your option) any later version.
  10. ;;;
  11. ;;; GNU Guix is distributed in the hope that it will be useful, but
  12. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  13. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  14. ;;; GNU General Public License for more details.
  15. ;;;
  16. ;;; You should have received a copy of the GNU General Public License
  17. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  18. (define-module (gnu packages libdaemon)
  19. #:use-module (guix licenses)
  20. #:use-module (guix packages)
  21. #:use-module (guix download)
  22. #:use-module (guix build-system gnu))
  23. (define-public libdaemon
  24. (package
  25. (name "libdaemon")
  26. (version "0.14")
  27. (source (origin
  28. (method url-fetch)
  29. (uri (list
  30. (string-append
  31. "mirror://debian/pool/main/libd/libdaemon/libdaemon_"
  32. version ".orig.tar.gz")
  33. "http://pkgs.fedoraproject.org/repo/pkgs/libdaemon/libdaemon-0.14.tar.gz/509dc27107c21bcd9fbf2f95f5669563/libdaemon-0.14.tar.gz"
  34. ;; This used to be the canonical URL but it vanished.
  35. ;; See <http://bugs.gnu.org/18639>.
  36. ;; (string-append
  37. ;; "http://0pointer.de/lennart/projects/libdaemon/libdaemon-"
  38. ;; version ".tar.gz")
  39. ))
  40. (sha256
  41. (base32
  42. "0d5qlq5ab95wh1xc87rqrh1vx6i8lddka1w3f1zcqvcqdxgyn8zx"))
  43. (file-name (string-append name "-" version ".tar.gz"))))
  44. (build-system gnu-build-system)
  45. ;; XXX: Stale URL, missing replacement. See <http://bugs.gnu.org/18639>.
  46. (home-page "http://0pointer.de/lennart/projects/libdaemon/")
  47. (synopsis "Lightweight C library that eases the writing of UNIX daemons")
  48. (description
  49. "Libdaemon is a lightweight C library that eases the writing of UNIX
  50. daemons. It consists of the following parts:
  51. • A wrapper around fork() which does the correct daemonization procedure of
  52. a process
  53. • A wrapper around syslog() for simpler and compatible log output to Syslog
  54. or STDERR
  55. • An API for writing PID files
  56. • An API for serializing UNIX signals into a pipe for usage with select() or
  57. poll()
  58. • An API for running subprocesses with STDOUT and STDERR redirected to
  59. syslog.
  60. APIs like these are used in most daemon software available. It is not that
  61. simple to get it done right and code duplication is not a goal.")
  62. (license lgpl2.1+)))