kde.scm 20 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
  3. ;;; Copyright © 2016, 2017 Thomas Danckaert <post@thomasdanckaert.be>
  4. ;;; Copyright © 2017, 2018 Mark Meyer <mark@ofosos.org>
  5. ;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
  6. ;;; Copyright © 2018 Gábor Boskovits <boskovits@gmail.com>
  7. ;;;
  8. ;;; This file is part of GNU Guix.
  9. ;;;
  10. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  11. ;;; under the terms of the GNU General Public License as published by
  12. ;;; the Free Software Foundation; either version 3 of the License, or (at
  13. ;;; your option) any later version.
  14. ;;;
  15. ;;; GNU Guix is distributed in the hope that it will be useful, but
  16. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  17. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  18. ;;; GNU General Public License for more details.
  19. ;;;
  20. ;;; You should have received a copy of the GNU General Public License
  21. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  22. (define-module (gnu packages kde)
  23. #:use-module (guix build-system cmake)
  24. #:use-module (guix download)
  25. #:use-module (guix git-download)
  26. #:use-module ((guix licenses) #:prefix license:)
  27. #:use-module (guix packages)
  28. #:use-module (guix utils)
  29. #:use-module (gnu packages algebra)
  30. #:use-module (gnu packages apr)
  31. #:use-module (gnu packages boost)
  32. #:use-module (gnu packages compression)
  33. #:use-module (gnu packages curl)
  34. #:use-module (gnu packages documentation)
  35. #:use-module (gnu packages gettext)
  36. #:use-module (gnu packages ghostscript)
  37. #:use-module (gnu packages gl)
  38. #:use-module (gnu packages gnome)
  39. #:use-module (gnu packages graphics)
  40. #:use-module (gnu packages image)
  41. #:use-module (gnu packages kde-frameworks)
  42. #:use-module (gnu packages kde-plasma)
  43. #:use-module (gnu packages llvm)
  44. #:use-module (gnu packages maths)
  45. #:use-module (gnu packages pdf)
  46. #:use-module (gnu packages perl)
  47. #:use-module (gnu packages photo)
  48. #:use-module (gnu packages pkg-config)
  49. #:use-module (gnu packages tls)
  50. #:use-module (gnu packages qt)
  51. #:use-module (gnu packages version-control)
  52. #:use-module (gnu packages video)
  53. #:use-module (gnu packages xorg))
  54. (define-public kdenlive
  55. (let ((version "18.08.1"))
  56. (package
  57. (name "kdenlive")
  58. (version version)
  59. (source
  60. (origin
  61. (method git-fetch)
  62. (uri (git-reference
  63. (url "git://anongit.kde.org/kdenlive.git")
  64. (commit (string-append "v" version))))
  65. (file-name (string-append name "-" version "-checkout"))
  66. (sha256
  67. (base32
  68. "0ifnaclsz7w08mc485i3j1kkcpd1m8q5qamckrfwc375ac13xf4g"))))
  69. (build-system cmake-build-system)
  70. (native-inputs
  71. `(("extra-cmake-modules" ,extra-cmake-modules)
  72. ("qttools" ,qttools)))
  73. (propagated-inputs
  74. `(("mlt" ,mlt)))
  75. (inputs
  76. `(("shared-mime-info" ,shared-mime-info)
  77. ("frei0r-plugins" ,frei0r-plugins)
  78. ("qtbase" ,qtbase)
  79. ("qtscript" ,qtscript)
  80. ("qtsvg" ,qtsvg)
  81. ("kparts" ,kparts)
  82. ("knotifications" ,knotifications)
  83. ("karchive" ,karchive)
  84. ("kdbusaddons" ,kdbusaddons)
  85. ("kcrash" ,kcrash)
  86. ("kguiaddons" ,kguiaddons)
  87. ("knewstuff" ,knewstuff)
  88. ("knotifyconfig" ,knotifyconfig)
  89. ("kfilemetadata" ,kfilemetadata)
  90. ("kdoctools" ,kdoctools)
  91. ("kdeclarative" ,kdeclarative)
  92. ("qtdeclarative" ,qtdeclarative)
  93. ("qtquickcontrols" ,qtquickcontrols)
  94. ("kiconthemes" ,kiconthemes)
  95. ("qtgraphicaleffects" ,qtgraphicaleffects)
  96. ("kplotting" ,kplotting)))
  97. (arguments
  98. `(#:phases
  99. (modify-phases %standard-phases
  100. (add-after 'install 'wrap-executable
  101. (lambda* (#:key inputs outputs #:allow-other-keys)
  102. (let* ((out (assoc-ref outputs "out"))
  103. (qtquickcontrols (assoc-ref inputs "qtquickcontrols"))
  104. (qtbase (assoc-ref inputs "qtbase"))
  105. (qtdeclarative (assoc-ref inputs "qtdeclarative"))
  106. (frei0r (assoc-ref inputs "frei0r-plugins"))
  107. (qml "/lib/qt5/qml"))
  108. (wrap-program (string-append out "/bin/kdenlive")
  109. `("QT_PLUGIN_PATH" ":" prefix
  110. ,(map (lambda (label)
  111. (string-append (assoc-ref inputs label)
  112. "/lib/qt5/plugins/"))
  113. '("qtbase" "qtsvg")))
  114. `("FREI0R_PATH" ":" =
  115. (,(string-append frei0r "/lib/frei0r-1/")))
  116. `("QT_QPA_PLATFORM_PLUGIN_PATH" ":" =
  117. (,(string-append qtbase "/lib/qt5/plugins/platforms")))
  118. `("QML2_IMPORT_PATH" ":" prefix
  119. (,(string-append qtquickcontrols qml)
  120. ,(string-append qtdeclarative qml)))))
  121. #t)))))
  122. (home-page "https://kdenlive.org")
  123. (synopsis "Non-linear video editor")
  124. (description "Kdenlive is an acronym for KDE Non-Linear Video Editor.
  125. Non-linear video editing is much more powerful than beginner's (linear)
  126. editors, hence it requires a bit more organization before starting. However,
  127. it is not reserved to specialists and can be used for small personal
  128. projects.")
  129. (license license:gpl2+))))
  130. (define-public kdevelop
  131. (package
  132. (name "kdevelop")
  133. (version "5.1.2")
  134. (source
  135. (origin
  136. (method url-fetch)
  137. (uri (string-append "mirror://kde/stable/kdevelop"
  138. "/" version "/src/kdevelop-"
  139. version ".tar.xz"))
  140. (sha256
  141. (base32
  142. "1iqaq0ilijjigqb34v5wq9in6bnjs0p9cmgbygjmy53xhh3yhm5g"))))
  143. (build-system cmake-build-system)
  144. (native-inputs
  145. `(("extra-cmake-modules" ,extra-cmake-modules)
  146. ("pkg-config" ,pkg-config)
  147. ("qttools" ,qttools)))
  148. (inputs
  149. `(("kdevplatform" ,kdevplatform)
  150. ("kdevelop-pg-qt" ,kdevelop-pg-qt)
  151. ("qtbase" ,qtbase)
  152. ("qtdeclarative" ,qtdeclarative)
  153. ("qtquickcontrols" ,qtquickcontrols)
  154. ("qtwebkit" ,qtwebkit)
  155. ("karchive" ,karchive)
  156. ("kcmutils" ,kcmutils)
  157. ("kconfig" ,kconfig)
  158. ("kdeclarative" ,kdeclarative)
  159. ("kdoctools" ,kdoctools)
  160. ("kguiaddons" ,kguiaddons)
  161. ("ki18n" ,ki18n)
  162. ("kio" ,kio)
  163. ("kiconthemes" ,kiconthemes)
  164. ("kitemmodels" ,kitemmodels)
  165. ("kitemviews" ,kitemviews)
  166. ("kjobwidgets" ,kjobwidgets)
  167. ("knotifyconfig" ,knotifyconfig)
  168. ("knotifications" ,knotifications)
  169. ("kparts" ,kparts)
  170. ("kcrash" ,kcrash)
  171. ("knewstuff" ,knewstuff)
  172. ("krunner" ,krunner)
  173. ("kxmlgui" ,kxmlgui)
  174. ("libksysguard" ,libksysguard)
  175. ("threadweaver" ,threadweaver)
  176. ("ktexteditor" ,ktexteditor)
  177. ("kwindowsystem" ,kwindowsystem)
  178. ("plasma" ,plasma-framework)
  179. ("grantlee" ,grantlee)
  180. ("libepoxy" ,libepoxy)
  181. ("clang" ,clang)
  182. ("shared-mime-info" ,shared-mime-info)))
  183. (arguments
  184. `(#:phases
  185. (modify-phases %standard-phases
  186. (delete 'check) ;; there are some issues with the test suite
  187. (add-after 'install 'wrap-executable
  188. (lambda* (#:key inputs outputs #:allow-other-keys)
  189. (let* ((out (assoc-ref outputs "out"))
  190. (kdevplatform (assoc-ref inputs "kdevplatform"))
  191. (kio (assoc-ref inputs "kio"))
  192. (kcmutils (assoc-ref inputs "kcmutils"))
  193. (qtquickcontrols (assoc-ref inputs "qtquickcontrols"))
  194. (qtbase (assoc-ref inputs "qtbase"))
  195. (qtdeclarative (assoc-ref inputs "qtdeclarative"))
  196. (qml "/qml"))
  197. (wrap-program (string-append out "/bin/kdevelop")
  198. `("XDG_DATA_DIRS" ":" prefix
  199. ,(map (lambda (s) (string-append s "/share"))
  200. (list out kdevplatform kcmutils)))
  201. `("QT_QPA_PLATFORM_PLUGIN_PATH" ":" =
  202. (,(string-append qtbase "/plugins/platforms")))
  203. `("QT_PLUGIN_PATH" ":" prefix
  204. ,(map (lambda (s) (string-append s "/lib/plugins"))
  205. (list out kdevplatform kio)))
  206. `("QML2_IMPORT_PATH" ":" prefix
  207. (,(string-append qtquickcontrols qml)
  208. ,(string-append qtdeclarative qml))))))))))
  209. (home-page "https://kdevelop.org")
  210. (synopsis "IDE for C, C++, Python, Javascript and PHP")
  211. (description "The KDevelop IDE provides semantic syntax highlighting, as
  212. well as code navigation and completion for C, C++ (using Clang/LLVM), QML,
  213. JavaScript, Python and PHP. It also integrates with a debugger, different
  214. build systems (CMake, QMake, custom Makefiles) and version control
  215. software (Git, Subversion, Mercurial, CVS and Bazaar).")
  216. (license license:lgpl2.1+)))
  217. (define-public kdevelop-pg-qt
  218. (package
  219. (name "kdevelop-pg-qt")
  220. (version "2.0.0")
  221. (source
  222. (origin
  223. (method url-fetch)
  224. (uri (string-append "https://github.com/KDE/kdevelop-pg-qt/archive/v"
  225. version ".tar.gz"))
  226. (file-name (string-append name "-" version ".tar.gz"))
  227. (sha256
  228. (base32 "1av8plqz7hyhrd07avnmn6ryslqlarmxn0pw7swzvb6ddiqp59j4"))))
  229. (native-inputs
  230. `(("extra-cmake-modules" ,extra-cmake-modules)))
  231. (inputs
  232. `(("qtbase" ,qtbase)))
  233. (build-system cmake-build-system)
  234. (home-page "https://kde.org")
  235. (synopsis "Parser generator library for KDevplatform")
  236. (description "KDevelop-PG-Qt is the parser generator used in KDevplatform
  237. for some KDevelop language plugins (Ruby, PHP, CSS...).")
  238. (license license:lgpl2.0+)))
  239. (define-public kdevplatform
  240. (package
  241. (name "kdevplatform")
  242. (version "5.1.2")
  243. (source (origin
  244. (method url-fetch)
  245. (uri (string-append "mirror://kde/stable/kdevelop"
  246. "/" version "/src/kdevplatform-"
  247. version ".tar.xz"))
  248. (sha256
  249. (base32
  250. "0jk6g1kiqpyjy8pca0236b9944gxqnymqv8ny6m8nrraannxs8p6"))))
  251. (build-system cmake-build-system)
  252. (native-inputs
  253. `(("extra-cmake-modules" ,extra-cmake-modules)
  254. ("pkg-config" ,pkg-config)))
  255. (inputs
  256. `(("apr" ,apr)
  257. ("apr-util" ,apr-util)
  258. ("boost" ,boost)
  259. ("karchive" ,karchive)
  260. ("kconfigwidgets" ,kconfigwidgets)
  261. ("kcmutils" ,kcmutils)
  262. ("kiconthemes" ,kiconthemes)
  263. ("kdeclarative" ,kdeclarative)
  264. ("kdoctools" ,kdoctools)
  265. ("kguiaddons" ,kguiaddons)
  266. ("kinit" ,kinit)
  267. ("kitemmodels" ,kitemmodels)
  268. ("knewstuff" ,knewstuff)
  269. ("knotifications" ,knotifications)
  270. ("knotifyconfig" ,knotifyconfig)
  271. ("kwindowsystem" ,kwindowsystem)
  272. ("kio" ,kio)
  273. ("ki18n" ,ki18n)
  274. ("kparts" ,kparts)
  275. ("kservice" ,kservice)
  276. ("grantlee" ,grantlee)
  277. ("libkomparediff2" ,libkomparediff2)
  278. ("sonnet" ,sonnet)
  279. ("threadweaver" ,threadweaver)
  280. ("ktexteditor" ,ktexteditor)
  281. ("qtbase" ,qtbase)
  282. ("qtdeclarative" ,qtdeclarative)
  283. ("qtscript" ,qtscript)
  284. ("qtwebkit" ,qtwebkit)
  285. ("qtx11extras" ,qtx11extras)
  286. ("plasma" ,plasma-framework)
  287. ("subversion" ,subversion)
  288. ("zlib" ,zlib)))
  289. (arguments
  290. `(#:phases
  291. (modify-phases %standard-phases
  292. (delete 'check)
  293. (add-after 'install 'check ;; add-after 'install
  294. (lambda* (#:key outputs #:allow-other-keys)
  295. (let ((out (assoc-ref outputs "out")))
  296. (setenv "CTEST_OUTPUT_ON_FAILURE" "1")
  297. (setenv "QT_PLUGIN_PATH"
  298. (string-append out "/lib/plugins:"
  299. (getenv "QT_PLUGIN_PATH")))
  300. (setenv "XDG_DATA_DIRS"
  301. (string-append out "/share:"
  302. (getenv "XDG_DATA_DIRS")))
  303. (zero?
  304. (system* "ctest" "-R" ;; almost all tests require a display
  305. "filteringstrategy|kdevvarlengtharray|kdevhash"))))))))
  306. (home-page "https://github.com/KDE/kdevplatform")
  307. (synopsis "Framework to build integrated development environments (IDEs)")
  308. (description "KDevPlatform is the basis of KDevelop and contains some
  309. plugins, as well as code to create plugins, or complete applications.")
  310. (license license:gpl3+)))
  311. (define-public krita
  312. (package
  313. (name "krita")
  314. (version "4.1.7.101")
  315. (source (origin
  316. (method url-fetch)
  317. (uri (string-append
  318. "mirror://kde/stable/krita/"
  319. (version-prefix version 3)
  320. "/" name "-" version ".tar.gz"))
  321. (sha256
  322. (base32
  323. "0pvghb17vj3y19wa1n1zfg3yl5206ir3y45znrgdgdw076m5pjav"))))
  324. (build-system cmake-build-system)
  325. (arguments
  326. `(#:tests? #f
  327. #:configure-flags
  328. (list "-DBUILD_TESTING=OFF" "-DKDE4_BUILD_TESTS=OFF"
  329. (string-append "-DWITH_FFTW3="
  330. (assoc-ref %build-inputs "fftw"))
  331. (string-append "-DWITH_GSL="
  332. (assoc-ref %build-inputs "gsl"))
  333. (string-append "-DWITH_LibRaw="
  334. (assoc-ref %build-inputs "libraw"))
  335. (string-append "-DWITH_TIFF="
  336. (assoc-ref %build-inputs "libtiff"))
  337. (string-append "-DCMAKE_CXX_FLAGS=-I"
  338. (assoc-ref %build-inputs "ilmbase")
  339. "/include/OpenEXR"))
  340. #:phases
  341. (modify-phases %standard-phases
  342. ;; Ensure that icons are found at runtime.
  343. ;; This works around <https://bugs.gnu.org/22138>.
  344. (add-after 'install 'wrap-executable
  345. (lambda* (#:key inputs outputs #:allow-other-keys)
  346. (let ((out (assoc-ref outputs "out"))
  347. (qt '("qtbase" "qtsvg")))
  348. (wrap-program (string-append out "/bin/krita")
  349. `("QT_PLUGIN_PATH" ":" prefix
  350. ,(map (lambda (label)
  351. (string-append (assoc-ref inputs label)
  352. "/lib/qt5/plugins/"))
  353. qt)))
  354. #t))))))
  355. (native-inputs
  356. `(("curl" ,curl)
  357. ("eigen" ,eigen)
  358. ("extra-cmake-modules" ,extra-cmake-modules)
  359. ("gettext-minimal" ,gettext-minimal)
  360. ("kitemmodels" ,kitemmodels)
  361. ("qwt" ,qwt)
  362. ("vc" ,vc)))
  363. (inputs
  364. `(("qtbase" ,qtbase)
  365. ("qtdeclarative" ,qtdeclarative)
  366. ("qtmultimedia" ,qtmultimedia)
  367. ("qtx11extras" ,qtx11extras)
  368. ("qtsvg" ,qtsvg)
  369. ("karchive" ,karchive)
  370. ("kcompletion" ,kcompletion)
  371. ("kconfig" ,kconfig)
  372. ("kcoreaddons" ,kcoreaddons)
  373. ("kcrash" ,kcrash)
  374. ("kguiaddons" ,kguiaddons)
  375. ("ki18n" ,ki18n)
  376. ("kiconthemes" ,kiconthemes)
  377. ("kio" ,kio)
  378. ("kitemviews" ,kitemviews)
  379. ("kwidgetsaddons" ,kwidgetsaddons)
  380. ("kwindowsystem" ,kwindowsystem)
  381. ("kxmlgui" ,kxmlgui)
  382. ("boost" ,boost)
  383. ("exiv2" ,exiv2)
  384. ("lcms" ,lcms)
  385. ("libpng" ,libpng)
  386. ("libjpeg-turbo" ,libjpeg-turbo)
  387. ("zlib" ,zlib)
  388. ("libx11" ,libx11)
  389. ("libxcb" ,libxcb)
  390. ("libxi" ,libxi)
  391. ("fftw" ,fftw)
  392. ("gsl" ,gsl)
  393. ("poppler-qt5" ,poppler-qt5)
  394. ("libraw" ,libraw-0.18)
  395. ("libtiff" ,libtiff)
  396. ("perl" ,perl)
  397. ("ilmbase" ,ilmbase)
  398. ("openexr" ,openexr)))
  399. (home-page "https://krita.org")
  400. (synopsis "Digital painting application")
  401. (description
  402. "Krita is a professional painting tool designed for concept artists,
  403. illustrators, matte and texture artists, and the VFX industry. Notable
  404. features include brush stabilizers, brush engines and wrap-around mode.")
  405. (license license:gpl2+)))
  406. (define-public kholidays
  407. (package
  408. (name "kholidays")
  409. (version "17.12.1")
  410. (source
  411. (origin
  412. (method url-fetch)
  413. (uri (string-append
  414. "mirror://kde/stable/applications/" version "/src/"
  415. name "-" version ".tar.xz"))
  416. (sha256
  417. (base32 "0595d7wbnz8kyq1bnivdrp20lwdp8ykvdll1fmb0fgm4q24z0cl8"))))
  418. (build-system cmake-build-system)
  419. (arguments
  420. `(#:phases
  421. (modify-phases %standard-phases
  422. (add-before 'check 'check-setup
  423. (lambda _
  424. ;; blacklist a failing test function TODO: make it pass
  425. (with-output-to-file "autotests/BLACKLIST"
  426. (lambda _
  427. (display "[testDefaultRegions]\n*\n")))
  428. #t)))))
  429. (native-inputs
  430. `(("extra-cmake-modules" ,extra-cmake-modules)
  431. ("qttools" ,qttools)))
  432. (inputs
  433. `(("qtbase" ,qtbase)
  434. ("qtdeclarative" ,qtdeclarative)))
  435. (home-page "https://cgit.kde.org/kholidays.git")
  436. (synopsis "Library for regional holiday information")
  437. (description "This library provides a C++ API that determines holiday and
  438. other special events for a geographical region.")
  439. (license license:lgpl2.0+)))
  440. (define-public libkomparediff2
  441. (package
  442. (name "libkomparediff2")
  443. (version "17.12.3")
  444. (source
  445. (origin
  446. (method url-fetch)
  447. (uri (string-append "mirror://kde/stable/applications"
  448. "/" version "/src/" name "-" version ".tar.xz"))
  449. (file-name (string-append name "-" version ".tar.gz"))
  450. (sha256
  451. (base32
  452. "0w6p8lvm2rn7y4qz0x3s87lwh1758xnyhwkkkng55n8v9rpjjw7l"))))
  453. (native-inputs
  454. `(("extra-cmake-modules" ,extra-cmake-modules)
  455. ("pkg-config" ,pkg-config)))
  456. (inputs
  457. `(("kcodecs" ,kcodecs)
  458. ("kconfig" ,kconfig)
  459. ("kcoreaddons" ,kcoreaddons)
  460. ("ki18n" ,ki18n)
  461. ("kio" ,kio)
  462. ("kxmlgui" ,kxmlgui)
  463. ("qtbase" ,qtbase)))
  464. (build-system cmake-build-system)
  465. (home-page "https://kde.org")
  466. (synopsis "Library to compare files and strings, used in Kompare and KDevelop")
  467. (description "Libkomparediff2 is a library to work with diffs and patches,
  468. used in KDE development tools Kompare and KDevelop.")
  469. ;; GPL, some files are also licensed under LGPL or BSD, see COPYING in the
  470. ;; source archive
  471. (license (list license:gpl2+ license:lgpl2.0+ license:bsd-3))))
  472. (define-public qca
  473. (package
  474. (name "qca")
  475. (version "2.1.3")
  476. (source
  477. (origin
  478. (method url-fetch)
  479. (uri (string-append "mirror://kde/stable/qca/" version
  480. "/src/qca-" version ".tar.xz"))
  481. (sha256
  482. (base32
  483. "0lz3n652z208daxypdcxiybl0a9fnn6ida0q7fh5f42269mdhgq0"))))
  484. (build-system cmake-build-system)
  485. (native-inputs
  486. `(("pkg-config" ,pkg-config)))
  487. (inputs
  488. `(("openssl" ,openssl)
  489. ("qtbase" ,qtbase)))
  490. (home-page "https://userbase.kde.org/QCA")
  491. (synopsis "Libraries for the Qt Cryptographic Architecture")
  492. (description "The Qt Cryptographic Architecture (QCA) provides a
  493. straightforward and cross-platform API for a range of cryptographic features,
  494. including SSL/TLS, X.509 certificates, SASL, OpenPGP, S/MIME CMS, and smart
  495. cards.")
  496. (license license:lgpl2.1)))
  497. (define-public snorenotify
  498. (package
  499. (name "snorenotify")
  500. (version "0.7.0")
  501. (source
  502. (origin
  503. (method url-fetch)
  504. (uri (string-append "mirror://kde/stable/snorenotify/"
  505. version "/src/snorenotify-" version ".tar.xz"))
  506. (sha256
  507. (base32
  508. "0jz6ivk90h7iwgyxar7xzzj8yvzn6s1my6cqs9bdnwqswfk1nhbd"))))
  509. (build-system cmake-build-system)
  510. (arguments
  511. `(#:tests? #f)) ; both tests fail, require display
  512. (inputs
  513. `(("extra-cmake-modules" ,extra-cmake-modules)
  514. ("qtbase" ,qtbase)
  515. ("qttools" ,qttools)))
  516. (home-page "https://techbase.kde.org/Projects/Snorenotify")
  517. (synopsis "Qt notification framework")
  518. (description "Snorenotify is a multi platform Qt notification framework.
  519. Using a plugin system it is possible to create notifications with many
  520. different notification systems.")
  521. (license license:lgpl3)))