12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182838485 |
- ;;; GNU Guix --- Functional package management for GNU
- ;;; Copyright © 2017, 2018 Arun Isaac <arunisaac@systemreboot.net>
- ;;;
- ;;; This file is part of GNU Guix.
- ;;;
- ;;; GNU Guix is free software; you can redistribute it and/or modify it
- ;;; under the terms of the GNU General Public License as published by
- ;;; the Free Software Foundation; either version 3 of the License, or (at
- ;;; your option) any later version.
- ;;;
- ;;; GNU Guix is distributed in the hope that it will be useful, but
- ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
- ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- ;;; GNU General Public License for more details.
- ;;;
- ;;; You should have received a copy of the GNU General Public License
- ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
- (define-module (gnu packages ham-radio)
- #:use-module ((guix licenses) #:prefix license:)
- #:use-module (guix packages)
- #:use-module (guix download)
- #:use-module (gnu packages gtk)
- #:use-module (gnu packages libusb)
- #:use-module (gnu packages pkg-config)
- #:use-module (gnu packages python)
- #:use-module (gnu packages python-xyz)
- #:use-module (gnu packages xml)
- #:use-module (guix build-system cmake)
- #:use-module (guix build-system python))
- (define-public rtl-sdr
- (package
- (name "rtl-sdr")
- (version "0.5.3")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "https://cgit.osmocom.org/rtl-sdr/snapshot/rtl-sdr-"
- version ".tar.xz"))
- (sha256
- (base32
- "08awca3v28sa4lxym4r81pzf0la0j86wbmpyhv3xd53an9gkpjy9"))))
- (build-system cmake-build-system)
- (inputs
- `(("libusb" ,libusb)))
- (native-inputs
- `(("pkg-config" ,pkg-config)))
- (arguments
- `(#:configure-flags '("-DDETACH_KERNEL_DRIVER=ON")
- #:tests? #f)) ; No tests
- (home-page "https://osmocom.org/projects/sdr/wiki/rtl-sdr")
- (synopsis "Software defined radio driver for Realtek RTL2832U")
- (description "DVB-T dongles based on the Realtek RTL2832U can be used as a
- cheap software defined radio, since the chip allows transferring the raw I/Q
- samples to the host. @code{rtl-sdr} provides drivers for this purpose.")
- (license license:gpl2+)))
- (define-public chirp
- (package
- (name "chirp")
- (version "20181205")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "https://trac.chirp.danplanet.com/chirp_daily/daily-"
- version "/chirp-daily-" version ".tar.gz"))
- (sha256
- (base32
- "1cp280b95j39xaxs50zn55jigg7pyfpm9n098hmsyxrplqn8z43c"))))
- (build-system python-build-system)
- (inputs
- `(("python2-libxml2" ,python2-libxml2)
- ("python2-pygtk" ,python2-pygtk)
- ("python2-pyserial" ,python2-pyserial)))
- (arguments
- `(#:python ,python-2))
- (home-page "https://chirp.danplanet.com")
- (synopsis "Cross-radio programming tool")
- (description "Chirp is a cross-radio programming tool. It supports a
- growing list of radios across several manufacturers and allows transferring of
- memory contents between them.")
- (license (list license:gpl3+
- license:lgpl3+)))) ; chirp/elib_intl.py
|