ham-radio.scm 3.2 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182838485
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2017, 2018 Arun Isaac <arunisaac@systemreboot.net>
  3. ;;;
  4. ;;; This file is part of GNU Guix.
  5. ;;;
  6. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  7. ;;; under the terms of the GNU General Public License as published by
  8. ;;; the Free Software Foundation; either version 3 of the License, or (at
  9. ;;; your option) any later version.
  10. ;;;
  11. ;;; GNU Guix is distributed in the hope that it will be useful, but
  12. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  13. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  14. ;;; GNU General Public License for more details.
  15. ;;;
  16. ;;; You should have received a copy of the GNU General Public License
  17. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  18. (define-module (gnu packages ham-radio)
  19. #:use-module ((guix licenses) #:prefix license:)
  20. #:use-module (guix packages)
  21. #:use-module (guix download)
  22. #:use-module (gnu packages gtk)
  23. #:use-module (gnu packages libusb)
  24. #:use-module (gnu packages pkg-config)
  25. #:use-module (gnu packages python)
  26. #:use-module (gnu packages python-xyz)
  27. #:use-module (gnu packages xml)
  28. #:use-module (guix build-system cmake)
  29. #:use-module (guix build-system python))
  30. (define-public rtl-sdr
  31. (package
  32. (name "rtl-sdr")
  33. (version "0.5.3")
  34. (source
  35. (origin
  36. (method url-fetch)
  37. (uri (string-append "https://cgit.osmocom.org/rtl-sdr/snapshot/rtl-sdr-"
  38. version ".tar.xz"))
  39. (sha256
  40. (base32
  41. "08awca3v28sa4lxym4r81pzf0la0j86wbmpyhv3xd53an9gkpjy9"))))
  42. (build-system cmake-build-system)
  43. (inputs
  44. `(("libusb" ,libusb)))
  45. (native-inputs
  46. `(("pkg-config" ,pkg-config)))
  47. (arguments
  48. `(#:configure-flags '("-DDETACH_KERNEL_DRIVER=ON")
  49. #:tests? #f)) ; No tests
  50. (home-page "https://osmocom.org/projects/sdr/wiki/rtl-sdr")
  51. (synopsis "Software defined radio driver for Realtek RTL2832U")
  52. (description "DVB-T dongles based on the Realtek RTL2832U can be used as a
  53. cheap software defined radio, since the chip allows transferring the raw I/Q
  54. samples to the host. @code{rtl-sdr} provides drivers for this purpose.")
  55. (license license:gpl2+)))
  56. (define-public chirp
  57. (package
  58. (name "chirp")
  59. (version "20181205")
  60. (source
  61. (origin
  62. (method url-fetch)
  63. (uri (string-append "https://trac.chirp.danplanet.com/chirp_daily/daily-"
  64. version "/chirp-daily-" version ".tar.gz"))
  65. (sha256
  66. (base32
  67. "1cp280b95j39xaxs50zn55jigg7pyfpm9n098hmsyxrplqn8z43c"))))
  68. (build-system python-build-system)
  69. (inputs
  70. `(("python2-libxml2" ,python2-libxml2)
  71. ("python2-pygtk" ,python2-pygtk)
  72. ("python2-pyserial" ,python2-pyserial)))
  73. (arguments
  74. `(#:python ,python-2))
  75. (home-page "https://chirp.danplanet.com")
  76. (synopsis "Cross-radio programming tool")
  77. (description "Chirp is a cross-radio programming tool. It supports a
  78. growing list of radios across several manufacturers and allows transferring of
  79. memory contents between them.")
  80. (license (list license:gpl3+
  81. license:lgpl3+)))) ; chirp/elib_intl.py