gnustep.scm 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
  3. ;;; Copyright © 2016, 2017 Kei Kebreau <kkebreau@posteo.net>
  4. ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
  5. ;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
  6. ;;;
  7. ;;; This file is part of GNU Guix.
  8. ;;;
  9. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  10. ;;; under the terms of the GNU General Public License as published by
  11. ;;; the Free Software Foundation; either version 3 of the License, or (at
  12. ;;; your option) any later version.
  13. ;;;
  14. ;;; GNU Guix is distributed in the hope that it will be useful, but
  15. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  16. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  17. ;;; GNU General Public License for more details.
  18. ;;;
  19. ;;; You should have received a copy of the GNU General Public License
  20. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  21. (define-module (gnu packages gnustep)
  22. #:use-module (guix download)
  23. #:use-module (guix packages)
  24. #:use-module (guix build-system gnu)
  25. #:use-module (guix licenses)
  26. #:use-module (gnu packages)
  27. #:use-module (gnu packages base)
  28. #:use-module (gnu packages xorg)
  29. #:use-module (gnu packages libffcall)
  30. #:use-module (gnu packages gnome)
  31. #:use-module (gnu packages gtk)
  32. #:use-module (gnu packages texinfo)
  33. #:use-module (gnu packages autotools)
  34. #:use-module (gnu packages glib)
  35. #:use-module (gnu packages fontutils)
  36. #:use-module (gnu packages image)
  37. #:use-module (gnu packages pkg-config)
  38. #:use-module (gnu packages xml)
  39. #:use-module (ice-9 match))
  40. (define-public gnustep-make
  41. (package
  42. (name "gnustep-make")
  43. (version "2.7.0")
  44. (source (origin
  45. (method url-fetch)
  46. (uri (string-append "ftp://ftp.gnustep.org/pub/gnustep/core/"
  47. name "-" version ".tar.gz"))
  48. (sha256
  49. (base32
  50. "1khiygfkz0zhh9b5nybn40g0xnnjxchk24n49hff1bwanszir84h"))))
  51. (build-system gnu-build-system)
  52. (arguments
  53. '(#:tests? #f)) ; no check target
  54. (native-inputs
  55. `(("which" ,which)))
  56. (home-page "http://gnustep.org")
  57. (synopsis "GNUstep make package")
  58. (description "The makefile package is a simple, powerful and extensible way
  59. to write makefiles for a GNUstep-based project. It allows the user to write a
  60. project without having to deal with the complex issues associated with
  61. configuration, building, installation, and packaging. It also allows the user
  62. to easily create cross-compiled binaries.")
  63. (license gpl3+)))
  64. (define-public windowmaker
  65. (package
  66. (name "windowmaker")
  67. (version "0.95.8")
  68. (synopsis "NeXTSTEP-like window manager")
  69. (source (origin
  70. (method url-fetch)
  71. (uri (string-append
  72. "http://windowmaker.org/pub/source/release/WindowMaker-"
  73. version ".tar.gz"))
  74. (sha256
  75. (base32
  76. "12p8kljqgx5hnic0zvs5mxwp7kg21sb6qjagb2qw8ydvf5amrgwx"))))
  77. (build-system gnu-build-system)
  78. (arguments
  79. `(#:modules ((guix build gnu-build-system)
  80. (guix build utils)
  81. (ice-9 match))
  82. #:phases
  83. (modify-phases %standard-phases
  84. (add-before 'configure 'pre-configure
  85. (lambda* (#:key outputs #:allow-other-keys)
  86. ;; 'wmaker' wants to invoke 'wmaker.inst' the first time,
  87. ;; and the 'wmsetbg', so make sure it uses the right ones.
  88. ;; We can't use a wrapper here because that would pollute
  89. ;; $PATH in the whole session.
  90. (let* ((out (assoc-ref outputs "out"))
  91. (bin (string-append out "/bin")))
  92. (substitute* "src/main.c"
  93. (("\"wmaker\\.inst")
  94. (string-append "\"" bin "/wmaker.inst")))
  95. (substitute* '("src/defaults.c" "WPrefs.app/Menu.c")
  96. (("\"wmsetbg")
  97. (string-append "\"" bin "/wmsetbg")))
  98. ;; Add enough cells to the command character array to
  99. ;; allow passing our large path to the wmsetbg binary.
  100. ;; The path to wmsetbg in Guix requires 67 extra characters.
  101. (substitute* "src/defaults.c"
  102. (("len = strlen\\(text\\) \\+ 40;")
  103. (string-append "len = strlen(text) + 107;")))
  104. #t)))
  105. (add-after 'install 'install-xsession
  106. (lambda* (#:key outputs #:allow-other-keys)
  107. (let* ((out (assoc-ref outputs "out"))
  108. (xsessions (string-append out "/share/xsessions")))
  109. (mkdir-p xsessions)
  110. (call-with-output-file
  111. (string-append xsessions "/windowmaker.desktop")
  112. (lambda (port)
  113. (format port "~
  114. [Desktop Entry]~@
  115. Name=Window Maker~@
  116. Comment=~a~@
  117. Exec=~a/bin/wmaker~@
  118. Type=Application~%"
  119. (string-map (match-lambda
  120. (#\newline #\space)
  121. (chr chr))
  122. ,synopsis) out))))
  123. #t))
  124. (add-after 'install-xsession 'wrap
  125. (lambda* (#:key outputs #:allow-other-keys)
  126. (let* ((out (assoc-ref outputs "out"))
  127. (bin (string-append out "/bin")))
  128. ;; In turn, 'wmaker.inst' wants to invoke 'wmmenugen'
  129. ;; etc., so make sure everything is in $PATH.
  130. (wrap-program (string-append bin "/wmaker.inst")
  131. `("PATH" ":" prefix (,bin)))
  132. #t))))))
  133. (inputs
  134. `(("libxmu" ,libxmu)
  135. ("libxft" ,libxft)
  136. ("libx11" ,libx11)
  137. ("libxinerama" ,libxinerama)
  138. ("fontconfig" ,fontconfig)
  139. ("libjpeg" ,libjpeg)
  140. ("giflib" ,giflib)
  141. ("libpng" ,libpng)
  142. ("libtiff" ,libtiff)))
  143. (native-inputs
  144. `(("pkg-config" ,pkg-config)))
  145. (home-page "http://windowmaker.org/")
  146. (description
  147. "Window Maker is an X11 window manager originally designed to provide
  148. integration support for the GNUstep Desktop Environment. In every way
  149. possible, it reproduces the elegant look and feel of the NeXTSTEP user
  150. interface. It is fast, feature rich, easy to configure, and easy to use.")
  151. ;; Artwork is distributed under the WTFPL.
  152. (license gpl2+)))
  153. (define-public wmbattery
  154. (package
  155. (name "wmbattery")
  156. (version "2.51")
  157. (source (origin
  158. (method url-fetch)
  159. (uri (string-append
  160. "mirror://debian/pool/main/w/wmbattery/wmbattery_"
  161. version ".orig.tar.gz"))
  162. (sha256
  163. (base32
  164. "084a3irxbmgms4bqaga80mlx9wgvlkx6d2w0ns939yrpfzg87laj"))))
  165. (build-system gnu-build-system)
  166. (arguments '(#:tests? #f)) ; no "check" target
  167. (inputs
  168. `(("glib" ,glib)
  169. ("libx11" ,libx11)
  170. ("libxext" ,libxext)
  171. ("libxpm" ,libxpm)
  172. ("upower" ,upower)))
  173. (native-inputs
  174. `(("autoconf" ,autoconf)
  175. ("automake" ,automake)
  176. ("pkg-config" ,pkg-config)))
  177. (home-page "http://www.dockapps.net/wmbattery")
  178. (synopsis "Display laptop battery info")
  179. (description
  180. "Wmbattery displays the status of your laptop's battery in a small icon.
  181. This includes if it is plugged in, if the battery is charging, how many minutes
  182. of battery life remain, battery life remaining (with both a percentage and a
  183. graph), and battery status (high - green, low - yellow, or critical - red).")
  184. (license gpl2)))
  185. (define-public wmnd
  186. (package
  187. (name "wmnd")
  188. (version "0.4.17")
  189. (source (origin
  190. (method url-fetch)
  191. (uri (string-append
  192. "http://www.thregr.org/~wavexx/software/wmnd/releases/"
  193. name "-" version ".tar.gz"))
  194. (sha256
  195. (base32
  196. "1amkbiwgr31gwkcp7wrjsr7aj1kns8bpmjpv70n86wb8v9mpm828"))))
  197. (build-system gnu-build-system)
  198. (inputs
  199. `(("libx11" ,libx11)
  200. ("libxext" ,libxext)
  201. ("libxpm" ,libxpm)))
  202. (native-inputs
  203. `(("pkg-config" ,pkg-config)))
  204. (home-page "http://www.thregr.org/~wavexx/software/wmnd/")
  205. (synopsis "Network interface monitor")
  206. (description
  207. "WMND is a dockapp for monitoring network interfaces under WindowMaker and
  208. other compatible window managers.")
  209. (license gpl2+)))
  210. (define-public wmcpuload
  211. (package
  212. (name "wmcpuload")
  213. (version "1.1.1")
  214. (source (origin
  215. (method url-fetch)
  216. (uri (string-append
  217. "mirror://debian/pool/main/w/wmcpuload/"
  218. name "_" version ".orig.tar.gz"))
  219. (sha256
  220. (base32
  221. "1334y0axnxydwv05d172f405iljrfakg4kcyg9kmn46v6ywv424g"))))
  222. (build-system gnu-build-system)
  223. (inputs
  224. `(("libx11" ,libx11)
  225. ("libxext" ,libxext)
  226. ("libxpm" ,libxpm)))
  227. (native-inputs
  228. `(("pkg-config" ,pkg-config)))
  229. (home-page "http://www.dockapps.net/wmcpuload")
  230. (synopsis "Monitor CPU usage")
  231. (description
  232. "Wmcpuload displays the current CPU usage, expressed as a percentile and a
  233. chart, and has an LCD look-alike user interface. The back-light may be turned
  234. on and off by clicking the mouse button over the application. If the CPU usage
  235. hits a certain threshold, an alarm-mode will alert you by turning back-light
  236. on.")
  237. (license gpl2+)))
  238. (define-public wmclock
  239. (package
  240. (name "wmclock")
  241. (version "1.0.16")
  242. (source (origin
  243. (method url-fetch)
  244. (uri (string-append
  245. "mirror://debian/pool/main/w/wmclock/"
  246. name "_" version ".orig.tar.gz"))
  247. (sha256
  248. (base32
  249. "1lx276ba8r2yydhmwj1g586jdqg695ad89ng36fr3mb067gvb2rz"))))
  250. (build-system gnu-build-system)
  251. (inputs
  252. `(("libx11" ,libx11)
  253. ("libxext" ,libxext)
  254. ("libxpm" ,libxpm)))
  255. ;; wmclock requires autoreconf to generate its configure script.
  256. (native-inputs
  257. `(("autoconf" ,autoconf)
  258. ("automake" ,automake)
  259. ("pkg-config" ,pkg-config)))
  260. (home-page "http://www.dockapps.net/wmclock")
  261. (synopsis "Display the date and time")
  262. (description
  263. "wmclock is an applet for Window Maker which displays the date and time in
  264. a dockable tile. It features multiple language support, 24h or 12h time
  265. display, and can run a user-specified program on mouse click.")
  266. (license gpl2+)))
  267. (define-public wmfire
  268. (package
  269. (name "wmfire")
  270. (version "1.2.4")
  271. (source (origin
  272. (method url-fetch)
  273. (uri (string-append "http://www.improbability.net/"
  274. name "/" name "-" version ".tar.gz"))
  275. (sha256
  276. (base32
  277. "101grahd80n97y2dczb629clmcgiavdpbbwy78kk5wgs362m12z3"))
  278. (patches
  279. (search-patches "wmfire-update-for-new-gdk-versions.patch"))))
  280. (build-system gnu-build-system)
  281. (inputs
  282. `(("gtk+" ,gtk+-2)
  283. ("libgtop" ,libgtop)))
  284. (native-inputs
  285. `(("pkg-config" ,pkg-config)))
  286. (home-page "http://www.improbability.net/")
  287. (synopsis "Display flames to represent resource usage")
  288. (description
  289. "wmfire is an applet for Window Maker that can monitor the average cpu
  290. load, or individual cpu load on SMP computers. Additionally it can monitor the
  291. memory, network load, a file or just be set to show a pretty flame. On
  292. entering the dock a burning spot replaces the cursor, and after two seconds
  293. symbols to represent the current monitor are \"burnt\" onscreen. The flame
  294. colour can also be changed.")
  295. (license gpl2+)))