gkrellm.scm 2.4 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
  3. ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
  4. ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
  5. ;;;
  6. ;;; This file is part of GNU Guix.
  7. ;;;
  8. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  9. ;;; under the terms of the GNU General Public License as published by
  10. ;;; the Free Software Foundation; either version 3 of the License, or (at
  11. ;;; your option) any later version.
  12. ;;;
  13. ;;; GNU Guix is distributed in the hope that it will be useful, but
  14. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  15. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  16. ;;; GNU General Public License for more details.
  17. ;;;
  18. ;;; You should have received a copy of the GNU General Public License
  19. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  20. (define-module (gnu packages gkrellm)
  21. #:use-module ((guix licenses) #:prefix license:)
  22. #:use-module (guix packages)
  23. #:use-module (guix download)
  24. #:use-module (guix build-system gnu)
  25. #:use-module (gnu packages gettext)
  26. #:use-module (gnu packages gtk)
  27. #:use-module (gnu packages pkg-config)
  28. #:use-module (gnu packages xorg))
  29. (define-public gkrellm
  30. (package
  31. (name "gkrellm")
  32. (version "2.3.10")
  33. (source
  34. (origin
  35. (method url-fetch)
  36. (uri (string-append "http://gkrellm.srcbox.net/releases/gkrellm-"
  37. version ".tar.bz2"))
  38. (sha256
  39. (base32
  40. "0rnpzjr0ys0ypm078y63q4aplcgdr5nshjzhmz330n6dmnxci7lb"))))
  41. (build-system gnu-build-system)
  42. (inputs
  43. `(("gettext" ,gettext-minimal)
  44. ("gtk+" ,gtk+-2)
  45. ("libice" ,libice)
  46. ("libsm" ,libsm)))
  47. (native-inputs
  48. `(("pkg-config" ,pkg-config)))
  49. (arguments
  50. `(#:tests? #f ; there is no check target
  51. #:phases
  52. (modify-phases %standard-phases
  53. (delete 'configure)) ; no configure script
  54. #:make-flags
  55. (let ((out (assoc-ref %outputs "out")))
  56. (list (string-append "INSTALLROOT=" out)
  57. "CC=gcc"))))
  58. (home-page "http://gkrellm.srcbox.net/")
  59. (synopsis "System monitors")
  60. (description
  61. "GKrellM is a single process stack of system monitors which supports
  62. applying themes to match its appearance to your window manager, Gtk, or any
  63. other theme.")
  64. (license license:gpl3+)))