fvwm.scm 3.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
  3. ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
  4. ;;; Copyright © 2017 Nils Gillmann <ng0@n0.is>
  5. ;;;
  6. ;;; This file is part of GNU Guix.
  7. ;;;
  8. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  9. ;;; under the terms of the GNU General Public License as published by
  10. ;;; the Free Software Foundation; either version 3 of the License, or (at
  11. ;;; your option) any later version.
  12. ;;;
  13. ;;; GNU Guix is distributed in the hope that it will be useful, but
  14. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  15. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  16. ;;; GNU General Public License for more details.
  17. ;;;
  18. ;;; You should have received a copy of the GNU General Public License
  19. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  20. (define-module (gnu packages fvwm)
  21. #:use-module ((guix licenses) #:select (gpl2+))
  22. #:use-module (guix packages)
  23. #:use-module (guix download)
  24. #:use-module (guix build-system gnu)
  25. #:use-module (gnu packages fribidi)
  26. #:use-module (gnu packages gnome)
  27. #:use-module (gnu packages image)
  28. #:use-module (gnu packages perl)
  29. #:use-module (gnu packages pkg-config)
  30. #:use-module (gnu packages readline)
  31. #:use-module (gnu packages xml)
  32. #:use-module (gnu packages xorg))
  33. (define-public fvwm
  34. (package
  35. (name "fvwm")
  36. (version "2.6.8")
  37. (source (origin
  38. (method url-fetch)
  39. (uri (string-append
  40. "https://github.com/fvwmorg/fvwm/releases/download/"
  41. version "/" name "-" version ".tar.gz"))
  42. (sha256
  43. (base32
  44. "0hgkkdzcqjnaabvv9cnh0bz90nnjskbhjg9qnzpi2x0mbliwjdpv"))))
  45. (build-system gnu-build-system)
  46. (arguments
  47. `(#:phases
  48. (modify-phases %standard-phases
  49. (add-after 'install 'install-xsession
  50. (lambda* (#:key outputs #:allow-other-keys)
  51. (let* ((out (assoc-ref outputs "out"))
  52. (xsessions (string-append out "/share/xsessions")))
  53. (mkdir-p xsessions)
  54. (with-output-to-file
  55. (string-append xsessions "/fvwm2.desktop")
  56. (lambda _
  57. (format #t
  58. "[Desktop Entry]~@
  59. Name=FVWM~@
  60. Comment=FVWM~@
  61. Exec=~a/bin/fvwm~@
  62. TryExec=~@*~a/bin/fvwm~@
  63. Icon=~@
  64. Type=Application~%"
  65. out))))
  66. #t)))))
  67. (native-inputs
  68. `(("perl" ,perl)
  69. ("pkg-config" ,pkg-config)
  70. ("xsltproc" ,libxslt)))
  71. (inputs
  72. `(("fribidi" ,fribidi)
  73. ("libpng" ,libpng)
  74. ("librsvg" ,librsvg)
  75. ("libxcursor" ,libxcursor)
  76. ("libxext" ,libxext)
  77. ("libxft" ,libxft)
  78. ("libxinerama" ,libxinerama)
  79. ("libxpm" ,libxpm)
  80. ("libxt" ,libxt)
  81. ("readline" ,readline)))
  82. (synopsis "Virtual window manager for X11")
  83. (description
  84. "FVWM is an extremely powerful ICCCM-compliant multiple virtual desktop
  85. window manager for the X Window system.")
  86. (home-page "http://www.fvwm.org/")
  87. (license gpl2+)))