123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362 |
- ;;; GNU Guix --- Functional package management for GNU
- ;;; Copyright © 2013, 2014, 2015, 2016, 2017 Ludovic Courtès <ludo@gnu.org>
- ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
- ;;; Copyright © 2014 Taylan Ulrich Bayirli/Kammer <taylanbayirli@gmail.com>
- ;;; Copyright © 2014, 2015, 2016, 2017, 2018 Mark H Weaver <mhw@netris.org>
- ;;; Copyright © 2014, 2015, 2016, 2017 Alex Kost <alezost@gmail.com>
- ;;; Copyright © 2016, 2018 Arun Isaac <arunisaac@systemreboot.net>
- ;;; Copyright © 2016 Federico Beffa <beffa@fbengineering.ch>
- ;;; Copyright © 2016 David Thompson <dthompson2@worcester.edu>
- ;;; Copyright © 2016 Nils Gillmann <ng0@n0.is>
- ;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
- ;;; Copyright © 2017 Maxim Cournoyer <maxim.cournoyer@gmail.com>
- ;;; Copyright © 2017 Alex Vong <alexvong1995@gmail.com>
- ;;; Copyright © 2017, 2018 Ricardo Wurmus <rekado@elephly.net>
- ;;; Copyright © 2017 Jan Nieuwenhuizen <janneke@gnu.org>
- ;;; Copyright © 2018 Efraim Flashner <efraim@flashner.co.il>
- ;;; Copyright © 2018 Mathieu Othacehe <m.othacehe@gmail.com>
- ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
- ;;;
- ;;; This file is part of GNU Guix.
- ;;;
- ;;; GNU Guix is free software; you can redistribute it and/or modify it
- ;;; under the terms of the GNU General Public License as published by
- ;;; the Free Software Foundation; either version 3 of the License, or (at
- ;;; your option) any later version.
- ;;;
- ;;; GNU Guix is distributed in the hope that it will be useful, but
- ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
- ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- ;;; GNU General Public License for more details.
- ;;;
- ;;; You should have received a copy of the GNU General Public License
- ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
- (define-module (gnu packages emacs)
- #:use-module ((guix licenses) #:prefix license:)
- #:use-module (guix packages)
- #:use-module (guix download)
- #:use-module (guix git-download)
- #:use-module (guix build-system gnu)
- #:use-module (guix build-system glib-or-gtk)
- #:use-module (gnu packages)
- #:use-module (gnu packages acl)
- #:use-module (gnu packages autotools)
- #:use-module (gnu packages base)
- #:use-module (gnu packages compression)
- #:use-module (gnu packages fontutils)
- #:use-module (gnu packages fribidi)
- #:use-module (gnu packages gd)
- #:use-module (gnu packages gettext)
- #:use-module (gnu packages glib)
- #:use-module (gnu packages gnome) ; for librsvg
- #:use-module (gnu packages gtk)
- #:use-module (gnu packages guile)
- #:use-module (gnu packages image)
- #:use-module (gnu packages imagemagick)
- #:use-module (gnu packages linux) ; alsa-lib
- #:use-module (gnu packages ncurses)
- #:use-module (gnu packages pkg-config)
- #:use-module (gnu packages texinfo)
- #:use-module (gnu packages tls)
- #:use-module (gnu packages webkit)
- #:use-module (gnu packages xml)
- #:use-module (gnu packages xorg)
- #:use-module (guix utils)
- #:use-module (srfi srfi-1))
- (define-public emacs
- (package
- (name "emacs")
- (version "26.1")
- (source (origin
- (method url-fetch)
- (uri (string-append "mirror://gnu/emacs/emacs-"
- version ".tar.xz"))
- (sha256
- (base32
- "0b6k1wq44rc8gkvxhi1bbjxbz3cwg29qbq8mklq2az6p1hjgrx0w"))
- (patches (search-patches "emacs-exec-path.patch"
- "emacs-fix-scheme-indent-function.patch"
- "emacs-source-date-epoch.patch"))
- (modules '((guix build utils)))
- (snippet
- ;; Delete the bundled byte-compiled elisp files and
- ;; generated autoloads.
- '(with-directory-excursion "lisp"
- (for-each delete-file
- (append (find-files "." "\\.elc$")
- (find-files "." "loaddefs\\.el$")
- ;; This is the only "autoloads" file that
- ;; does not have "*loaddefs.el" name.
- '("eshell/esh-groups.el")))
- ;; Make sure Tramp looks for binaries in the right places on
- ;; remote GuixSD machines, where 'getconf PATH' returns
- ;; something bogus.
- (substitute* "net/tramp-sh.el"
- ;; Patch the line after "(defcustom tramp-remote-path".
- (("\\(tramp-default-remote-path")
- (format #f "(tramp-default-remote-path ~s ~s ~s ~s "
- "~/.guix-profile/bin" "~/.guix-profile/sbin"
- "/run/current-system/profile/bin"
- "/run/current-system/profile/sbin")))
- ;; Make sure Man looks for C header files in the right
- ;; places.
- (substitute* "man.el"
- (("\"/usr/local/include\"" line)
- (string-join
- (list line
- "\"~/.guix-profile/include\""
- "\"/var/guix/profiles/system/profile/include\"")
- " ")))
- #t))))
- (build-system glib-or-gtk-build-system)
- (arguments
- `(#:tests? #f ; no check target
- #:phases
- (modify-phases %standard-phases
- (add-before 'configure 'fix-/bin/pwd
- (lambda _
- ;; Use `pwd', not `/bin/pwd'.
- (substitute* (find-files "." "^Makefile\\.in$")
- (("/bin/pwd")
- "pwd"))
- #t))
- (add-after 'install 'install-site-start
- ;; Use 'guix-emacs' in "site-start.el". This way, Emacs packages
- ;; provided by Guix and installed in
- ;; ~/.guix-profile/share/emacs/site-lisp/guix.d/PACKAGE-VERSION are
- ;; automatically found.
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (lisp-dir (string-append out "/share/emacs/site-lisp")))
- (copy-file (assoc-ref inputs "guix-emacs.el")
- (string-append lisp-dir "/guix-emacs.el"))
- (with-output-to-file (string-append lisp-dir "/site-start.el")
- (lambda ()
- (display
- (string-append "(when (require 'guix-emacs nil t)\n"
- " (guix-emacs-autoload-packages))\n"))))
- #t))))))
- (inputs
- `(("gnutls" ,gnutls)
- ("ncurses" ,ncurses)
- ;; TODO: Add the optional dependencies.
- ("libx11" ,libx11)
- ("gtk+" ,gtk+)
- ("libxft" ,libxft)
- ("libtiff" ,libtiff)
- ("giflib" ,giflib)
- ("libjpeg" ,libjpeg)
- ("imagemagick" ,imagemagick)
- ("acl" ,acl)
- ;; When looking for libpng `configure' links with `-lpng -lz', so we
- ;; must also provide zlib as an input.
- ("libpng" ,libpng)
- ("zlib" ,zlib)
- ("librsvg" ,librsvg)
- ("libxpm" ,libxpm)
- ("libxml2" ,libxml2)
- ("libice" ,libice)
- ("libsm" ,libsm)
- ("alsa-lib" ,alsa-lib)
- ("dbus" ,dbus)
- ;; multilingualization support
- ("libotf" ,libotf)
- ("m17n-lib" ,m17n-lib)))
- (native-inputs
- `(("guix-emacs.el" ,(search-auxiliary-file "emacs/guix-emacs.el"))
- ("pkg-config" ,pkg-config)
- ("texinfo" ,texinfo)))
- (native-search-paths
- (list (search-path-specification
- (variable "INFOPATH")
- (files '("share/info")))))
- (home-page "https://www.gnu.org/software/emacs/")
- (synopsis "The extensible, customizable, self-documenting text editor")
- (description
- "GNU Emacs is an extensible and highly customizable text editor. It is
- based on an Emacs Lisp interpreter with extensions for text editing. Emacs
- has been extended in essentially all areas of computing, giving rise to a
- vast array of packages supporting, e.g., email, IRC and XMPP messaging,
- spreadsheets, remote server editing, and much more. Emacs includes extensive
- documentation on all aspects of the system, from basic editing to writing
- large Lisp programs. It has full Unicode support for nearly all human
- languages.")
- (license license:gpl3+)))
- (define-public emacs-minimal
- ;; This is the version that you should use as an input to packages that just
- ;; need to byte-compile .el files.
- (package (inherit emacs)
- (name "emacs-minimal")
- (synopsis "The extensible text editor (used only for byte-compilation)")
- (build-system gnu-build-system)
- (arguments
- `(#:configure-flags (list "--with-gnutls=no")
- ,@(substitute-keyword-arguments (package-arguments emacs)
- ((#:phases phases)
- `(modify-phases ,phases
- (delete 'install-site-start))))))
- (inputs
- `(("ncurses" ,ncurses)))
- (native-inputs
- `(("pkg-config" ,pkg-config)))))
- (define-public emacs-xwidgets
- (package
- (inherit emacs)
- (name "emacs-xwidgets")
- (synopsis "The extensible, customizable, self-documenting text
- editor (with xwidgets support)")
- (build-system gnu-build-system)
- (arguments
- `(#:configure-flags
- '("--with-xwidgets")
- ,@(package-arguments emacs)))
- (inputs
- `(("webkitgtk" ,webkitgtk)
- ("libxcomposite" ,libxcomposite)
- ,@(package-inputs emacs)))))
- (define-public emacs-no-x
- (package (inherit emacs)
- (name "emacs-no-x")
- (synopsis "The extensible, customizable, self-documenting text
- editor (console only)")
- (build-system gnu-build-system)
- (inputs (fold alist-delete
- (package-inputs emacs)
- '("libx11" "gtk+" "libxft" "libtiff" "giflib" "libjpeg"
- "imagemagick" "libpng" "librsvg" "libxpm" "libice"
- "libsm"
- ;; These depend on libx11, so remove them as well.
- "libotf" "m17n-lib" "dbus")))))
- (define-public emacs-no-x-toolkit
- (package (inherit emacs)
- (name "emacs-no-x-toolkit")
- (synopsis "The extensible, customizable, self-documenting text
- editor (without an X toolkit)" )
- (build-system gnu-build-system)
- (inputs (append `(("inotify-tools" ,inotify-tools))
- (alist-delete "gtk+" (package-inputs emacs))))
- (arguments (append '(#:configure-flags '("--with-x-toolkit=no"))
- (package-arguments emacs)))))
- (define-public guile-emacs
- (package (inherit emacs)
- (name "guile-emacs")
- (version "20150512.41120e0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "git://git.hcoop.net/git/bpt/emacs.git")
- (commit "41120e0f595b16387eebfbf731fff70481de1b4b")))
- (file-name (string-append name "-" version "-checkout"))
- (patches (search-patches "guile-emacs-fix-configure.patch"))
- (sha256
- (base32
- "0lvcvsz0f4mawj04db35p1dvkffdqkz8pkhc0jzh9j9x2i63kcz6"))))
- (native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("guile" ,guile-for-guile-emacs)
- ,@(package-native-inputs emacs)))
- (arguments
- (substitute-keyword-arguments `(;; Build fails if we allow parallel build.
- #:parallel-build? #f
- ;; Tests aren't passing for now.
- #:tests? #f
- ,@(package-arguments emacs))
- ((#:phases phases)
- `(modify-phases ,phases
- (add-after 'unpack 'autogen
- (lambda _
- (invoke "sh" "autogen.sh")))
- ;; Build sometimes fails: deps/dispnew.d: No such file or directory
- (add-before 'build 'make-deps-dir
- (lambda _
- (invoke "mkdir" "-p" "src/deps")))))))))
- (define-public m17n-db
- (package
- (name "m17n-db")
- (version "1.8.0")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "mirror://savannah/m17n/m17n-db-"
- version ".tar.gz"))
- (sha256
- (base32
- "0vfw7z9i2s9np6nmx1d4dlsywm044rkaqarn7akffmb6bf1j6zv5"))))
- (build-system gnu-build-system)
- (inputs
- `(("gettext" ,gettext-minimal)))
- (arguments
- `(#:configure-flags
- (list (string-append "--with-charmaps="
- (assoc-ref %build-inputs "libc")
- "/share/i18n/charmaps"))))
- ;; With `guix lint' the home-page URI returns a small page saying
- ;; that your browser does not handle frames. This triggers the "URI
- ;; returns suspiciously small file" warning.
- (home-page "https://www.nongnu.org/m17n/")
- (synopsis "Multilingual text processing library (database)")
- (description "The m17n library realizes multilingualization of
- many aspects of applications. The m17n library represents
- multilingual text as an object named M-text. M-text is a string with
- attributes called text properties, and designed to substitute for
- string in C. Text properties carry any information required to input,
- display and edit the text.
- This package contains the library database.")
- (license license:lgpl2.1+)))
- (define-public m17n-lib
- (package
- (name "m17n-lib")
- (version "1.8.0")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "mirror://savannah/m17n/m17n-lib-"
- version ".tar.gz"))
- (sha256
- (base32
- "0jp61y09xqj10mclpip48qlfhniw8gwy8b28cbzxy8hq8pkwmfkq"))))
- (build-system gnu-build-system)
- (inputs
- `(("fribidi" ,fribidi)
- ("gd" ,gd)
- ("libotf" ,libotf)
- ("libxft" ,libxft)
- ("libxml2" ,libxml2)
- ("m17n-db" ,m17n-db)))
- (arguments
- `(#:parallel-build? #f))
- ;; With `guix lint' the home-page URI returns a small page saying
- ;; that your browser does not handle frames. This triggers the "URI
- ;; returns suspiciously small file" warning.
- (home-page "https://www.nongnu.org/m17n/")
- (synopsis "Multilingual text processing library (runtime)")
- (description "The m17n library realizes multilingualization of
- many aspects of applications. The m17n library represents
- multilingual text as an object named M-text. M-text is a string with
- attributes called text properties, and designed to substitute for
- string in C. Text properties carry any information required to input,
- display and edit the text.
- This package contains the library runtime.")
- (license license:lgpl2.1+)))
|