cook.scm 3.5 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677787980818283
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2014 John Darrington <jmd@gnu.org>
  3. ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
  4. ;;;
  5. ;;; This file is part of GNU Guix.
  6. ;;;
  7. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  8. ;;; under the terms of the GNU General Public License as published by
  9. ;;; the Free Software Foundation; either version 3 of the License, or (at
  10. ;;; your option) any later version.
  11. ;;;
  12. ;;; GNU Guix is distributed in the hope that it will be useful, but
  13. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  14. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  15. ;;; GNU General Public License for more details.
  16. ;;;
  17. ;;; You should have received a copy of the GNU General Public License
  18. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  19. (define-module (gnu packages cook)
  20. #:use-module (guix packages)
  21. #:use-module (guix licenses)
  22. #:use-module (guix download)
  23. #:use-module (gnu packages ed)
  24. #:use-module (gnu packages bison)
  25. #:use-module (gnu packages groff)
  26. #:use-module (gnu packages compression)
  27. #:use-module (guix build-system gnu))
  28. (define-public cook
  29. (package
  30. (name "cook")
  31. (version "2.34")
  32. (source
  33. (origin
  34. (method url-fetch)
  35. (uri "http://fossies.org/linux/misc/old/cook-2.34.tar.gz")
  36. (sha256
  37. (base32
  38. "104saqnqql1l7zr2pm3f718fdky3ds8j07c6xvwrs1rfkhrw58yw"))))
  39. (build-system gnu-build-system)
  40. (arguments
  41. `(#:parallel-build? #f ; There are some nasty racy rules in the Makefile.
  42. #:phases
  43. (modify-phases %standard-phases
  44. (add-before 'configure 'pre-conf
  45. (lambda _
  46. (substitute* (append '("common/env.c")
  47. (find-files "test" "\\.sh"))
  48. (("/bin/sh") (which "sh")))
  49. ;; Guix's binutils (because it wants bit-reproducable builds) is
  50. ;; is configured with the --enable-deterministic-archives flag.
  51. ;; This means the timestamp of files appended to an ar archive
  52. ;; are automatically and silently mutated to 00:00 1 Jan 1970
  53. ;; which plays havoc with this test, for which correct timestamps
  54. ;; are very important. Adding the U flag undoes the effect of
  55. ;; --enable-deterministic-archives and allows this test to work
  56. ;; again.
  57. (substitute* "test/00/t0077a.sh"
  58. (("ar qc") "ar qcU"))
  59. (setenv "SH" (which "sh"))
  60. #t)))))
  61. (native-inputs `(("bison" ,bison)
  62. ;; For building the documentation:
  63. ("groff" ,groff)
  64. ;; For the tests:
  65. ("sharutils" ,sharutils)
  66. ;; One test wants rsh. However there is no rsh server
  67. ;; running in the build environment and so far as I'm
  68. ;; aware, it cannot be started without root.
  69. ;; This test is therefore just skipped.
  70. ;; ("inetutils" ,inetutils)
  71. ("ed" ,ed)))
  72. (home-page "http://miller.emu.id.au/pmiller/software/cook")
  73. (synopsis "Tool for constructing files")
  74. (description "Cook is a tool for constructing files. It is given a set of
  75. files to create, and recipes of how to create them. In any non-trivial program
  76. there will be prerequisites to performing the actions necessary to creating
  77. any file, such as include files. Cook provides a mechanism to define these.")
  78. (license gpl3+)))