sunxi-sources-6.9.1.ebuild 965 B

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253
  1. # Copyright 1999-2024 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="8"
  4. ETYPE="sources"
  5. K_WANT_GENPATCHES="base extras experimental"
  6. K_GENPATCHES_VER="2"
  7. #K_DEFCONFIG="orangepi_lite_defconfig"
  8. K_SECURITY_UNSUPPORTED=1
  9. EXTRAVERSION="-${PN}/-*"
  10. #K_EXP_GENPATCHES_NOUSE=1
  11. K_DEBLOB_AVAILABLE=0
  12. PV_MY="$(ver_cut 1-2)"
  13. inherit kernel-2 linux-info
  14. detect_version
  15. detect_arch
  16. KEYWORDS="arm arm64"
  17. HOMEPAGE="https://xff.cz/kernels/"
  18. IUSE="experimental"
  19. DESCRIPTION="Full sources including the Gentoo patchset for the Allwiner Sunxi boards"
  20. SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI}"
  21. RESTRICT="mirror"
  22. #UNIPATCH_EXCLUDE="
  23. # 10*
  24. # 15*
  25. # 2400
  26. # 29*
  27. # 1700*
  28. # 3000
  29. # 4567
  30. #"
  31. src_unpack() {
  32. kernel-2_src_unpack
  33. eapply -s "${FILESDIR}/${P}-all.patch"
  34. }
  35. pkg_postinst() {
  36. kernel-2_pkg_postinst
  37. einfo "For more info on this patchset, see:"
  38. einfo "${HOMEPAGE}/${PV_MY}/README"
  39. }
  40. pkg_postrm() {
  41. kernel-2_pkg_postrm
  42. }