it87-driver-20240922.ebuild 1.2 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455
  1. # Copyright 1999-2024 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. inherit linux-mod-r1
  5. MODULES_KERNEL_MAX=6.12
  6. MODULES_KERNEL_MIN=2.6.19
  7. COMMIT="213db3aa999e9cb14d8b9a7f84d711e15d2619f6"
  8. DESCRIPTION="Driver for it87/it86 series hardware monitoring chips."
  9. HOMEPAGE="https://github.com/frankcrawford/it87"
  10. SRC_URI="https://github.com/frankcrawford/it87/archive/${COMMIT}.tar.gz -> it87-${PV}.tar.gz"
  11. SLOT="0"
  12. LICENSE="GPL-2"
  13. KEYWORDS="~x86 ~amd64"
  14. DEPEND="virtual/linux-sources"
  15. RDEPEND="!<sys-kernel/it87-driver-${PV}"
  16. S="${WORKDIR}/it87-${COMMIT}"
  17. RESTRICT="mirror bindist"
  18. pkg_setup() {
  19. linux-mod-r1_pkg_setup
  20. CONFIG_CHECK=""
  21. CONFIG_CHECK2=""
  22. }
  23. src_compile() {
  24. local modlist=( it87=kernel/drivers/hwmon:. )
  25. local modargs=(
  26. KERNELDIR="${KV_OUT_DIR}"
  27. TARGET=${KV_FULL}
  28. KERNEL_BUILD=${KERNEL_DIR}
  29. )
  30. linux-mod-r1_src_compile
  31. }
  32. pkg_postinst() {
  33. linux-mod-r1_pkg_postinst
  34. einfo "If module it87 fails to load at boot, and a manual insertion with modprobe"
  35. einfo "results in a device or resource busy error, you likely need to add"
  36. einfo "'acpi_enforce_resources=lax' to your kernel boot paramaters. Grub users"
  37. einfo "can do this in /etc/default/grub with the GRUB_CMDLINE_LINUX variable."
  38. }