coreutils-bsd-20240108.ebuild 998 B

123456789101112131415161718192021222324252627282930313233343536373839404142434445
  1. # Copyright 1999-2024 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. inherit toolchain-funcs
  5. DESCRIPTION="Standard BSD utilities"
  6. HOMEPAGE="https://github.com/dcantrell/bsdutils"
  7. SRC_URI="https://github.com/matijaskala/${PN}/archive/52ecd743ee01a094f9d533a2745b4882a2363a52.tar.gz -> ${P}.tar.gz"
  8. LICENSE="BSD"
  9. SLOT="0"
  10. KEYWORDS="amd64 x86 arm64 arm mips mipsel"
  11. IUSE=""
  12. RESTRICT="mirror"
  13. DEPEND="
  14. dev-libs/libbsd
  15. sys-libs/fts-standalone
  16. "
  17. RDEPEND="${DEPEND}
  18. !sys-apps/coreutils
  19. !sys-apps/net-tools[hostname]
  20. !sys-apps/util-linux[kill]
  21. !sys-apps/which
  22. !sys-process/procps[kill]"
  23. src_prepare() {
  24. default
  25. tc-export CC CXX
  26. tc-export_build_env BUILD_CC
  27. #use elibc_musl && export LDLIBS+=" -lfts"
  28. #sed -i s@md5@@ Makefile || die
  29. use elibc_musl && append-ldflags -Wl,--whole-archive -Wl,-lcompat_time32 -Wl,--no-whole-archive
  30. }
  31. src_install() {
  32. default
  33. rm -f "${D}"/usr/bin/groups || die
  34. rm -f "${D}"/usr/share/man/man1/groups.1 || die
  35. }