swaynagmode-0.2.1.ebuild 472 B

12345678910111213141516171819202122232425262728293031
  1. # Copyright 2022 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. DESCRIPTION="Control swaynag via keyboard shortcuts"
  5. HOMEPAGE="https://github.com/b0o/swaynagmode"
  6. SRC_URI="https://github.com/b0o/${PN}/archive/v${PV}.tar.gz"
  7. LICENSE="GPL-3"
  8. SLOT="0"
  9. KEYWORDS="~x86 ~amd64"
  10. DEPEND="
  11. gui-wm/sway
  12. app-shells/bash
  13. "
  14. RDEPEND="${DEPEND}"
  15. BDEPEND=""
  16. RESTRICT="mirror"
  17. src_compile() {
  18. :
  19. }
  20. src_install() {
  21. dobin ${PN}
  22. default
  23. }