fnott-9999.ebuild 1.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657
  1. # Copyright 1999-2024 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. inherit meson toolchain-funcs
  5. DESCRIPTION="Keyboard driven and lightweight Wayland notification daemon."
  6. HOMEPAGE="https://codeberg.org/dnkl/fnott"
  7. if [[ "${PV}" == "9999" ]]; then
  8. inherit git-r3
  9. EGIT_REPO_URI="https://codeberg.org/dnkl/fnott.git"
  10. else
  11. SRC_URI="https://codeberg.org/dnkl/fnott/archive/${PV}.tar.gz -> ${P}.tar.gz"
  12. S="${WORKDIR}/${PN}"
  13. KEYWORDS="~amd64 ~x86 ~arm ~arm64"
  14. fi
  15. IUSE="doc zsh-completion test"
  16. RESTRICT="mirror"
  17. LICENSE="MIT ZLIB"
  18. SLOT="0"
  19. DEPEND="
  20. x11-libs/pixman
  21. media-libs/libpng
  22. dev-libs/wayland
  23. sys-apps/dbus
  24. media-libs/fcft
  25. media-libs/freetype
  26. media-libs/fontconfig
  27. "
  28. RDEPEND="${DEPEND}
  29. "
  30. BDEPEND="
  31. dev-util/wayland-scanner
  32. dev-libs/wayland-protocols
  33. doc? ( app-text/scdoc )
  34. dev-libs/tllist
  35. "
  36. src_prepare() {
  37. default
  38. tc-is-cross-compiler && ( sed "/wscanner\./s@native\: true@native\: false@" -i meson.build || die "Sed failed..." )
  39. use doc || ( sed "/subdir('doc')/d" -i meson.build || die "Sed failed..." )
  40. use zsh-completion || ( sed "/subdir('completions')/d" -i meson.build || die "Sed failed..." )
  41. }
  42. src_install() {
  43. local DOCS=( CHANGELOG.md README.md LICENSE )
  44. meson_src_install
  45. #use doc || ( rm -r "${ED}/usr/share/doc/${P}" || die )
  46. }