fatrace-0.17.0.ebuild 789 B

123456789101112131415161718192021222324252627282930313233343536373839
  1. # Copyright 2022 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. PYTHON_COMPAT=( python3_{8..10} )
  5. inherit linux-info python-r1 toolchain-funcs
  6. DESCRIPTION="Report file access events from all running processes"
  7. HOMEPAGE="https://github.com/martinpitt/fatrace"
  8. SRC_URI="https://github.com/martinpitt/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
  9. LICENSE="GPL-3"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~x86"
  12. IUSE="man doc powertop"
  13. RDEPEND="powertop? ( ${PYTHON_DEPS} )"
  14. DEPEND="${RDEPEND}"
  15. REQUIRED_USE="powertop? ( ${PYTHON_REQUIRED_USE} )"
  16. RESTRICT="mirror"
  17. CONFIG_CHECK="~FANOTIFY"
  18. src_prepare() {
  19. default
  20. tc-export CC
  21. }
  22. src_install() {
  23. dosbin fatrace
  24. use powertop && dosbin power-usage-report
  25. use man && doman fatrace.1
  26. use doc && dodoc NEWS
  27. }