libvterm-0.3.2-r1.ebuild 822 B

1234567891011121314151617181920212223242526272829303132333435363738394041424344
  1. # Copyright 1999-2023 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. inherit autotools
  5. DESCRIPTION="An abstract library implementation of a VT220/xterm/ECMA-48 terminal emulator"
  6. HOMEPAGE="https://www.leonerd.org.uk/code/libvterm/"
  7. SRC_URI="https://www.leonerd.org.uk/code/${PN}/${P}.tar.gz"
  8. LICENSE="MIT"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~x64-macos"
  11. BDEPEND="
  12. dev-lang/perl
  13. virtual/pkgconfig
  14. "
  15. PATCHES=(
  16. "${FILESDIR}"/${PN}-0.3.2-slibtool.patch # 779034
  17. )
  18. src_prepare() {
  19. default
  20. eautoreconf
  21. }
  22. src_compile() {
  23. emake VERBOSE=1
  24. }
  25. src_test() {
  26. emake VERBOSE=1 test
  27. }
  28. src_install() {
  29. emake VERBOSE=1 DESTDIR="${D}" install
  30. find "${ED}" -name '*.la' -delete || die "Failed to prune libtool files"
  31. find "${ED}" -name '*.a' -delete || die
  32. }