wsdd2-1.8.ebuild 825 B

123456789101112131415161718192021222324252627282930313233343536373839
  1. # Copyright 1999-2023 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. inherit toolchain-funcs systemd
  5. DESCRIPTION="WSD/LLMNR Discovery/Name Service Daemon"
  6. HOMEPAGE="https://github.com/kochinc/wsdd2"
  7. SRC_URI="https://github.com/kochinc/${PN}/archive/refs/heads/master.tar.gz -> ${P}.tar.gz"
  8. LICENSE="GPL-3"
  9. SLOT="0"
  10. IUSE="systemd man"
  11. KEYWORDS="~amd64 ~arm ~x86 ~mips"
  12. RESTRICT="mirror"
  13. S="${WORKDIR}/${PN}-master"
  14. DEPEND=""
  15. src_compile() {
  16. emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" ${PN}
  17. }
  18. src_install() {
  19. dosbin ${PN}
  20. if use "systemd"; then
  21. systemd_dounit "${PN}.service"
  22. systemd_enable_service "system-services.target" "${PN}.service"
  23. fi
  24. use "man" && doman "${S}/${PN}.8"
  25. }
  26. pkg_postinst() {
  27. elog "WSD daemon is part of smbd service.\nRun: /usr/sbin/wsdd2"
  28. }