Th3inspector-9999.ebuild 1.0 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647
  1. # Copyright 1999-2018 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. inherit git-r3 edos2unix
  5. DESCRIPTION="All in one tool for Information Gathering"
  6. HOMEPAGE="https://fb.me/mohamed.riahi.official.account"
  7. if [[ ${PV} == "9999" ]]; then
  8. EGIT_REPO_URI="https://github.com/Moham3dRiahi/Th3inspector"
  9. fi
  10. LICENSE="MIT"
  11. SLOT="0"
  12. IUSE=""
  13. DEPEND="
  14. dev-perl/JSON
  15. dev-lang/perl
  16. dev-vcs/git
  17. "
  18. src_prepare() {
  19. if [[ ${PV} == "9999" ]] ; then
  20. local ver="git-${EGIT_VERSION:0:6}"
  21. #sed -i "/^GITVER[[:space:]]*=/s:=.*:=${ver}:" mk/git.mk || die
  22. einfo "Producing ChangeLog from Git history"
  23. GIT_DIR="${S}/.git" git log >"${S}"/ChangeLog
  24. fi
  25. # Allow user patches to be applied without modifying the ebuild
  26. eapply_user
  27. edos2unix $(find ${S} -type 'f')
  28. }
  29. src_install() {
  30. dodir /usr/share/Th3inspector
  31. insinto /usr/share/Th3inspector
  32. doins Th3inspector.pl
  33. fperms 0755 /usr/share/Th3inspector/Th3inspector.pl
  34. dosym /usr/share/Th3inspector/Th3inspector.pl /usr/bin/Th3inspector
  35. }