mulish-3.6.0.ebuild 767 B

12345678910111213141516171819202122232425262728293031
  1. # Copyright 1999-2023 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. inherit font
  5. DESCRIPTION="Sans serif font by Vernon Adams"
  6. HOMEPAGE="https://github.com/googlefonts/mulish"
  7. EGIT_COMMIT="ab3f1c59394dafbc6cb55feec2135d6116476142"
  8. SRC_URI="https://github.com/googlefonts/${PN}/archive/${EGIT_COMMIT}.tar.gz -> ${PN}-${EGIT_COMMIT}.tar.gz"
  9. IUSE="+otf +ttf"
  10. REQUIRED_USE="|| ( otf ttf )"
  11. LICENSE="|| ( LGPL-2.1 OFL-1.1 )"
  12. SLOT="0"
  13. KEYWORDS="*"
  14. # No binaries, only fonts
  15. RESTRICT="strip binchecks mirror"
  16. S="${WORKDIR}/${PN}-${EGIT_COMMIT}"
  17. DOCS="README.md"
  18. src_install() {
  19. use otf && FONT_S="${S}/fonts/otf" FONT_SUFFIX="otf" font_src_install
  20. use ttf && FONT_S="${S}/fonts/ttf" FONT_SUFFIX="ttf" font_src_install
  21. }