wxedid-0.0.29.ebuild 797 B

1234567891011121314151617181920212223242526272829303132333435363738394041
  1. # Copyright 1999-2023 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. WX_GTK_VER=3.2-gtk3
  5. inherit toolchain-funcs wxwidgets desktop
  6. DESCRIPTION="wxWidgets-based EDID (Extended Display Identification Data) editor"
  7. HOMEPAGE="https://wxedid.sourceforge.io"
  8. SRC_URI="mirror://sourceforge/${PN}/${PN}-${PV}.tar.gz"
  9. LICENSE="GPL-3"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~riscv ~x86"
  12. IUSE=""
  13. RESTRICT="mirror"
  14. BDEPEND="
  15. x11-libs/wxGTK:${WX_GTK_VER}
  16. "
  17. QA_PRESTRIPPED="usr/bin/wxedid"
  18. S="${WORKDIR}/${PN}-${PV}"
  19. PATCHES=(
  20. "${FILESDIR}"/${PN}_xdg_cfg.patch
  21. )
  22. pkg_setup() {
  23. setup-wxwidgets
  24. }
  25. src_install() {
  26. default
  27. insinto /usr/share/applications
  28. domenu "${FILESDIR}/net.sourceforge.wxEDID.desktop"
  29. doicon -s scalable "${FILESDIR}/net.sourceforge.wxEDID.svg"
  30. }