rofi-calc-9999.ebuild 822 B

12345678910111213141516171819202122232425262728293031323334353637383940414243444546
  1. # Copyright 1999-2024 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. WANT_LIBTOOL="none"
  5. inherit autotools
  6. DESCRIPTION="Do live calculations in rofi!"
  7. HOMEPAGE="https://github.com/svenstaro/rofi-calc"
  8. if [[ ${PV} = *9999 ]]; then
  9. inherit git-r3
  10. EGIT_REPO_URI="https://github.com/svenstaro/rofi-calc.git"
  11. EGIT_SUBMODULES=()
  12. KEYWORDS=""
  13. else
  14. SRC_URI="https://github.com/svenstaro/rofi-calc/archive/v${PV}.tar.gz -> ${P}.tar.gz"
  15. KEYWORDS="~amd64 ~x86 ~arm ~arm64"
  16. fi
  17. LICENSE="MIT"
  18. SLOT="0"
  19. IUSE=""
  20. RESTRICT="mirror"
  21. DEPEND="
  22. gui-apps/rofi
  23. >=sci-libs/libqalculate-2.0
  24. "
  25. RDEPEND="${DEPEND}"
  26. PATCHES=(
  27. "${FILESDIR}/${PN}-2.2.1-add-to-history-hint.patch"
  28. )
  29. src_prepare() {
  30. default
  31. eautoreconf -i
  32. }
  33. src_install() {
  34. default
  35. find "${ED}" -name '*.la' -delete || die
  36. }