xkb-switch-9999.ebuild 831 B

12345678910111213141516171819202122232425262728293031323334
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. # $Id$
  4. EAPI=8
  5. inherit cmake multilib
  6. DESCRIPTION="Switch your X keyboard layouts from the command line"
  7. HOMEPAGE="https://github.com/ierton/xkb-switch"
  8. if [[ ${PV} = 9999* ]]; then
  9. inherit git-r3
  10. SRC_URI=""
  11. EGIT_REPO_URI="https://github.com/ierton/xkb-switch"
  12. KEYWORDS=""
  13. else
  14. SRC_URI="https://github.com/grwlf/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
  15. KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
  16. fi
  17. LICENSE="GPL-3"
  18. SLOT="0"
  19. IUSE=""
  20. RESTRICT="mirror"
  21. DEPEND="x11-libs/libxkbfile"
  22. RDEPEND="${DEPEND}"
  23. src_prepare() {
  24. # multilib-strict
  25. sed -i -e "s/DESTINATION lib/DESTINATION $(get_libdir)/" CMakeLists.txt
  26. cmake_src_prepare
  27. }